Upgrade to FreeType 2.5.1

Bug #1256114 reported by Michael Kuhn on 2013-11-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
freetype (Ubuntu)
Undecided
Unassigned

Bug Description

I have prepared an update to FreeType 2.5.1 for my PPA and thought I would share it. I have been using it for the last few days and have noticed no regressions.

You can find the .orig.tar.gz here: https://launchpad.net/~suraia/+archive/desktop/+files/freetype_2.5.1.orig.tar.gz

Michael Kuhn (suraia) wrote :

… and here is the .diff.gz.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freetype - 2.5.1-1ubuntu1

---------------
freetype (2.5.1-1ubuntu1) trusty; urgency=low

  * Merge from Debian unstable (LP: #1256114), remaining changes:
    - debian/patches-freetype/revert_scalable_fonts_metric.patch:
      revert commit "Fix metrics on size request for scalable fonts.",
      which breaks gtk underlining markups
  * Dropped changes, included in Debian:
    - debian/control: build-depends on libpng-dev
    - debian/libfreetype6.symbols: new version update
  * Drop debian/patches-ft2demos/compiler-warning-fixes.patch, which is
    actually a bug in the compiler_hardening_fixes.patch and has been fixed
    there in the Ubuntu version.

freetype (2.5.1-1) unstable; urgency=low

  * New upstream release. Closes: #717952, #729231.
    - Add build-dependency on libpng-dev.
    - Dropped patches, included upstream: savannah-bug-35847.patch,
      savannah-bug-35833.patch, savannah-bug-37905.patch,
      savannah-bug-37906.patch, savannah-bug-37907.patch
    - Internal symbols have been dropped in this version. No soname change
      because the symbols are not supposed to be used, but past experience
      suggests that this may break some third-party software anyway.
  * compiler_hardening_fixes.patch: fix wrong snprintf() calls in ttdebug.c
    that cause an overflow 100% of the time.
  * debian/patches-ft2demos/compiler-warning-fixes.patch: Fix a wrong
    cast that triggers a compiler warning.
  * debian/patches-ft2demos/revert-wrong-extern.patch: revert wrong
    upstream commit that causes a build failure.
 -- Steve Langasek <email address hidden> Thu, 28 Nov 2013 23:10:19 +0000

Changed in freetype (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers