freeSpeak reports errors

Bug #459033 reported by Coz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
freespeak (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: freespeak

Hey guys,
  using any of the options in freespeak spits out these errors;

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/intro.py", line 173, in on_text_clicked
    TextTranslation (self.application, self.manager)
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/translation.py", line 51, in __init__
    BaseTranslation.__init__ (self, *args)
  File "/usr/lib/python2.6/dist-packages/freespeak/translation.py", line 170, in __init__
    self.setup ()
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/translation.py", line 158, in setup
    self.setup_label ()
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/translation.py", line 65, in setup_label
    self.label = TranslationLabel (self.application, self)
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/translation_label.py", line 52, in __init__
    self.setup_icon ()
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/translation_label.py", line 68, in setup_icon
    self.icon = Spinner (self.application, None)
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/spinner.py", line 68, in __init__
    self.setup_animation (application)
  File "/usr/lib/python2.6/dist-packages/freespeak/ui/spinner.py", line 59, in setup_animation
    del cls.animation[0]
IndexError: list assignment index out of range

coz

ProblemType: Bug
Architecture: i386
Date: Fri Oct 23 08:26:08 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: freespeak 0.3.0-3
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: freespeak
Uname: Linux 2.6.31-14-generic i686

Revision history for this message
Coz (cosimo321) wrote :
Revision history for this message
Luca Bruno (lucabru) wrote :

Thanks for your report. Looks like you don't have gnome-icon-theme, so you don't have the process-working image. I'll fix that in the next release by shipping the animation within the distribution rather than using the icon theme.

Revision history for this message
Coz (cosimo321) wrote : Re: [Bug 459033] Re: freeSpeak reports errors

On Fri, Oct 23, 2009 at 9:00 AM, Luca Bruno <email address hidden> wrote:

> Thanks for your report. Looks like you don't have gnome-icon-theme, so
> you don't have the process-working image. I'll fix that in the next
> release by shipping the animation within the distribution rather than
> using the icon theme.
>
> --
> freeSpeak reports errors
> https://bugs.launchpad.net/bugs/459033
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hey guy,
 Actually gnome-icon-theme is installed!
could this be something other than that?

coz

Revision history for this message
Luca Bruno (lucabru) wrote : Re: freeSpeak reports errors

On Sat, Oct 24, 2009 at 11:13:00AM -0000, Coz wrote:
> Hey guy,
> Actually gnome-icon-theme is installed!
> could this be something other than that?
>

I think the problem is that it can't find the process-working image in the
theme. Could you try commenting that line? I think it should work. Thanks
for you help.

--
http://www.debian.org - The Universal Operating System

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers