Remmina Crashes with when connecting to some RDP hosts

Bug #971219 reported by Zaphod on 2012-04-02
90
This bug affects 18 people
Affects Status Importance Assigned to Milestone
freerdp (Ubuntu)
Undecided
Unassigned

Bug Description

When connecting to some RDP Hosts Remmina will crash every time they are 2008 server hosts but not all 2008 server hosts have the problem.

[ 2375.493642] remmina[7647]: segfault at 100000018 ip 00007f0db307718c sp 00007f0da4c836f0 error 6 in libfreerdp-core.so.1.0.1[7f0db3060000+42000]
[ 2509.507670] remmina[7727]: segfault at 100000018 ip 00007fe454b6b18c sp 00007fe4467b36f0 error 6 in libfreerdp-core.so.1.0.1[7fe454b54000+42000]

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: remmina 1.0.0-1ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
Date: Mon Apr 2 11:24:51 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: remmina
UpgradeStatus: No upgrade log present (probably fresh install)

Zaphod (vilppu777) wrote :
Zaphod (vilppu777) wrote :

When I changed the security to RDP instead of negotiate under advanced it worked when it would crash every time with a particular host.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in remmina (Ubuntu):
status: New → Confirmed

I even can't connect to some windows 2003 und xp clients per rdp. sometimes it works, sometimes not, even if i change security to rdp. The windows stays black. With Vinagre i don't have this Problems. How can we help to debug the Problem? In 11.04 everythink worked perfekt. (Ubuntu 12.04 lts 64 bit)
Best
Michael

Jean-Louis Dupond (dupondje) wrote :

Its the FreeRDP library that gives issues here.
Remmina uses that lib to make RDP connections.
Assign to FreeRDP

affects: remmina (Ubuntu) → freerdp (Ubuntu)
Thijs Elferink (t-elferink) wrote :

I can confirm comment #2, after changing from negotiate to RDP on all hosts Remmina doesn't crash.
Though I can't be 100% sure because before it almost always crashed but not always.
As far as I can see now, it works.

I can confirm #4, this is what I have been seeing. I have set connections to 'RDP' security rather than negotiate, but I still see black window on connection (until you resize window) and various crashes and disconnects. I too had a perfect experience with 11.04. I'll try downgrading the FreeRDP library.

RyanJ (rjacksland) wrote :

I tried #2 and still was seeing it crash immediately after connecting to a XP SP2 machine. Server 2003 and 2008 were able to connect without issue.

 kernel: [ 816.519723] remmina[6182]: segfault at 120 ip 00007fcbb79a4c2d sp 00007fcbb5d7e720 error 4 in libfreerdp-gdi.so.1.0.1[7fcbb7995000+15000]

RyanJ (rjacksland) wrote :

I am also seeing that the 'Num Lock' is not being transferred through the RDP session. If in Ubuntu the num lock is on, it is off in my rdp sessions and if on in the RDP it is off in Ubuntu. This is all new behavior after the upgrade to 12.04.

The workaround in #2 worked for me

Joshua Buysse (buysse) wrote :

I can see that it's crashing on hosts that have a custom SSL cert that includes subject alternative names, and not on hosts with the default cert from active directory. Here's a backtrace from gdb:
% gdb /usr/bin/xfreerdp
...
(gdb) run -d AD -u buysse REDACTED.umn.edu
Starting program: /usr/bin/xfreerdp -d AD -u buysse REDACTED.umn.edu
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7ffff42a7700 (LWP 21643)]
connected to REDACTED.umn.edu:3389
Password:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff42a7700 (LWP 21643)]
0x00007ffff738918c in crypto_cert_subject_alt_name () from /usr/lib/libfreerdp-core.so.1.0
(gdb) bt
#0 0x00007ffff738918c in crypto_cert_subject_alt_name () from /usr/lib/libfreerdp-core.so.1.0
#1 0x00007ffff739e2bb in tls_verify_certificate () from /usr/lib/libfreerdp-core.so.1.0
#2 0x00007ffff7389579 in credssp_get_public_key () from /usr/lib/libfreerdp-core.so.1.0
#3 0x00007ffff7389f98 in credssp_authenticate () from /usr/lib/libfreerdp-core.so.1.0
#4 0x00007ffff739fc0a in transport_connect_nla () from /usr/lib/libfreerdp-core.so.1.0
#5 0x00007ffff739aaa1 in rdp_client_connect () from /usr/lib/libfreerdp-core.so.1.0
#6 0x00007ffff73962d4 in freerdp_connect () from /usr/lib/libfreerdp-core.so.1.0
#7 0x000000000041034b in xfreerdp_run ()
#8 0x000000000041062c in thread_func ()
#9 0x00007ffff5fd1e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007ffff5cfecbd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()
(gdb) quit

Thiago Martins (martinx) wrote :

Still a problem on Xenial!

Jon Brockway (jdbway) wrote :

I changed the color from 8bpp to 16bpp, but I don't think it caused the crash immediately on the next connection, though I don't remember now. However, once it started crashing, it crashed on every connection attempt. I changed it to 8bpp and then I could connect without a crash. I then changed it back to 16bpp and I am still able to connect.

Boris Malkov (hikari968) wrote :

The problem still persists.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers