remmina/xfreerdp crashes while trying to use 'remote control'

Bug #1000356 reported by urusha
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
freerdp (Ubuntu)
High
Jean-Louis Dupond
Precise
High
Unassigned

Bug Description

[Impact]
Remmina (program that uses freerdp libs) crashes with a segfault.

[Development Fix]
The patch got added in Quantal.
This patch was cherry picked from the freerdp git, so its already upstream.

[Stable Fix]
The patch for this fix has been attached to the bug.

[Test Case]
- Start Remmina
- Conntect to a random RDP server
- Open taskmgr (Task Manager)
- Go to the users, and click 'Remote Control' on a user
=> Now Remmina will crash completely.

[Regression Potential]
This worked fine in the previous default RDP client (rdesktop).
But now we have Remmina (with FreeRDP libs), and it crashes.
----------------------------------------------------------------------

Remmina crashes when I'm trying to use 'remote control' on windows server. It crashes every time within 5 seconds after initiating 'remote control' (in both directions: when remmina's session controls and when it becomes controlled). Tested with rdesktop which doesn't crash.
This bug seems to be similar to https://bugs.launchpad.net/ubuntu/+source/remmina/+bug/633930 (which also affected me earlier with old versions)
But with this issue remmina's session resolution doesn't matter.

xfreerdp also crashes, but only if it becomes controlled. Remote controlling another session seems to work without crashes.

These issues affected every i386, amd64 (l)ubuntu 12.04 installation I tested.

All these issues could have different reasons, so If it's needed I can fill separate bug report per issue.

remmina:
  Installed: 1.0.0-1ubuntu6
  Candidate: 1.0.0-1ubuntu6
  Version table:
 *** 1.0.0-1ubuntu6 0
        500 http://ru.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.0-1ubuntu5 0
        500 http://ru.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

freerdp-x11:
  Installed: 1.0.1-1ubuntu2
  Candidate: 1.0.1-1ubuntu2
  Version table:
 *** 1.0.1-1ubuntu2 0
        500 http://ru.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Filling this bug report and facing others, like https://bugs.launchpad.net/ubuntu/+source/remmina/+bug/937522 , I'm wondering, does ubuntu business remix really support RDP 7.1? (http://www.ubuntu.com/business/desktop/remix)

Thanks.

Revision history for this message
urusha (urusha) wrote :
Revision history for this message
urusha (urusha) wrote :
Revision history for this message
urusha (urusha) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freerdp (Ubuntu):
status: New → Confirmed
Changed in remmina (Ubuntu):
status: New → Confirmed
Revision history for this message
Jean-Louis Dupond (dupondje) wrote :

Hi

Thanks for reporting this.
By doing a "Remote Control" you just mean you connect to RDP?

Is this happening for every RDP connection? Or to some specific versions of Windows?
I'm unable to simulate this, so it would be cool if you could hand me the steps to reproduce this.

Thanks!

Changed in remmina (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
urusha (urusha) wrote :

Hi,
"Remote control" = In terminal session (windows) open Terminal Services Manager (or task manager -> users tab) as admin -> right click on another user's session -> Remote control -> OK
Remmina crashes if you try to control another user session. Remmina and xfreerdp crash if you are tried to control by another user (admin).
Rdesktop works fine in both directions (all tests were made using it on the other side).
Tested with win2k3sp2, win2k8r2. It happens every time.

This feature of rdp is very important for admins. It allows us to support our users. So, I'll be glad to make any tests/traces you need to fix this issues.
Thanks.

Revision history for this message
Jean-Louis Dupond (dupondje) wrote :

Its a FreeRDP lib bug.
Was able to simulate this, and fix is comming!

Changed in remmina (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Jean-Louis Dupond (dupondje)
Changed in freerdp (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Jean-Louis Dupond (dupondje)
Changed in remmina (Ubuntu):
status: In Progress → Invalid
Revision history for this message
Jean-Louis Dupond (dupondje) wrote :

Attached the patch that fixes this issue.
Code cherry picked from upstream.

Michael Terry (mterry)
Changed in remmina (Ubuntu Precise):
status: New → Invalid
no longer affects: remmina (Ubuntu)
no longer affects: remmina (Ubuntu Precise)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freerdp - 1.0.1-1ubuntu3

---------------
freerdp (1.0.1-1ubuntu3) quantal; urgency=low

  [ Jean-Louis Dupond ]
  * debian/patches/remote_control.diff: Cherry pick patch from upstream.
    This fixes crash in 'Remote Control'. (LP: #1000356)

  [ Michael Terry ]
  * debian/*.install: Update for multiarch locations
 -- Michael Terry <email address hidden> Thu, 24 May 2012 14:25:00 -0400

Changed in freerdp (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Michael Terry (mterry) wrote :

Just uploaded an SRU version for precise. This is a good SRU candidate because it crashes on basic functionality, and the patch is direct from upstream trunk.

Revision history for this message
urusha (urusha) wrote :

Hi,

I installed freerdp, remmina from quantal to precise and that's what I've got:

rdesktop 1024x768 -> remmina/xfreerdp 1024x768 - still crashes (see attachments) before crash I can see graphical artifacts (windows that was minimized in rdesktop - still visible in remmina and similar... feels like pixels are cached the wrong way)

remmina 1024x768 -> rdesktop 1024x768 - seems to work fine now
remmina 1024x768 -> rdesktop 800x600 - seems to work fine too
remmina 800x600 -> rdesktop 1024x768 - facing white space on the right and bottom side of the screen, it's clickable (I can run 'start' menu), but it's always white - that's really bad thing, it's mostly unusable... But seems to not crash

remmina/xfreerdp -> rdesktop (with different (higher/lower) from remmina/xfreerdp color depth) - graphical artifacts in the remmina - absolutly unusable. But seems to not crash.

Should I fill another report(s) for that artifact issues?

Revision history for this message
urusha (urusha) wrote :
Revision history for this message
urusha (urusha) wrote :
description: updated
Revision history for this message
Clint Byrum (clint-fewbar) wrote : Please test proposed package

Hello urusha, or anyone else affected,

Accepted freerdp into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in freerdp (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
urusha (urusha) wrote :

Hi. I've just repeated all tests from my comment #12 with proposed build... Results are absolutely the same - remmina/xfreerdp still crashes when it's controlled by rdesktop... So, the proposed build doesn't fix crashes when xfreerdp/remmina is controlled by another client.

And graphical artifacts makes it's unusable in most another cases.
White space (remmina 800x600 -> rdesktop 1024x768) is a remmina problem, xfreerdp works fine.
Please, tell me should I fill another bug report(s) about those artifacts or this will e fixed here, probably?

Revision history for this message
Clint Byrum (clint-fewbar) wrote : Re: [Bug 1000356] Re: remmina/xfreerdp crashes while trying to use 'remote control'

Excerpts from urusha's message of 2012-05-30 05:56:11 UTC:
> Hi. I've just repeated all tests from my comment #12 with proposed
> build... Results are absolutely the same - remmina/xfreerdp still
> crashes when it's controlled by rdesktop... So, the proposed build
> doesn't fix crashes when xfreerdp/remmina is controlled by another
> client.
>
> And graphical artifacts makes it's unusable in most another cases.
> White space (remmina 800x600 -> rdesktop 1024x768) is a remmina problem, xfreerdp works fine.
> Please, tell me should I fill another bug report(s) about those artifacts or this will e fixed here, probably?

The artifacts probably need another bug report.

Is there any possibility you could produce a backtrace to help us narrow
down the problem?

Revision history for this message
urusha (urusha) wrote :

> Is there any possibility you could produce a backtrace to help us narrow
> down the problem?

If you are talking about crashes, backtraces are in my comments #12,13,14 (quantal 'fixed' version). I don't think something is changed with precise, but if it's needed to repeat, just let me know.

Revision history for this message
urusha (urusha) wrote :

Well, here is the bug report about graphical artifacts: https://bugs.launchpad.net/ubuntu/+source/remmina-plugins/+bug/1006300
Could you take a look at it?

Changed in freerdp (Ubuntu):
importance: Undecided → High
Changed in freerdp (Ubuntu Precise):
importance: Undecided → High
Revision history for this message
Sebastien Bacher (seb128) wrote :

what's the status of that update then? is the fix working or should it be dropped from the SRUs queue?

Revision history for this message
urusha (urusha) wrote :

Crashes still take place as I wrote in #12,16. Backtraces of quantal 1.0.1-1ubuntu3 are in #12,13,14.

Revision history for this message
Brian Murray (brian-murray) wrote :

Bug 1008391 is from a user using the package from -proposed and may be a regression.

Revision history for this message
Steve Langasek (vorlon) wrote :

Bug #1008391 is a bug in a non-Ubuntu package; triaged as such.

Still, it seems that this SRU is lacking any evidence that it fixes the bug in question.

Revision history for this message
Steve Langasek (vorlon) wrote :

urusha, you mention that you installed the remmina and freerdp packages from quantal and still got the crash. But you don't mention upgrading the libfreerdp1 package, which is where this bug was fixed. Can you confirm whether you upgraded libfreerdp1? If you didn't, could you please upgrade to the *precise-proposed* version of libfreerdp1, which is the one that we're looking to get tested for SRU so that we can fix this for our 12.04 LTS users?

Revision history for this message
urusha (urusha) wrote :

Steve, I have proposed version installed:

# LANG=C apt-cache policy libfreerdp1
libfreerdp1:
  Installed: 1.0.1-1ubuntu2.1
  Candidate: 1.0.1-1ubuntu2.1
  Version table:
 *** 1.0.1-1ubuntu2.1 0
        200 http://ru.archive.ubuntu.com/ubuntu/ precise-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.1-1ubuntu2 0
        500 http://ru.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

And I still get crashes when remmina client is controlled (is a target of remote control). More info is in my previous comments.
Crashes take place in both precise-proposed and quantal(tested with 1.0.1-1ubuntu3) builds.

Revision history for this message
Steve Langasek (vorlon) wrote :

Considering verification-failed then based on the latest comment. Sorry that this build doesn't fix it, urusha. I've solicited feedback from the uploader; unless there's something else I've overlooked this package should be removed from precise-proposed in the next couple of days.

tags: added: verification-failed
removed: verification-needed
Revision history for this message
Jean-Louis Dupond (dupondje) wrote :

See comment #12:

remmina 1024x768 -> rdesktop 1024x768 - seems to work fine now
remmina 1024x768 -> rdesktop 800x600 - seems to work fine too

Seems like the patch does fix the bug in SOME cases. Its indeed not completely fixed, but some cases seems to work now after the patch.
So I guess its safe to accept this.

tags: added: verification-done
removed: verification-failed
Revision history for this message
Steve Langasek (vorlon) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freerdp - 1.0.1-1ubuntu2.1

---------------
freerdp (1.0.1-1ubuntu2.1) precise-proposed; urgency=low

  * debian/patches/remote_control.diff: Cherry pick patch from upstream.
    This fixes crash in 'Remote Control'. (LP: #1000356)
 -- Jean-Louis Dupond <email address hidden> Thu, 24 May 2012 13:52:13 +0200

Changed in freerdp (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
urusha (urusha) wrote :

Now this bug marked as fixed, but actually it isn't fixed completly. Should I open the new one about its unfixed part?

Revision history for this message
Jean-Louis Dupond (dupondje) wrote :

@Urusha: yes, please file a new bug with a report of whats still broken. Then we can investigate that for you :)

Revision history for this message
urusha (urusha) wrote :

Here is it: https://bugs.launchpad.net/ubuntu/+source/freerdp/+bug/1034802
Please, take a look at it.
Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers