distorted view

Bug #1075102 reported by bartje
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
freeplane (Ubuntu)
Fix Released
Undecided
Felix Natter

Bug Description

Freeplane shows it's map in a distorted way when the view is moved. It get's ok, when moving again, as if there is a refresh issue with the graphics.
In attachment I've added a screenshot of the problem.
I suspect it has something to do with the java integration, since fonts are rendered horribly in all java-applications as well.
It happens when using openjdk and with oracle java.

Revision history for this message
bartje (bart-deruyter) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freeplane (Ubuntu):
status: New → Confirmed
Revision history for this message
Felix Natter (fnatter) wrote :

hi bartje,

As you say it's probably a java issue. Does the problem still occur?

If yes, and a java upgrade (e.g. latest openjdk7) does not help,
please post in our forum and we'll work together to find a solution:
http://sourceforge.net/apps/phpbb/freeplane/viewforum.php?f=1

Best Regards,
Felix

Changed in freeplane (Ubuntu):
assignee: nobody → Felix Natter (fnatter)
Revision history for this message
bartje (bart-deruyter) wrote : Re: [Bug 1075102] Re: distorted view

hi,

yes, it still occurs on 13.04, running KDE and openjdk7
I'll post it on the forum

grtz,

Bart

http://www.bartart3d.be/
On facebook <https://www.facebook.com/pages/BartArt3D/169488999795102>
On Twitter <https://twitter.com/#%21/Bart_Issimo>
On Identi.ca <http://identi.ca/bartart3d>
On Google+ <https://plus.google.com/u/0/b/116379400376517483499/>

2013/6/14 Felix Natter <email address hidden>

> hi bartje,
>
> As you say it's probably a java issue. Does the problem still occur?
>
> If yes, and a java upgrade (e.g. latest openjdk7) does not help,
> please post in our forum and we'll work together to find a solution:
> http://sourceforge.net/apps/phpbb/freeplane/viewforum.php?f=1
>
> Best Regards,
> Felix
>
> ** Changed in: freeplane (Ubuntu)
> Assignee: (unassigned) => Felix Natter (fnatter)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1075102
>
> Title:
> distorted view
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/freeplane/+bug/1075102/+subscriptions
>

Revision history for this message
Felix Natter (fnatter) wrote :

hi Bart,

you could try the fix discussed in this bug report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669712

Best Regards,
Felix

Revision history for this message
bartje (bart-deruyter) wrote :

hi Felix,

this did seem to do the trick :-) and fix the problem.

http://www.bartart3d.be/
On facebook <https://www.facebook.com/pages/BartArt3D/169488999795102>
On Twitter <https://twitter.com/#%21/Bart_Issimo>
On Identi.ca <http://identi.ca/bartart3d>
On Google+ <https://plus.google.com/u/0/b/116379400376517483499/>

2013/6/16 Felix Natter <email address hidden>

> hi Bart,
>
> you could try the fix discussed in this bug report:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669712
>
> Best Regards,
> Felix
>
> ** Bug watch added: Debian Bug tracker #669712
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669712
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1075102
>
> Title:
> distorted view
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/freeplane/+bug/1075102/+subscriptions
>

Revision history for this message
Felix Natter (fnatter) wrote :

hi Bart,

the problem is that this is a problem specific to Radeon graphics cards:
  https://bugs.freedesktop.org/show_bug.cgi?id=50850

Here is the documentation for the setting:
  http://docs.oracle.com/javase/7/docs/technotes/guides/2d/flags.html#xrender

=> I am not sure whether it would break other users' experience if I generally enable this in /usr/bin/freeplane...

Best Regards,
Felix

Revision history for this message
Felix Natter (fnatter) wrote :

hi,

Unfortunately, the XRender pipeline (-Dsun.java2d.xrender=True) can also cause problems (this time when scrolling vertically ;-)
=> therefore the current resolution is not to include this in /usr/bin/freeplane, see here for details:
  https://sourceforge.net/apps/phpbb/freeplane/viewtopic.php?f=1&t=681#p3370

BTW: Bart reported that this is not specific to Radeon graphics cards.

Best Regards,
Felix

Revision history for this message
Felix Natter (fnatter) wrote :

@Ubuntu Maintainer/Bug supervisor: Can we close this bug?
Please see http://sourceforge.net/apps/phpbb/freeplane/viewtopic.php?f=1&t=681&p=3370&hilit=distorted#p3370

Changed in freeplane (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.