SRU: ogre exception when starting - can't load library (no change rebuild)

Bug #1292308 reported by Jason Edgecombe
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
freeorion (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned

Bug Description

SRU:
No source change rebuild is required, just bump debian/changelog to 0.4.3-2build1 for trusty.

test case:
1) try to run freeorion
2) nothing happens

PPA linked below
working test case:
1) try to run freeorion
2) it runs

no chance of regression since nothing works now anyways.

cheers,
Scott

____
On 14.04 (Trusty), freeorion refuses to start and gives the following error:
$ freeorion
CWD: /usr/share/games/freeorion
main() caught exception(std::exception): OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library RenderSystem_GL. System Error: RenderSystem_GL.so: cannot open shared object file: No such file or directory in DynLib::load at /build/buildd/ogre-1.8-1.8.1+dfsg/OgreMain/src/OgreDynLib.cpp (line 93)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: freeorion 0.4.3-2
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Mar 13 22:19:16 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-03-09 (4 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140309)
SourcePackage: freeorion
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Jason Edgecombe (jason-rampaginggeek) wrote :
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I get the same error message when attempting to start freeorion on Ubuntu Trusty. I notice the ogre library in Ubuntu is different (and newer) than the one in Debian. Maybe this can explain the issue?

Changed in freeorion (Ubuntu):
status: New → Confirmed
Revision history for this message
Markus Koschany (apoleon) wrote :

I believe this bug is caused by changes made to Ubuntu's version of Ogre. See also

https://bugs.launchpad.net/ubuntu/+source/ogre-1.8/+bug/1244592

The version of Ogre differs from the one in Debian.

The value for "Pluginfolder" in

/usr/share/games/freeorion/ogre_plugins.cfg

is generated at build-time and points on amd64 to /usr/lib/x86_64-linux-gnu/OGRE-1.8.0.

Since the version of Ogre is different, the plugins can't most likely be found. Although I noticed that an Ubuntu patch tries to compensate this by symlinking the OGRE-1.8.1 plugin folder to OGRE-1.8.0.

What happens if you change the value of Pluginfolder to /usr/lib/x86_64-linux-gnu/OGRE-1.8.1 ?

Maybe a rebuild will resolve the issue?

Changed in ogre-1.8 (Ubuntu):
importance: Undecided → High
Changed in freeorion (Ubuntu):
importance: Undecided → High
Changed in ogre-1.8 (Ubuntu):
status: New → Confirmed
Revision history for this message
Lyn Perrine (walterorlin) wrote :

Changing pluginfolder in /usr/share/games/freeorion/ogre_plugins.cfg to /usr/lib/x86_64-linux-gnu/OGRE-1 caused game to at least launch for me.

Revision history for this message
Fabio (fabiomb) wrote :

same issue here , the solution works fine:

set
PluginFolder=/usr/lib/x86_64-linux-gnu/OGRE-1.8.1

in
/usr/share/games/freeorion/ogre_plugins.cfg

Revision history for this message
nunatak (nunatak) wrote :

Thanks for solution advice! For me the path is: /usr/lib/i386-linux-gnu/OGRE-1.8.1

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Fwiw, the version of freeorion in Ubuntu Utopic seems to work just fine. However, that one uses libogre-1.9.0.

Revision history for this message
Scott Howard (showard314) wrote :

hello all, please try the PPA:
https://launchpad.net/~showard314/+archive/ubuntu/ppa

a new-change rebuild is requried

Revision history for this message
Scott Howard (showard314) wrote :

no-change rebuild

summary: - ogre exception when starting - can't load library
+ SRU: ogre exception when starting - can't load library (no change
+ rebuild)
description: updated
no longer affects: ogre-1.8 (Ubuntu)
Changed in freeorion (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Iain Lane (laney) wrote :

Thanks, I uploaded a rebuild - it'll wait in the queue for manual approval. When approved, this bug will get another message and you can then verify if the fix works or not.

Changed in freeorion (Ubuntu):
status: Triaged → Fix Released
Changed in freeorion (Ubuntu Trusty):
status: New → In Progress
Revision history for this message
Chris J Arges (arges) wrote : Please test proposed package

Hello Jason, or anyone else affected,

Accepted freeorion into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/freeorion/0.4.3-2build1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in freeorion (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Markus Koschany (apoleon) wrote :

Thanks for the rebuild which fixes the bug for me. The game starts as intended.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freeorion - 0.4.3-2build1

---------------
freeorion (0.4.3-2build1) trusty; urgency=medium

  * No change rebuild against Trusty's current OGRE. (LP: #1292308)
 -- Iain Lane <email address hidden> Wed, 13 Aug 2014 17:24:26 +0100

Changed in freeorion (Ubuntu Trusty):
status: Fix Committed → Fix Released
Revision history for this message
Scott Kitterman (kitterman) wrote : Update Released

The verification of the Stable Release Update for freeorion has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers