No file association for .mm files

Bug #883008 reported by Adrian Wilkins on 2011-10-28
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
freemind (Debian)
Fix Released
Unknown
freemind (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]
Frequency : always
Severity : User cannot open file in packaged application with default actions like double-click, selection from dash, etc.

Justification for backporting : Restores intended behaviour. Broken behaviour annoying and frustrating, especially since there is no right-click menu in the dash. Lack of extremely basic OS integration with application filetype undermines image of distribution.

[Text Case]

1. Install FreeMind
2. Start the application, create a trivial mind map, and use default save, creating a .mm file
3. Close application, browse to file with nautilus
4. Note that nautilus correctly lists file type as "FreeMind Map"
5. Double click file

Broken Behavior: File opens in Firefox, you see XML
Fixed Behavior: File opens in FreeMind, you see a mind map

[Regression Potential]

Low risk change. No perceived potential for regression.

---- Original bug text below

After installing FreeMind, the mm file type is successfully detected as "FreeMind Map" and listed as such in Nautilus.

However, the application association appears to have gone. While FreeMind is present as an option in the "Open With" context menu, FreeMind is not the default application, and cannot be set as the default application via the GUI as it no longer appears in the list of applications for "Open With" dialogs.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freemind (Ubuntu):
status: New → Confirmed

I can confirm that the bug still exists in Precise.

Paul Calvelage (paul-calvelage) wrote :

See http://linux.derkeiler.com/Mailing-Lists/Debian/2011-11/msg01994.html. It seems the Exec line in /usr/share/applications/freemind.desktop is missing the %U parameter.

Adding that allows Freemind to be set as default via the GUI in Ubuntu 10.10. Alternatively I can manually add "application/x-freemind=freemind.desktop;" to ~/.local/share/applications/mimeapps.list.

Paul Calvelage (paul-calvelage) wrote :

Correction: I meant I was testing on Ubuntu 11.10, not 10.10.

Changed in freemind (Ubuntu Precise):
status: New → Triaged
Changed in freemind (Ubuntu):
status: Confirmed → In Progress
Bryce Harrington (bryce) on 2012-06-21
description: updated
description: updated
Marc Deslauriers (mdeslaur) wrote :

Thanks for the merge proposal. I've uploaded a slightly modified version of it to quantal, and have uploaded a slightly modified version of it to precise-proposed for processing by the SRU team.

Changed in freemind (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freemind - 0.9.0+dfsg-2ubuntu1

---------------
freemind (0.9.0+dfsg-2ubuntu1) quantal; urgency=low

  * Add file URL list parameter (%U) to .desktop file (LP: #883008)
 -- Adrian Wilkins <email address hidden> Wed, 11 Jul 2012 10:33:43 +0100

Changed in freemind (Ubuntu Quantal):
status: Fix Committed → Fix Released
Marc Deslauriers (mdeslaur) wrote :

Opened upstream Debian bug also.

Hello Adrian, or anyone else affected,

Accepted freemind into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/freemind/0.9.0+dfsg-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in freemind (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

Tested with a clean user session (guest account).

Saving a file and accessing it in nautilus indeed shows freemind as the file type but it's associated to gedit, not freemind.

So fixing the Exec path is definitely part of the fix but isn't the only fix needed to get the mime/type associated properly to freemind.

tags: added: verification-failed
removed: verification-needed
Stéphane Graber (stgraber) wrote :

I marked it verification-failed as although it doesn't hurt, it's not really changing anything either.

doubi (doubi) wrote :

Hi all,

I'm afraid I can't the precise symptoms and solution to this problem for me, but I do remember that the advice you most usually get from a search on the topic, about editing ~/.local/share/applications/mimeapps.list and .desktop files elsewhere, didn't solve it for me either.

I remember what eventually fixed it was either creating or editing an entry for freemind in /usr/share/mime/packages, making sure the "*.mm" glob was present.

Hope that helps in some way.

Cheers,

-d

Scott Kitterman (kitterman) wrote :

It seems like this could go ahead into -updates, but the bug should stay open since it's an incomplete resolution.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freemind - 0.9.0+dfsg-1ubuntu0.1

---------------
freemind (0.9.0+dfsg-1ubuntu0.1) precise-proposed; urgency=low

  * Add file URL list parameter (%U) to .desktop file (LP: #883008)
 -- Adrian Wilkins <email address hidden> Wed, 11 Jul 2012 10:33:43 +0100

Changed in freemind (Ubuntu Precise):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Setting back to Triaged since the fix appears to be incomplete.

Changed in freemind (Ubuntu Precise):
status: Fix Released → Triaged
Changed in freemind (Ubuntu Quantal):
status: Fix Released → Triaged
Changed in freemind (Debian):
status: Unknown → New
Changed in freemind (Debian):
status: New → Fix Released
Franck (alci) wrote :

Humm... seems still broken here with 0.9.0+dfsg2-1ubuntu1 (on Ubuntu 14.10)

Adding %U to the command in /usr/share/applications/freemind.desktop solved the issue.

Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in freemind (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.