freemind depends on icedtea-java7-bin

Bug #164535 reported by hawkes on 2007-11-22
8
Affects Status Importance Assigned to Milestone
freemind (Ubuntu)
Medium
Daniel Hahler

Bug Description

Freemind runs with Java6. Therefore it should depend on java2-runtime or | sun-java6-jdk. I don't want to have multiple JVMs and Classpath Libraries installed.

Related branches

Dan Trevino (dantrevino) wrote :

set package

Daniel Hahler (blueyed) on 2008-02-21
Changed in freemind:
assignee: nobody → blueyed
importance: Undecided → Medium
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freemind - 0.7.1-6ubuntu2

---------------
freemind (0.7.1-6ubuntu2) hardy; urgency=low

  * debian/control:
    - Depend on icedtea-java7-jre|sun-java6-jre|java2-runtime (LP: #164535)
    - Standards-Version 3.7.3
    - Moved Homepage from description to control field
    - Move debhelper from Build-Depends-Indep to B-D (lintian)
  * debian/copyright: add license/copyright for
    freemind/freemind/main/ExampleFileFilter.java

 -- Daniel Hahler <email address hidden> Fri, 22 Feb 2008 01:00:10 +0100

Changed in freemind:
status: In Progress → Fix Released
Anders (andersja+launchpad-net) wrote :

I installed freemind - 0.7.1-6ubuntu2 but there must be an incorrect dependency / java version, because when starting freemind, I get this error:

$ freemind
Exception in thread "main" java.lang.UnsupportedClassVersionError: freemind/main/FreeMind (Unsupported major.minor version 50.0)
 at java.lang.ClassLoader.defineClass0(Native Method)
 at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
 at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
 at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
 at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
 at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
 at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
[1]+ Exit 1 freemind

Am running latest Hardy Heron alpha, fully patched

Daniel Hahler (blueyed) wrote :

Anders, please provide the output of the following commands:
$ echo $FREEMIND_JAVA
$ echo $JAVACMD
$ echo $JAVA_BINDIR
$ echo $JAVA_HOME
$ which java
$ java -version
$ update-alternatives --display java

You can look at /usr/bin/freemind to see how freemind determines the java runtime to use.. which is quite strange IMHO, but let's see first what gets triggered on your system.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers