Depend on libnss-sss and libpam-sss

Bug #1600513 reported by Marlin Cremers on 2016-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
freeipa (Ubuntu)
Undecided
Unassigned

Bug Description

Currently libnss-sss and libpam-sss are marked as recommended on the sssd-common package. This however causes issues on systems that have installing recommended packages turned off (which I noticed was enabled on a VPS).

The fact that those libaries are not installed means that the client install is not able to get a working setup running. It would probably be best if freeipa-client had a dependency on libnss-sss and libpam-nss as they're essentially necessary to get a working setup.

CVE References

Philippe Clérié (pclerie) wrote :

I strongly concur. I was about to file a bug on that.

Also add: libsss-sudo.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freeipa - 4.3.2-5

---------------
freeipa (4.3.2-5) unstable; urgency=medium

  * fix-cve-2016-5404.diff: Fix permission check bypass (Closes: #835131)
    - CVE-2016-5404
  * ipa-kdb-support-dal-version-5-and-6.diff: Support mit-krb5 1.15.
    (Closes: #844114)

 -- Timo Aaltonen <email address hidden> Sat, 03 Dec 2016 01:02:40 +0200

Changed in freeipa (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers