chkconfig call in ipa-client-install doesn't work

Bug #1025018 reported by Stephan Ruegamer on 2012-07-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
freeipa (Ubuntu)
High
Unassigned

Bug Description

Dear Colleagues,

the chkconfig call in add_debian.py.patch doesn't work on Ubuntu (didn't test it with Debian though), because /sbin/insserv doesn't exist.
/usr/lin/insserv/insserv exists, but doesn't behave correctly.

For Ubuntu we should rewrite these calls, to match our service tools.

Furthermore, more checks needs to be included into this tool, to check if a service is already started.

Regards,

\sh

Timo Aaltonen (tjaalton) wrote :

yeah, and chkconfig got removed from the archive, so the current platform code should be ported to use something else..

Changed in freeipa (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Stephan Ruegamer (sadig) wrote :

So,

what do we have, the service <upstart service name> status calls are not parsed correctly.
Even with dbus and sssd started, it still fires up the service dbus start and service sssd start commands.

Actually, with FreeIPA 2.2.0 the whole debian platform module breaks.
So, it looks like we have to do much more on this.

Timo Aaltonen (tjaalton) wrote :

There's much restructuring needed upstream before a proper debian platform module can be created (that works for the server as well). I'm in process of doing it, but not sure how long it takes until everything is in place.

we should still be able to fix the current package so that it doesn't need chkconfig.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freeipa - 3.1.2-0ubuntu1

---------------
freeipa (3.1.2-0ubuntu1) raring; urgency=low

  * Merge from unreleased debian git.
    - new upstream release
    - doesn't use chkconfig anymore (LP: #1025018, #1124093)
    - drop -U from the ntpdate options (LP: #1149468)
 -- Timo Aaltonen <email address hidden> Thu, 07 Mar 2013 14:10:03 +0200

Changed in freeipa (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers