Freeguide does not work with the GNU Java Interpreter

Bug #125591 reported by Per Thykjaer Jensen on 2007-07-12
8
Affects Status Importance Assigned to Milestone
freeguide (Debian)
Fix Released
Unknown
freeguide (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: freeguide

Here are the error messages:
---
Load module jar: /usr/share/freeguide/lib/reminder-alarm.jar
Load module jar: /usr/share/freeguide/lib/importexport-html.jar
Load module jar: /usr/share/freeguide/lib/importexport-jtv.jar
Load module jar: /usr/share/freeguide/lib/ui-horizontal.jar
Load module jar: /usr/share/freeguide/lib/common.jar
Load module jar: /usr/share/freeguide/lib/importexport-palmatv.jar
Load module jar: /usr/share/freeguide/lib/importexport-xmltv.jar
Load module jar: /usr/share/freeguide/lib/storage-serfiles.jar
Load module jar: /usr/share/freeguide/lib/grabber-rbc.jar
Load module jar: /usr/share/freeguide/lib/grabber-cosmostv.jar
Load module jar: /usr/share/freeguide/lib/grabber-ntvplus.jar
Load module jar: /usr/share/freeguide/lib/grabber-vsetv.jar
Load module jar: /usr/share/freeguide/lib/importexport-mobile.jar
Load module jar: /usr/share/freeguide/lib/program-freeguide.jar
Load module jar: /usr/share/freeguide/lib/grabber-xmltv.jar
Load module jar: /usr/share/freeguide/lib/grabber-kulichki.jar
Load module jar: /usr/share/freeguide/lib/tagsoup-1.0rc3.jar
Load module jar: /usr/share/freeguide/lib/grabber-hallmark.jar
Load module jar: /usr/share/freeguide/lib/grabber-newsvm.jar
java.lang.reflect.InvocationTargetException
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   at freeguide.startup.Startup.run(Startup.java:119)
   at freeguide.startup.Startup.main(Startup.java:51)
Caused by: java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.70)
   at java.awt.Window.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at javax.swing.JFrame.<init>(libgcj.so.70)
   at freeguide.plugins.program.freeguide.dialogs.PleaseWaitFrame.<init>(PleaseWaitFrame.java:46)
   at freeguide.plugins.program.freeguide.FreeGuide.showPleaseWait(FreeGuide.java:440)
   at freeguide.plugins.program.freeguide.FreeGuide.main(FreeGuide.java:398)
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   ...2 more
Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: cannot open shared object file: No such file or directory
   at java.lang.Runtime._load(libgcj.so.70)
   at java.lang.Runtime.loadLibrary(libgcj.so.70)
   at java.lang.System.loadLibrary(libgcj.so.70)
   at gnu.java.awt.peer.gtk.GtkToolkit.<clinit>(libgcj.so.70)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at java.lang.Class.forName(libgcj.so.70)
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   ...10 more
java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.70)
   at java.awt.Window.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at javax.swing.JFrame.<init>(libgcj.so.70)
   at freeguide.plugins.program.freeguide.dialogs.PleaseWaitFrame.<init>(PleaseWaitFrame.java:46)
   at freeguide.plugins.program.freeguide.FreeGuide.showPleaseWait(FreeGuide.java:440)
   at freeguide.plugins.program.freeguide.FreeGuide.main(FreeGuide.java:398)
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   at freeguide.startup.Startup.run(Startup.java:119)
   at freeguide.startup.Startup.main(Startup.java:51)
Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: cannot open shared object file: No such file or directory
   at java.lang.Runtime._load(libgcj.so.70)
   at java.lang.Runtime.loadLibrary(libgcj.so.70)
   at java.lang.System.loadLibrary(libgcj.so.70)
   at gnu.java.awt.peer.gtk.GtkToolkit.<clinit>(libgcj.so.70)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at java.lang.Class.forName(libgcj.so.70)
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   ...10 more
Exception in main method
java.lang.reflect.InvocationTargetException
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   at freeguide.startup.Startup.run(Startup.java:119)
   at freeguide.startup.Startup.main(Startup.java:51)
Caused by: java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.70)
   at java.awt.Window.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at javax.swing.JFrame.<init>(libgcj.so.70)
   at freeguide.plugins.program.freeguide.dialogs.PleaseWaitFrame.<init>(PleaseWaitFrame.java:46)
   at freeguide.plugins.program.freeguide.FreeGuide.showPleaseWait(FreeGuide.java:440)
   at freeguide.plugins.program.freeguide.FreeGuide.main(FreeGuide.java:398)
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   ...2 more
Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: cannot open shared object file: No such file or directory
   at java.lang.Runtime._load(libgcj.so.70)
   at java.lang.Runtime.loadLibrary(libgcj.so.70)
   at java.lang.System.loadLibrary(libgcj.so.70)
   at gnu.java.awt.peer.gtk.GtkToolkit.<clinit>(libgcj.so.70)
   at java.lang.Class.initializeClass(libgcj.so.70)
   at java.lang.Class.forName(libgcj.so.70)
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   ...10 more
Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.70)
   at java.awt.Window.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at freeguide.startup.MessageBox.<init>(MessageBox.java:24)
   at freeguide.startup.MessageBox.display(MessageBox.java:35)
   at freeguide.startup.Startup.die(Startup.java:188)
   at freeguide.startup.Startup.run(Startup.java:163)
   at freeguide.startup.Startup.main(Startup.java:51)
Caused by: java.lang.NoClassDefFoundError: gnu.java.awt.peer.gtk.GtkToolkit
   at java.lang.Class.initializeClass(libgcj.so.70)
   at java.lang.Class.forName(libgcj.so.70)
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   ...9 more

rgds. Per Thykjaer Jensen

Vincent Legout (vlegout) wrote :

I confirm the bug with feisty amd64 and freeguide 0.10.4-2. And there is no bug with feisty i386.

Changed in freeguide:
status: New → Confirmed
Allyn (allyn-carterhq) wrote :

I can confirm that this problem still exists in Gutsy / Kubuntu on AMD 64.

I don't think this is anything to do with AMD64-ness. I've a plain 8.04 and have just installed freeguide 0.10.6-1ubuntu1. Selecting Applications -> Sound & Video -> Freeguide gives similar output to the above in ~/.xsession-errors. Running `freeguide' at the command line does the same, see attachment. I assume it's a packaging error; there's a missing dependency.

> I don't think this is anything to do with AMD64-ness. I've a plain 8.04
> and have just installed freeguide 0.10.6-1ubuntu1.

I meant to say, 32-bit x86.

The package depends on "java" but actually, FreeGuide doesn't work with the gcj version of java - it requires openjdk-6-jre or sun-java6-jre.

I don't know whether there's a good way to specify something like that in the package.

Please could you try installing openjdk and seeing whether that fixes the problem?

Changed in freeguide:
status: Unknown → Confirmed
Hans (12hans12) wrote :

installed default-jre wich points to openjdk-6-jre and now it works fine for me.
Using Ubuntu 9.10 Amd64

On a fresh 9.10 install, freeguide installs and runs. It has the odd
quirk, but they may be different bugs, or problems caused by the Java
runtime it's using. The interesting thing is, none of the Java packages
it claims to need are installed AFAICS.

    $ apt-cache show freeguide
    ...
    Version: 0.10.9-1
    Depends: xmltv-gui, openjdk-6-jre | java2-runtime, openjdk-6-jre-headless | java-virtual-machine

    $ apt-rdepends --state-follow=Installed -p freeguide
    freeguide
      Depends: java-virtual-machine [NotInstalled]
      Depends: java2-runtime [NotInstalled]
      Depends: openjdk-6-jre [NotInstalled]
      Depends: openjdk-6-jre-headless [NotInstalled]
      Depends: xmltv-gui [Installed]
    xmltv-gui
    ...

So why `apt-get install' thought it was OK to proceed, I don't know.

Changed in freeguide (Debian):
status: Confirmed → Fix Released
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in freeguide (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.