package freeciv-client-gtk 2.1.5-1 failed to install/upgrade (with error exit status 255)

Bug #262440 reported by Reid on 2008-08-28
324
This bug affects 22 people
Affects Status Importance Assigned to Milestone
freeciv (Ubuntu)
High
Unassigned

Bug Description

8.10

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage:
 ErrorMessage: subprocess new pre-removal script returned error exit status 255
NonfreeKernelModules: nvidia
Package: freeciv-client-gtk 2.1.5-1
SourcePackage: freeciv
Title: package freeciv-client-gtk 2.1.5-1 failed to install/upgrade:
Uname: Linux 2.6.24-19-386 i686

Reid (redhead-lightning) wrote :
Brian Murray (brian-murray) wrote :

I also experienced this on 2008-09-03.

Changed in freeciv:
importance: Undecided → High
status: New → Confirmed

Is it still a problem with 2.1.5-2?

If yes, can you check if /usr/share/ggz/modules/freeciv/civclient.dsc exists? It seems that ggz-config has problems removing this module.

Pauli (paniemin) wrote :

Same problem for me and civclient.dsc is still present in that directory.

Caroline Ford (secretlondon) wrote :

Think this is fixed in jaunty. Managed to install freeciv-gtk on a netbook running jaunty netbook remix.

Balder (damtroll) wrote :

I'm running 8.04 and did a dist-upgrade to 9.04 and that was then the problem occurred.

Roman Sergey (roman-sergey) wrote :

a helpful solution is the next:
1) get file civclient.dsc.in from the source package of freeciv-client-gtk
2) cp civclient.dsc.in /usr/share/ggz/modules/freeciv/civclient.dsc
3) dpkg --configure freeciv-client-gtk

Roman Sergey (roman-sergey) wrote :

sorry, I meant the freeciv source package. (location freeciv-x.x.x.tgz/data/civclient.dsc.in)
However the content of the civclient.dsc file:

# GGZ client game description file for Freeciv
[ModuleInfo]
Author = See http://www.freeciv.org/wiki/People
CommandLine = @prefix@/bin/civclient
Frontend = any
Homepage = http://www.freeciv.org/
Name = Freeciv
ProtocolEngine = Freeciv
ProtocolVersion = @NETWORK_CAPSTRING@
Version = @VERSION@
#END

KarlGoetz (kgoetz) wrote :

I've updated the title to include the only relevant part of the bugs I'm about to mark as dupe of this. sorry if this is noisy (in the email sense), LP won't automatically mark dupes of a dupe against the new parent.

summary: - package freeciv-client-gtk 2.1.5-1 failed to install/upgrade:
+ package freeciv-client-gtk 2.1.5-1 failed to install/upgrade (with error
+ exit status 255)
Rigved Rakshit (rigved) wrote :

Description: Ubuntu 12.04.3 LTS
Release: 12.04

freeciv-client-gtk:
  Installed: 2.3.1-1
  Candidate: 2.3.1-1
  Version table:
     2.3.2-1~ubuntu12.04.1 0
        100 http://in.archive.ubuntu.com/ubuntu/ precise-backports/universe amd64 Packages
 *** 2.3.1-1 0
        500 http://in.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Expected Outcome: This package should have been configured without any issues.

Actual Outcome: I encountered this error message while installing freeciv-client-gtk on a freshly installed Ubuntu 12.04.3.

To post a comment you must log in.