freeciv 2.5.6-2 FTBFS

Bug #1652663 reported by Hans Joachim Desserud on 2016-12-26
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
freeciv (Ubuntu)
Undecided
Unassigned

Bug Description

freeciv 2.5.6-2 in zesty-proposed currently fails to build from source with the following error message:

configure: exit 1
dh_auto_configure: ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=${prefix}/lib/x86_64-linux-gnu --libexecdir=${prefix}/lib/x86_64-linux-gnu --disable-maintainer-mode --disable-dependency-tracking --cache-file=/<<PKGBUILDDIR>>/config.cache --sysconfdir=/etc --prefix=/usr --datadir=${prefix}/share/games --bindir=${prefix}/games --enable-debug=no --enable-client=gtk2,gtk3,sdl,qt --enable-fcmp=gtk3 --with-ggz-server=no --with-ggz-client=no --enable-ipv6=yes --enable-sys-lua --disable-silent-rules --enable-fcdb=sqlite3 --without-freeciv-manual --with-missinglist returned exit code 1
debian/rules:18: recipe for target 'override_dh_auto_configure' failed
make[1]: *** [override_dh_auto_configure] Error 2
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
debian/rules:15: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

see https://launchpadlibrarian.net/299093535/buildlog_ubuntu-zesty-amd64.freeciv_2.5.6-2_BUILDING.txt.gz for complete build log.

I get the same error message when attempting to build the package on my Zesty vm, but it worked fine on Debian Sid, so it looks like an Ubuntu-only issue.

Extremeadin (extremeadin) wrote :

I get a same error on xenial, it looks like it's a problem with finding the q5 devel files:

checking Qt5 libraries... not found
configure: error: selected client 'qt' cannot be built: Missing Qt5 development files

Graham Inggs (ginggs) wrote :

Fixed released in 2.5.6-2ubuntu1. The problem was this change from Debian:

  * Export all hardening build flags and use -pie again. (Closes: #844198)

Changed in freeciv (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers