Please rebuild: Inconsistent deps - depends on both libopenal0a and libopenal1

Bug #252273 reported by Bryan Donlan on 2008-07-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
freealut (Ubuntu)
Undecided
Unassigned

Bug Description

libalut-dev depends on libopenal-dev, which depends on libopenal1.
However, libalut-dev also depends on libalut0 (also part of this package), which depends on libopenal0a.

freealut should be rebuilt (or whatever else is needed) to use the new openal lib.

It appears that a rebuild (with no source changes) in intrepid is sufficient to fix this.

Related branches

Bryan Donlan (bdonlan) wrote :

Once freealut is updated, the next upload of openal-soft should probably include a Breaks: libalut-dev (< [whatever version it's fixed in]) on libopenal-dev, to help avoid inconsistent library installations, if someone tries to upgrade only openal.

Bryan Donlan (bdonlan) on 2008-08-02
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freealut - 1.1.0-1build1

---------------
freealut (1.1.0-1build1) intrepid; urgency=low

  * Rebuild for libopenal0a -> libopenal1 transition (LP: #252273).

 -- Michael Bienia <email address hidden> Sun, 03 Aug 2008 16:57:01 +0200

Changed in freealut:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers