linking against libfwImage.so fails

Bug #496122 reported by Andrew Straw on 2009-12-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
framewave (Ubuntu)
Undecided
Unassigned

Bug Description

I cannot link a simple C program against libfwImage.so. I am including an example program as an attachment, although I imagine any valid C program will do -- this seems to be a problem with libfwImage.so.

This is happening on Karmic and Lucid. (With libfwbase1-dev 1.3-5 and 1.3.1-1, respectively.) With 1.3.1-1 on sid, I do not get this error. (This makes me think that the issue might be with scons or other part of the buildsystem rather than with the framewave package itself.)

Steps to reproduce:

(download fwitest.c attached to this ticket.)
gcc -o fwitest.o -c fwitest.c
gcc fwitest.o -o fwitest -lfwBase -lfwImage

In this last step on Lucid amd64, I get:

/usr/lib/gcc/x86_64-linux-gnu/4.4.2/../../../../lib/libfwImage.so: undefined reference to `void REFR::My_FW_PointHandle<float, (REFR::DispatchType)0>(double, double, int, int, float const*, int, FwiRect, float*, int, int, int*, int, int, float)'
/usr/lib/gcc/x86_64-linux-gnu/4.4.2/../../../../lib/libfwImage.so: undefined reference to `void REFR::My_FW_PointHandle<unsigned short, (REFR::DispatchType)0>(double, double, int, int, unsigned short const*, int, FwiRect, unsigned short*, int, int, int*, int, int, float)'
/usr/lib/gcc/x86_64-linux-gnu/4.4.2/../../../../lib/libfwImage.so: undefined reference to `void REFR::My_FW_PointHandle<unsigned char, (REFR::DispatchType)0>(double, double, int, int, unsigned char const*, int, FwiRect, unsigned char*, int, int, int*, int, int, float)'
/usr/lib/gcc/x86_64-linux-gnu/4.4.2/../../../../lib/libfwImage.so: undefined reference to `void SSE2::My_FW_PointHandle<unsigned char, (SSE2::DispatchType)0>(double, double, int, int, unsigned char const*, int, FwiRect, unsigned char*, int, int, int*, int, int, float)'
/usr/lib/gcc/x86_64-linux-gnu/4.4.2/../../../../lib/libfwImage.so: undefined reference to `void SSE2::My_FW_PointHandle<unsigned short, (SSE2::DispatchType)0>(double, double, int, int, unsigned short const*, int, FwiRect, unsigned short*, int, int, int*, int, int, float)'
/usr/lib/gcc/x86_64-linux-gnu/4.4.2/../../../../lib/libfwImage.so: undefined reference to `void SSE2::My_FW_PointHandle<float, (SSE2::DispatchType)0>(double, double, int, int, float const*, int, FwiRect, float*, int, int, int*, int, int, float)'
collect2: ld returned 1 exit status

Related branches

Andrew Straw (astraw) wrote :
Andrew Straw (astraw) wrote :

I started a thread on this at Framewave's forum (at SourceForge) here: https://sourceforge.net/projects/framewave/forums/forum/764940/topic/3488703

Andrew Straw (astraw) wrote :

This was fixed in svn upstream in their commits 488,489,490. Unfortunately, these commits don't apply cleanly against the debian source. I was able the patches onto the debian source with no manual intervention using git and kdiff3 as the mergetool.

I am attaching the resulting debdiff against framewave-1.3.1-1 that solves the problem. (Tested on karmic.)

I'm not very familiar with the Ubuntu process -- what should I do to get this into Lucid? Since the package was originally synced from Debian, and I presume these upstream svn changes will eventually make it into Debian, this is just a temporary, Ubuntu-specific patch. I guess the upstream changes going to Debian will take a while, though, since it depends on upstream to do a release and Debian to build a package from it. Therefore, I'd like help help get this into Ubuntu as quickly as possible. What more can I do?

Colin Watson (cjwatson) wrote :

framewave (1.3.1-1ubuntu2) maverick; urgency=low

  * Pull in upstream svn to fix LP: #496122.

 -- Andrew Straw <email address hidden> Thu, 17 Dec 2009 19:14:27 +0000

Changed in framewave (Ubuntu):
status: New → Fix Released
Luis J. Manso (luis-manso) wrote :

Is it fixed? Not on 10.04.1. I'm still having the problem...

Thanks Andrew for your contribution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments