fingerprint scanner usually keeps flashing after use, requiring a second (useless) fingerprint scan

Bug #1588815 reported by Christopher Barrington-Leigh
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
fprintd (Ubuntu)
Medium
Unassigned

Bug Description

After upgrade to 16.04, any action which invokes the fingerprint scanner (for me: unlocking screen, sudo, etc) will cause the scanner to flash its green light until I scan my finger. Then the desired authentication and action take place.

However, the scanner continues to flash its green light until I scan my finger a second time. However, this scan accomplishes nothing except to make it stop flashing.

Also, when I log in (with my password, not fingerprint, otherwise I won't have access to encrypted folders), the scanner flashes needlessly until I scan once.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: fprintd 0.6.0-1
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Jun 3 08:55:32 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-02-12 (111 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: fprintd
UpgradeStatus: Upgraded to xenial on 2016-05-24 (9 days ago)

Revision history for this message
Christopher Barrington-Leigh (cpbl) wrote :
summary: - fingerprint scanner usually keeps flashing after use; requiring a second
- (meaningless) fingerprint scan
+ fingerprint scanner usually keeps flashing after use, requiring a second
+ (useless) fingerprint scan
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fprintd (Ubuntu):
status: New → Confirmed
Revision history for this message
Andre T (wind-kitesurfer) wrote :

Same here

Even with 4.6 kernel.
I've tried both figerpritgui (https://launchpad.net/~fingerprint/+archive/ubuntu/fingerprint-gui) and fprint (https://launchpad.net/~fingerprint/+archive/ubuntu/fprint).

It is not a major issue for me but still it is annoying that the keeps flashing after authentication occurs

Ubuntu 16.04
Lenovo T450

:)

Changed in fprintd (Ubuntu):
importance: Undecided → Medium
Revision history for this message
John LaRocque (jwlarocque) wrote :

I am also experiencing this bug, both fingerprintgui and fprint. It's not much of a problem (weird mouse focus issues) but it would be nice to have a fix.
16.04, kernel 4.6.3
Lenovo T460

Revision history for this message
Samson Danziger (samson-danziger) wrote :

+1 Also having this issue.

Ubuntu 16.04, kernel 4.4.0
Lenovo X250

Revision history for this message
Oleg (oleg-tarassov) wrote :

+1 having same issue where light remains flashing after i login using the finger print or via keyboard entered password. Work around is to pass the finger over it once again to stops it.

thanks

P.S kernel: 4.7.7-200

Revision history for this message
Dennis Tang (dennistang) wrote :

+1 as well.

Ubuntu 16.04, 4.4.0-43
Lenovo T460

Revision history for this message
db (dvb7836) wrote :

+1

Ubuntu 16.04 4.4.0-45-generic
Lenovo T460

Revision history for this message
menie (menie482) wrote :

Same for me.
Does anyone find a solution?

Ubuntu 16.04 4.4.0-45-generic
X1 Carbon 3rd Gen.

Revision history for this message
Botond (botond88) wrote :

Same here. Ubuntu 16.04 on a Lenovo x260

Revision history for this message
Kacper Kulczak (magikis) wrote :

Same here ubuntu 16.04 on Lenovo X1 Carbon 3rd generation

Revision history for this message
Robert May (robotmay) wrote :

Also present on 16.04 on a ThinkPad X250.

Revision history for this message
Dalibor Kovač (hogar1977) wrote :

Also present on 16.10, Thinkpad W550s

sapotacoin (sapotacoin)
Changed in fprintd (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers