upgrade from 16.04 to 18.04 uncalculatable due to fpc packages

Bug #1786486 reported by Luiz Coutinho on 2018-08-10
54
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fpc (Debian)
Fix Committed
Unknown
fpc (Ubuntu)
Medium
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
Upgrades from 16.04 to 18.04 might fail if fpc packages are installed, as fp-units-base-3.0.4 Breaks fp-units-misc-3.0.0 (<= 3.0.0+dfsg-2); a leftover from fp-units-base-3.0.0 that should have been removed (all paths in the deb are versioned).

[Test case]
1. Extract dpkg status from apt clone system state in comment #1 and run apt dist-upgrade against it in a bionic system
2. Restore apt-clone and run ubuntu-release-upgrader

[Regression potential]
Since all paths are versioned, there should be no regressions.

[Original bug report]

it aborts in second step.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.25
ProcVersionSignature: Ubuntu 4.4.0-131.157-generic 4.4.134
Uname: Linux 4.4.0-131-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Fri Aug 10 11:06:26 2018
InstallationDate: Installed on 2015-06-30 (1137 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2018-08-10 (0 days ago)
VarLogDistupgradeTermlog:

modified.conffile..etc.update-manager.release-upgrades: [modified]
mtime.conffile..etc.update-manager.release-upgrades: 2018-08-10T07:52:29.705103

Luiz Coutinho (lffc60) wrote :
tags: added: xenial2bionic
Brian Murray (brian-murray) wrote :

I was able to recreate this bug by using the apt-clone file in it, after restoring the clone file the upgrade failed to calculate. When I removed the fpc package the upgrade was calculatable so it seems to be an issue with the fpc packages.

summary: - upgrade 16.04 to 18.04
+ upgrade from 16.04 to 18.04 uncalculatable due to fpc packages
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Changed in fpc (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in fpc (Debian):
status: Unknown → New
Julian Andres Klode (juliank) wrote :

I believe it's a problem with fp-units-base-3.0.4 Breaks fp-units-misc-3.0.0 (<= 3.0.0+dfsg-2), as that prevents the old versions from remaining installed. Needs verification to make sure.

Julian Andres Klode (juliank) wrote :

Just verified, this solves the bug.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Won't Fix
Changed in fpc (Ubuntu):
status: Confirmed → In Progress
description: updated
Changed in fpc (Ubuntu):
status: In Progress → Fix Committed
Changed in fpc (Ubuntu Bionic):
status: New → In Progress
no longer affects: ubuntu-release-upgrader (Ubuntu)
no longer affects: ubuntu-release-upgrader (Ubuntu Bionic)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fpc - 3.0.4+dfsg-20ubuntu1

---------------
fpc (3.0.4+dfsg-20ubuntu1) cosmic; urgency=medium

  * Remove wrong fp-units-base-3.0.4 Breaks fp-units-misc-3.0.0, this breaks
    upgrades from xenial (LP: #1786486)

 -- Julian Andres Klode <email address hidden> Wed, 29 Aug 2018 22:34:16 +0200

Changed in fpc (Ubuntu):
status: Fix Committed → Fix Released

Hello Luiz, or anyone else affected,

Accepted fpc into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fpc/3.0.4+dfsg-18ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fpc (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in fpc (Debian):
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.