Ubuntu

problems with fp-docs, unexpected error using html help files

Reported by jonatan_fischer on 2007-06-10
4
Affects Status Importance Assigned to Milestone
fpc (Debian)
Fix Released
Unknown
fpc (Ubuntu)
Undecided
Unassigned

Bug Description

When I was trying to use help files, I went to Help menu and chose Contents, then when I chose User's guide and in that moment fp showed an error message. The error message is something like this "Program generated a signal 11, please Save your sources and restart the IDE". Then appears another error message saying "The IDE generated a error message and will be closed"

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Fri Jun 8 18:31:09 2007
Dependencies: fp-units-rtl 2.0.4-5
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/fp
Package: fp-ide 2.0.4-5
PackageArchitecture: i386
ProcCmdline: fp
ProcCwd: /home/jonas
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=es_AR.UTF-8
Signal: 11
SourcePackage: fpc
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Uname: Linux K-jona 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux
UserGroups: audio cdrom dialout floppy lpadmin plugdev scanner video

jonatan_fischer (jonainge333) wrote :

StacktraceTop:?? ()
?? ()
?? ()
?? ()
?? ()

Paul Gevers (paul-climbing) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I am trying to reproduce your bug, but I don't understand where you find the Help menu (are you using Lazarus or some other GUI?). Could you give me a more detailed description to trigger this bug? If you can not reproduce this bug yourself could you please also respond?

Changed in fpc:
status: New → Incomplete
Paul Gevers (paul-climbing) wrote :

Please disregard my previous comment, I figured out how to use fp directly (hadn't done that before). However, I still not able to reproduce your bug because I don't get the documentation to load into fp (probably an other bug I guess)

Changed in fpc:
status: Incomplete → New
Paul Gevers (paul-climbing) wrote :

Using 2.2.2-8 (from Jaunty installed on Intrepid) I get the same errors. The error occurs when I select " User's guide", "Programmer's guide" or "Pascal Language Reference guide", but NOT when I select one of the other three items.

Changed in fpc:
status: New → Confirmed
jonatan_fischer (jonainge333) wrote :

That's exactly what happened, I don't use any more Free Pascal, I was using it for learning Pascal at my university... but it seems that the bug wasn't corrected... the IDE can be launched from command line, it is similar to Borland Pascal 7 IDE, I guess it's written in ncurses. If you go to the help tag, then select " User's guide", "Programmer's guide" or "Pascal Language Reference guide", the program crashes, even if you have correctly installed the documentation package.

Changed in fpc (Debian):
status: Unknown → New
Changed in fpc (Debian):
status: New → Fix Released
Paul Gevers (paul-climbing) wrote :

As per the same comment of the bug in Debian:

I am not able to reproduce this issue anymore. I am now running 2.6.0-6.

Changed in fpc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.