Error writing settings file: file:///usr/lib/firefox-3.0.3/foxyproxy.xml

Bug #279466 reported by Sean Sosik-Hamor on 2008-10-07
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
foxyproxy (Ubuntu)
High
Unassigned
Declined for Intrepid by Steve Langasek

Bug Description

Binary package hint: foxyproxy

After installing the foxyproxy package I get the attached error when running Firefox. "Error writing settings file: file:///usr/lib/firefox-3.0.3/foxyproxy.xml. Ensure the path exists and that Firefox has write access, then restart Firefox. FoxyProxy will not function until then."

Yes, I could give myself write access to /usr/lib/firefox-3.0.3 but that doesn't seem like a good idea. ;) Under Hardy foxyproxy.xml was saved as ~/.mozilla/firefox/XXXXXXXX.default/foxyproxy.xml.

Distributor ID: Ubuntu
Description: Ubuntu intrepid (development branch)
Release: 8.10
Codename: intrepid
foxyproxy:
  Installed: 2.7.5-0ubuntu3
  Candidate: 2.7.5-0ubuntu3
  Version table:
 *** 2.7.5-0ubuntu3 0
        500 http://archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status
firefox:
  Installed: 3.0.3+build1+nobinonly-0ubuntu1
  Candidate: 3.0.3+build1+nobinonly-0ubuntu1
  Version table:
 *** 3.0.3+build1+nobinonly-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Sean Sosik-Hamor (sciri) wrote :
Changed in foxyproxy:
importance: Undecided → High
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I believe this is because foxyproxy is installed in /usr/lib/firefox-3.0.3/ and the extension looks for the xml file there.

From foxyproxy.js:

var self;
var fileProtocolHandler = CC["@mozilla.org/network/protocol;1?name=file"].createInstance(CI["nsIFileProtocolHandler"]);
if ("undefined" != typeof(__LOCATION__)) {
  // preferred way
  self = __LOCATION__;
}
else {
  self = fileProtocolHandler.getFileFromURLSpec(Components.Exception().filename);
}
var componentDir = self.parent; // the directory this file is in
var settingsDir = componentDir.clone();

Changed in foxyproxy:
status: Confirmed → Triaged

Not that its the best idea - or even original - but if you make a blank xml file n your home directory then put a link n the /usr/lib/firefox-3.0.3/ dir it will knock it right out

Ilya Barygin (randomaction) wrote :

This happens regardless of how you install foxyproxy: as a separate package, or via firefox's extension mechanism.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package foxyproxy - 2.8.9-0ubuntu1

---------------
foxyproxy (2.8.9-0ubuntu1) jaunty; urgency=low

  * New upstream release 2.8.9
  * Remove firefox-2 dependency (LP: #272959)
  * Use med-xpi-pack provided by mozilla-devscripts
    - Remove debian/med-xpi-pack
    - Remove MOZ_XPI_BUILD_COMMAND in debian/rules
  * Modify getDefaultPath() in foxyproxy.js to use profile directory for
    settings file instead of /usr/lib/firefox/ (LP: #279466)

  [ Alexander Sack <email address hidden> ]
  * add auto-magic config for bzr builddeb's export-upstream feature
    see: http://jameswestby.net/bzr/builddeb/user_manual/export_upstream.html
    - add .bzr-builddeb/default.conf

 -- Sasa Bodiroza <email address hidden> Wed, 17 Dec 2008 12:31:58 +0100

Changed in foxyproxy:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers