foxlib throws an error in XFE Filemanager due to Ubuntu-packaging wt -Bsymbolic-functions

Bug #1188185 reported by Flames_in_Paradise on 2013-06-06
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fox1.6 (Debian)
Fix Released
Unknown
fox1.6 (Ubuntu)
Undecided
Unassigned

Bug Description

foxlib1.6 is packaged with link -Bsymbolic functions. This produces an error on the mouse-right click function (e.g. File-properties, ..open with, etc.) within the XFE-Filemanager, V 1.32.5

This is reproducable.

Reference1: http://changelogs.ubuntu.com/changelogs/pool/universe/f/fox1.6/fox1.6_1.6.45-1ubuntu2/changelog

Remaining changes:
    - Link without -Bsymbolic-functions. Wed, 30 May 2012 00:43:49 -0500

Reference2:Project-housing XFE @ sourceforge

http://sourceforge.net/p/xfe/bugs/171/ (status:closed/works for me)

So a simple rebuild of the package could fix this. Would be nice to have it SRUed then.

Thanks in advance for helping to make Ubuntu better every day.

tags: added: precise quantal
description: updated
summary: foxlib throws an error in XFE Filemanager due to Ubuntu-packaging wt
- Bsymbolic-Function
+ -Bsymbolic-functions
description: updated
Changed in fox1.6 (Debian):
status: Unknown → Confirmed
Roland65 (roland65) wrote :

I confirm the bug.
It seems that the lines:

ifneq (,$(LDFLAGS))
  LDFLAGS := $(filter-out %-Bsymbolic-functions,$(LDFLAGS))
endif

that were added to the debian/rules file in Ubuntu 12.04 does nothing now.

Changed in fox1.6 (Ubuntu):
status: New → Confirmed
Changed in fox1.6 (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fox1.6 - 1.6.50-1

---------------
fox1.6 (1.6.50-1) unstable; urgency=medium

  * New upstream release.
  * Add optional code into debian/rules for Ubuntu to link without
      -Bsymbolic-functions. LP: #1188185
  * Add patch: remove Nedstat Basic links in docs.

 -- Joachim Wiedorn <email address hidden> Tue, 02 Sep 2014 22:55:55 +0200

Changed in fox1.6 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.