Many fortunes point to dead URLs

Bug #915651 reported by GeekSmith on 2012-01-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fortunes-ubuntu-server (Ubuntu)
Medium
Unassigned

Bug Description

The following fortunes in /usr/share/games/fortunes/ubuntu-server-tips contain URLs that are no longer valid:

'etckeeper' allows you to save changes you make to /etc in a bazaar
repository. Useful to track and revert
changes. http://tinyurl.com/etckeeper (The URL registered at tinyurl.com points to https://help.ubuntu.com/9.04/serverguide/C/etckeeper.html.)

Need a little refresh on networking concept? Take a look at the networking
section of the server guide.
https://help.ubuntu.com/9.10/serverguide/C/networking.html

Keep your servers time in sync, use the ntpd package.
https://help.ubuntu.com/9.10/serverguide/C/NTP.html

Package updates can be automated on your server using the
unattended-upgrades package.
https://help.ubuntu.com/9.10/serverguide/C/automatic-updates.html

These could be fixed by pointing to the most recent (or perhaps the next) LTS release server guide URL. Even better would be for the installer script to grab the version of Ubuntu from the installation and create the URL on the fly. Maybe I'll submit a patch that does this.

GeekSmith (lixo-geeksmith) wrote :

The best I could come up with was to use a command to grab last year's last release (which should always be a reliable value, right?). Something like this in the debian rules script:
sed -i 's/@@LASTRELEASE@@/'$(( $(date +%y) - 1 ))'.10/' <file>

Where file is either ubuntu-server-tips or the language-specific version of that file. I'm no Makefile magician, so my efforts to actually implement this were brief. If I need to put a little more effort into it, I'd be happy to do so. As a consolation gift, I've attached a patch to fix the current problem, though it won't really work for long.

The attachment "Update URLs to Ubuntu help site" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

Looks like this patch is still relevant for fortunes-ubuntu-server 0.4 (on Ubuntu Wily)

Changed in fortunes-ubuntu-server (Ubuntu):
status: New → Confirmed
tags: added: precise trusty vivid wily
Changed in fortunes-ubuntu-server (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fortunes-ubuntu-server - 0.5

---------------
fortunes-ubuntu-server (0.5) xenial; urgency=medium

  [ Evan McIntire ]
  * ubuntu-server-tips: fix grammar (LP: #1458260).

  [ GeekSmith ]
  * ubuntu-server-tips: fix links (LP: #915651)

 -- Evan McIntire <email address hidden> Mon, 04 Jan 2016 14:06:40 +0100

Changed in fortunes-ubuntu-server (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers