fOptions library fails to load

Bug #366569 reported by Ramin Nakisa on 2009-04-25
2
Affects Status Importance Assigned to Milestone
foptions (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: r-cran-foptions

I upgraded to Jaunty and started getting errors when loading the R fOptions library (within R of course),

> library(fOptions)
Rmetrics Package fOptions (270.74) loaded.
Error : package 'fImport' does not have a name space
Error in as.environment(pos) :
  no item called "newtable" on the search list

Release information

$ dpkg -l | grep foptions
ii r-cran-foptions 270.74-1 GNU R package for financial engineering -- f

$ lsb_release -d
Description: Ubuntu 9.04

I installed almost all of the R packages and fOptions version 270.74-1 fails to load because of the name space error in fImport. The fImport library is also version 270.74-1.

$ dpkg -l | grep fimport
ii r-cran-fimport 270.74-1

This link suggests the problem is due to the mixing of r-forge and release package versions:

https://stat.ethz.ch/pipermail/r-sig-finance/2008q3/002616.html

And indeed the versions are out of synch, because r-cran-fbasics is a newer version than the fimport and foptions packages:

$ dpkg -l | grep r-cran-f
ii r-cran-fbasics 280.74-1 GNU R package for financial engineering -- f
ii r-cran-fimport 270.74-1 GNU R package for financial engineering -- f
ii r-cran-foptions 270.74-1 GNU R package for financial engineering -- f

description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers