Printer detection failed w. parallel port printer and USB-parallel port adaptor

Bug #92034 reported by Martin Leopold on 2007-03-13
4
Affects Status Importance Assigned to Milestone
foomatic-gui (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: foomatic-gui

Hi All.
I tried to install my parallel port printer using a USB-parallel-port adapter, however foomatic-gui inserted a device URI that did not work. Changing it manually or addidg it with gnome-cups-manager worked. The printer in question is an aging HP1100.

1. Inserting the USB-parallel port adapter the device "/dev/usblp0" shows up.
2. "sudo foomatic-gui" detects that a HP1100 is present and suggests appropriate drivers.
3. The queue printer is added, but does not print...

Looking at "/etc/cups/printers.conf" the following device has been added:
 DeviceURI usb:/dev/usblp0

Changing this to the following fixed the problem for me:
 DeviceURI parallel:/dev/usblp0

Trying out gnome-cups-manager it added the following device which also worked for me:
 DeviceURI usb://HP/LaserJet%201100

Cheers
Martin.

Adam Niedling (krychek) wrote :

What version of Ubuntu are you using? Is this still an issue?

Changed in foomatic-gui:
status: New → Incomplete
Martin Leopold (martin-leopold) wrote :

Hi Adam.
Thank you for taking the time to review the bug report. I can't recall what version of Ubuntu I used at that point in time, but I've just retested my old printer and using Intrepid the printer is automagically configured (and working) when pluged in. Same goes for foomatic-gui - both now choose the usb://HP url.

I'm changeing the status to fixed.

- Martin

Changed in foomatic-gui:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers