Ubuntu

HP LaserJet P2015 not printing with Postscript driver

Reported by Greg Aumann on 2007-03-31
20
Affects Status Importance Assigned to Milestone
foomatic-db (Ubuntu)
Medium
Unassigned
hplip (Ubuntu)
Low
Pascal De Vuyst

Bug Description

Binary package hint: cupsys

This is on feisty beta with all updates as of 31 March 2007. I set up this system to test this printer so only default packages are installed.

The printer is attached locally via USB port.

This printer is supported in feisty's version of hplip (but not edgy's) and is recognised correctly and installed without any errors.

I am trying to print the ubuntu test page from the printer properties page. There is no error displayed on the GUI when I print the test page. The printer's activity light flashes and after a few seconds the orange warning light starts flashing. According to the printer manual this indicates a continuable error. The manual suggests pressing the Go button and the printer will try to print whatever it can. When I do this the test page prints. It looks complete.

/var/log/cups/error_log is full of the following error:
E [31/Mar/2007:15:12:24 +0800] cupsdAuthorize: Local authentication certificate
not found!

This is the only kind of message in the error_log
No messages indicating errors in the other cups logs

ProblemType: Bug
Architecture: i386
Date: Sat Mar 31 14:55:10 2007
DistroRelease: Ubuntu 7.04
Uname: Linux tux 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Related branches

Till Kamppeter (till-kamppeter) wrote :

This looks like a bug in the driver for this printer (the "Local authentication certificate
not found!" in the error_log can be ignored).

Don, Raghu, can you look into this? Thanks.

Changed in cupsys:
importance: Undecided → Low

Please verify the InputSlot selection, verify that Manual feed is not selected.

Till Kamppeter (till-kamppeter) wrote :

Raghu, Don, can you check all the PPD files for PostScript printers and make sure that

- for all laser printers the default tray is tray 2 and not tray 1, as tray 1 is the bypass tray which usually does not contain paper.

- manual feed is turned off by default

For example in your PPD for my HP LaserJet 3390 Tray 1 is the default tray in the PPD. If a user does not see and correct it, he will also get prompted on the printer's front panel LCD.

Greg Aumann (greg-aumann) wrote :

I have tested the postscript driver with tray 1 (empty and closed), tray 2 and tray 1 (manual) (open and with paper).

In all cases I get the continuable error. This is with hplip 1.7.3 on feisty beta.

previously I have also had the same problem with hplip 1.7.1 on feisty beta and hplip 1.7.3 (sourceforge package) on edgy both with the postscript driver.

This problem does not occur on feisty beta with hplip 1.7.3 and the hpijs driver.

I suspect there is some kind of postscript error and the hp-toolbox doesn't give me anyway to turn on the option to print the postscript errors on paper so I have no way to access them.

According to the printer manual (page 78) there are four possible causes of a "Manual Feed or Continuable Error":
1) Manual feed
2) General continuable error
3) Memory configuration error
4) Personality/Job related error

On page 24 of the manual it states "The printer prints from tray 1 before attempting to print from other trays." I take it to mean that tray 1 should be the default tray (which it is in the drivers) and that it doesn't matter if it is empty. Anyway using tray 1 is not the cause of this error as evidenced by the tests above.

Till Kamppeter (till-kamppeter) wrote :

Can you try to print directly to the printer, without driver?

Do

lpr -o raw /usr/share/cups/data/testprint.ps

Changed in foomatic-db:
importance: Undecided → Low
status: Unconfirmed → Needs Info
Changed in hplip:
status: Unconfirmed → Needs Info
Greg Aumann (greg-aumann) wrote :

Just tried

lpr -o raw /usr/share/cups/data/testprint.ps

This printed the test page ok. No "Manual Feed or Continuable Error".

BUT
The activity light kept flashing. This indicates the printer is still processing data. So it seems that all is not completely well. However at least I didn't have to press a button to get the page out of the printer and the activity light eventually stopped flashing.

> This problem does not occur on feisty beta with hplip 1.7.3 and the hpijs driver.
Rejecting hplip task.

Changed in hplip:
assignee: nobody → pascal-devuyst
status: Needs Info → Rejected

Confirmed by duplicate.

Changed in foomatic-db:
importance: Low → Medium
status: Needs Info → Confirmed
Greg Aumann (greg-aumann) wrote :

I just retested this on a new install of Feisty (released version, with all updates installed). I changed to the postscript driver and printed two pages from an openoffice document. After some processing time in the printer the orange warning light started flashing. When I press the Go button for a second the pages were printed and the output looked correct. When I changed back to the hpijs driver (no other changes) the same two pages printed without the warning light flashing. The output from the postscript driver looks identical to that from the hpijs driver.

This is a problem as the postscript driver is the default driver for this printer and actually has recommended in parentheses next to the name of the driver.

mannheim (kronheim) wrote :

I had this problem with the same printer. The problem went away when I installed a modified PPD file, with the changes described in the "User Notes" at

http://openprinting.org/show_printer.cgi?recnum=HP-LaserJet_P2015

This problem does not occur any more with Hardy or Intrepid. Marking as fixed. If you still have the problem with Intrepid, please put the status back to "New".

Changed in foomatic-db:
status: Confirmed → Fix Released
Tim Waugh (twaugh) wrote :

But it looks like the PPD shipped with foomatic still contains the incorrect InputSlot code.

Is it definitely fixed?

Tim Waugh wrote:
> But it looks like the PPD shipped with foomatic still contains the
> incorrect InputSlot code.
>
> Is it definitely fixed?
>

The problem here was that several PostScript PPD files for HP printers
had tray 1 as the default tray. At HP printers tray 1 is the bypass tray
and tray 2 is the standard tray. I have checked the PPDs and all which
come with HPLIP are fixed. On OpenPrinting there was one broken PPD
which I have fixed now.

    Till

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers