Canon PIXMA IP2200 not in list - Driver Canon doesn't work

Bug #54233 reported by jlippens on 2006-07-27
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
foomatic-db (Ubuntu)
Medium
Unassigned
hal-cups-utils (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Kubuntu 6.06. My printer the Canon Pixma IP2200 is not in the list. I downloaded the drivers from Canon web site.
After installing the printer IP2200 wasin the list, but my printer doesn't work.

Prashant Vaibhav (mercurysquad) wrote :

Just adding info:

Numerous other models like Canon PIXMA iP1000, iP1500 are also not in the list. iP4000 is in the list but the driver doesn't work with iP1000. The Canon PIXMA range (especially the lower models like ip1000) are extremely popular and should be supported out-of-the-box by Ubuntu.

Binary close-source drivers are available from Canon's website, but in Suse RPM format. As far as I remember, it refuses to properly install on Ubuntu via alien, or if it installs, it doesn't really work. I'm sorry I can't test this further as I don't have access to that printer until January '07.

Till Kamppeter (till-kamppeter) wrote :

At FSG I am working on standards and a DDK for ditribution-independent printer driver packages. This gives the possibility to printer manufacturers to publish the drivers in a way that they work with all distributions and so problems like this should disappear.

See

https://features.launchpad.net/distros/ubuntu/+spec/printing-summit-lexington-and-ubuntu
https://features.launchpad.net/distros/ubuntu/+spec/printerdriverautodownload

Changed in foomatic-db:
importance: Undecided → Low
status: Unconfirmed → In Progress
Till Kamppeter (till-kamppeter) wrote :

Returning to "Confirmed", as it is not yet in progress downstream at Ubuntu, but only upstream at FSG.

Changed in foomatic-db:
status: In Progress → Confirmed

Raising importance to medium as per the wiki page on importances: "A problem with a non-essential hardware component (network card, camera, webcam, music player, sound card, power management feature, printer, etc.)"

Changed in foomatic-db:
importance: Low → Medium

I agree. Canon Pixma ip1700 is not supported by default, despite the fact that a workaround exists using the ip2200 2.60 driver, which is available in .rpm format.

The ip2200 driver can be found here: http://software.canon-europe.com/products/0010231.asp

Changed in foomatic-db:
status: Confirmed → Triaged

It looks like Ubuntu or Debian would not be able to distribute this rpm as the License includes the wording:

Licence: Your licence to use the Software is non-exclusive and, save as expressly stated in this Agreement, non-transferable. You are permitted to: (1) use one copy of the Software ("use" shall mean storing, loading, installing, executing or displaying the software) for your own internal purposes; (2) make a reasonable number of back-up copies of the Software in support of the permitted use, provided that all such copies include the Canon copyright notice as it appears in the original copy of the Software provided to you; (3) transfer the Software and the benefit of this Agreement to another person, provided that this person has agreed to accept the terms of this Agreement and you cease all use of the Software, transfer all copies of the Software you have made to that person or destroy all copies not transferred. If any transferee does not accept such terms then this Agreement automatically terminates.

Key point is part number (3): you can't share the code with anyone without destroying the code on your computer.

This would probably have to be handled similarly to how Flash-nonfree is handled.

Ubuntuxer (johannes-schw) wrote :

The Ubuntu versions Hardy and Intrepid detects my iP2200, but I can't print. The Canon support for Linux is absolut bad.
It would not be expensive to make also deb packages of the drivers.
Can we make something?

Uwe Schilling (uschilling) wrote :

Exactly the same problem here on Hardy. My system detects my iP2200 and autoinstalls the drivers, but I cannot print.

Ubuntuxer, Uwe Schilling,
Which printer driver is automatically detected for your iP2200 in Hardy or Intrepid?
You can find out after by running the following command from a terminal:
cat /etc/cups/ppd/<printername>.ppd | grep '*NickName'
Don't forget to replace <printername> by the name of your printer.

Uwe Schilling (uschilling) wrote :

us@styx:~$ cat /etc/cups/ppd/iP2200.ppd | grep '*NickName'
*NickName: "Canon PIXMA iP2000 - CUPS+Gutenprint v5.0.2 Simplified"

There is no "Canon PIXMA iP2200*" in the list of drivers, so it seems to me the next best thing to choose, and this is exactly what hardy automatically does.

That's a bug in the Plug 'n Print detection, it should not match the incorrect "Canon PIXMA iP2000 - CUPS+Gutenprint v5.0.2 Simplified" driver for your Canon PIXMA iP2200 printer.

Changed in hal-cups-utils:
status: New → Confirmed
Uwe Schilling (uschilling) wrote :

Here you can find an explanation of how to make the proprietary canon driver, which is provided in an *.rpm format, work in ubuntu: http://forums.linux-foundation.org/read.php?25,1032,8245#msg-8245

Actually, the post is meant as a workaround to get a PIXMA iP1300 working with the iP2200 drivers. However, it also did work for me for the iP2200 itself.

hal-cups-utils now auto-creates print queues only with an exact model match. Otherwise it starts system-config-printer for interactive queue setup.

Changed in hal-cups-utils (Ubuntu):
status: Confirmed → Fix Released

As the Canon drivers are non-free and also not redistributable by distros, this will not be fixed in any Ubuntu package. A fix would be an auto-downloadable driver package provided by Canon on the OpenPrinting server.

Changed in foomatic-db (Ubuntu):
status: Triaged → Invalid
Mantas Kriaučiūnas (mantas) wrote :

Working solution for lots Canon printers and multifunctions is described here: http://ubuntuportal.com/how-to-install-canon-printer-driver-for-linux-ubuntu/
All Canon printer drivers also will be included into official Baltix GNU/Linux software repository - http://ftp.akl.lt/Linux/Baltix/Baltix-Ubuntu-packages/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers