Printer options and other strings are not translatable

Bug #513168 reported by Sergio Zanchetta on 2010-01-27
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Unassigned
foomatic-db (Ubuntu)
Wishlist
Unassigned
gtk+2.0 (Ubuntu)
Wishlist
Unassigned
qt4-x11 (Ubuntu)
Wishlist
Unassigned
system-config-printer (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: system-config-printer

1) Go to System->Administration->Print
2) Select an already configured printer.
3) Right click on it and select "Properties".
4) Select "Policies" and you see that dropdown items are in English.
5) Select "Printer options" and you see that all the items are in English.

Affected releases:
All supported releases are affected by this bug, even Lucid Lynx.

Firefox printing support is affected too (it probably picks up from the same source)
1) Open Firefox
2) Go to File->Print...
3) "Image Quality" and "Advanced" tabs content is in English.

Many KDE apps are also affected
1) Open any KDE application which can print anything, e.g. open an image in Gwenview.
2) Go to File → Print.
3) Click »Properties« ans select the »Advanced« tab. All printer options there are untranslated.

Sergio Zanchetta (primes2h) wrote :

It affects all not-english users.

Changed in system-config-printer (Ubuntu):
importance: Undecided → High
tags: added: i18n
description: updated
Adi Roiban (adiroiban) wrote :

Hi,

I'm running Karmic and the printing configuration interface is translatated.

See screenshot.

Changed in ubuntu-translations:
status: New → Incomplete
Sergio Zanchetta (primes2h) wrote :

@Adi
As I wrote on the description, it's not the configuration interface altogether affected.
Just the policies dropdowns and the "printer options" content in system-config-printer, as well as the "Image Quality" and "Advanced" tabs content in Firefox.

Adi Roiban (adiroiban) on 2010-01-27
Changed in ubuntu-translations:
status: Incomplete → Confirmed
Milo Casagrande (milo) wrote :

Some of those strings could probably come from the gutenprint package/domain [1] (or at least are very similar). Could be worth to check that out to see if the problem is there instead of system-config-printer.

[1] http://translationproject.org/domain/gutenprint.html

Sergio Zanchetta (primes2h) wrote :

I checked that and it doesn't seem the correct package/domain to look into.

It's more like a foomatic/ppd issue.
I found out this really interesting page:
http://fedoraproject.org/wiki/Printing/I18n

I change the package affected accordingly, foomatic-db seems to be a good candidate.

affects: system-config-printer (Ubuntu) → foomatic-db (Ubuntu)
David Planella (dpm) wrote :

I've seen that bug 303273 looks quite similar, but I'm not sure it's duplicate, thus adding only the link for now.

Moritz Baumann (mo42) wrote :

I found a similar problem, as I already mentioned on the ubuntu-translators mailing list. Since I'm pretty sure it's the same bug, I don't want to open a new bug report for it.

1. Open any KDE application which can print anything, e.g. open an image in Gwenview.
2. Go to File → Print.
3. Click »Properties« ans select the »Advanced« tab. All printer options there are untranslated.

Moritz Baumann (mo42) on 2010-02-01
description: updated
Changed in foomatic-db (Ubuntu):
importance: High → Wishlist
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Wishlist
Changed in kdebase (Ubuntu):
importance: Undecided → Wishlist
Changed in system-config-printer (Ubuntu):
importance: Undecided → Wishlist
Till Kamppeter (till-kamppeter) wrote :

This is not really a bug, but a missing feature. The feature needs to be added in various packages, first, the PPD files which come from foomatic-db and also from every printer driver package need to get internationalized by making them globalized/multi-language. See http://www.cups.org/documentation.php/doc-1.4/spec-ppd.html, section "Globalized PPD Support". Only the PPDs of the Gutenprint driver and the Postscript printer PPDs of HPLIP are internationalized. Second, the printing dialogs of all applications and printer setup tools like system-config-printer need to support internationalized PPDs. Currently they ignore the translations in the PPDs and simply show the English text.

I am adding tasks for printer drivers and packages which contain printing dialogs or printer setup dialogs. If one or another package has already implemented the support for internationalized PPDs, please mark the task as fixed.

Changed in foomatic-db (Ubuntu):
status: New → Triaged
Changed in gtk+2.0 (Ubuntu):
status: New → Triaged
Changed in kdebase (Ubuntu):
status: New → Triaged
Changed in system-config-printer (Ubuntu):
status: New → Triaged
affects: kdebase (Ubuntu) → kdeadmin (Ubuntu)
affects: kdeadmin (Ubuntu) → qt4-x11 (Ubuntu)
Jonathan Thomas (echidnaman) wrote :

Aoops, forgot to add a comment. The KDE print dialog comes from Qt4 in KDE 4.x.

David Planella (dpm) on 2010-08-02
Changed in ubuntu-translations:
status: Confirmed → Triaged
importance: Undecided → Low
Thibault D (thibdrev) wrote :

Still true in the french Oneiric 11.10
See screenshot for identified missing translations.

Thibault D (thibdrev) wrote :

Still true in the french Precise 12.04 as of today.

tags: added: precise

In the still true series, still true in 13.04 ?

Hendrik Knackstedt (hennekn) wrote :

I assume it is but haven't checked.

system-config-printer has support for internationalized PPDs in 14.04 LTS

Changed in system-config-printer (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers