[Feisty, Gutsy] MASTER: HP LaserJet 1000/1005/1018/1020 don't work because of missing firmware

Bug #96454 reported by Marcus Moreira de Souza on 2007-03-26
180
This bug affects 4 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
Ubuntu
Wishlist
Unassigned
foo2zjs (Baltix)
Undecided
Unassigned
foo2zjs (Ubuntu)
Low
Unassigned
hplip (Ubuntu)
Medium
Unassigned
system-config-printer (Ubuntu)
Wishlist
Unassigned

Bug Description

I have installed a HP Laserjet 1020 on Ubuntu 7.04 beta1, but the printer don`t works.

I get this on printing...

Mar 26 10:06:17 zakk /usr/bin/hplj1020: Missing HP LaserJet 1020 firmware file /usr/share/foo2zjs/firmware/sihp1020.dl
Mar 26 10:06:17 zakk /usr/bin/hplj1020: ...read foo2zjs installation instructions and run ./getweb 1020

ProblemType: Bug
Architecture: i386
Date: Mon Mar 26 10:13:37 2007
DistroRelease: Ubuntu 7.04
Uname: Linux zakk 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

Till Kamppeter (till-kamppeter) wrote :

If you have an up-to-date Feisty, you can make your printer working by following the instructions in the log file. Run

getweb 1020

and put the sihp1020.dl into the /usr/share/foo2zjs/firmware/ directory. Then your printer will work.

A solution to make this automatic is available in printerdrake (which is planned to be added to Ubuntu Feisty+1):

https://blueprints.launchpad.net/ubuntu/+spec/printerdrake

Changed in cupsys:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Andrew Frank (frank-geoinfo) wrote :

i read the blueprint for printerdrake and hope it can be doen - printing on a laserjet 1000 on ubuntu is a nightmare (the instructions above did not work for me).

i followed the instructions on
http://foo2zjs.rkkda.com/
and now it works.

thank you for your effort!
andrew

Weiers Coetser (coetserw) wrote :

I found that "getweb 1020" downloaded a sihp1020.img file.

This needs to be converted to a sihp1020.dl file.

The command to do this is
sudo arm2hpdl sihp1020.img > sihp1020.dl

And then copy it to the /usr/share/foo2zjs/firmware/ folder.

Dan Munckton (munckfish) wrote :

I've got 1020 too. Here's a vote to get this automated.

Note that the LaserJet 1022 has built-in firmware. It should simply work with Ubuntu.

We have at the Andalusian ITC School Project more than 300 HP Lasejet 1020 and get this job automated for pupils and teachers its very important.

Weiers Coetser steps works properly for us too.

ehamberg (hamberg) wrote :

This package *should* fix this issue for LaserJet 1000, 1005 and 1020.

(Only tested on LaserJet 1020.)

If it doesn't work: apt-get remove it, and then reinstall to get the default package from the ubuntu repository.

Till Kamppeter (till-kamppeter) wrote :

ehamberg, thank you for the package, but note that we cannot ship this version with Ubuntu as the firmware files are copyrighted and therefore they cannot simply get redistributed.

ehamberg (hamberg) wrote :

I see. Well, I hope it can help people who just need their printer to work without having to build foo2zjs from source and install it manually.

However, the foo2zjs version in ubuntu should be upgraded so that all you have to do is to use webget to download the driver and put it in /usr/share/foo2zjs/firmware. I hope this is the case for gutsy.
I guess this could even be automated with a script so the user could get notified about the legal concerns and choose to download the firmware if one of these printers are detected, or..?

Weiers Coetser (coetserw) wrote :

Unless I am misunderstanding something we can already download the firmware using the Getweb command in Feisty. It is downloaded as an .img file. It needs to be converted to a .dl file before being copied over to usr/share/foo2zjs/firmware.

I wish that the process could somehow be automated in Gutsy so that the user don't have to know how to do this. It should just be done. Perhaps a user could be prompted about the legal copyright aspects before installing the firmware.

I guess that is not a driver issue, but a feature that would have to be built into CUPS. (?)

Can one perhaps let the restricted-manager download and install firmware files for these printers (and also copyrighted ICM profiles for the foo2zjs-supported color lasers)?

One could make the UDEV-triggered firmware-upload script call restriucted manager in the case that the appropriate firmware file is missing.

Changed in restricted-manager:
importance: Undecided → Wishlist

Script for get and install firmwares
(you must run this script by su or sudo)

#!/bin/bash
printers="1000 1005 1018 1020"
cd /tmp
for prn in $printers; do
    img="sihp${prn}.img"
    dl="sihp${prn}.dl"
    getweb $prn
    if [ -f $img ]; then
        arm2hpdl $img > /usr/share/foo2zjs/firmware/$dl
        rm $img
    fi;
done

Henrik Nilsen Omma (henrik) wrote :

Downloading printer firmware with restricted manager is an interesting option and something we should discuss more closely at UDS for Hardy (I'm making a note).

Till, is this particular issue solvable for Gutsy or should we wait for a more general solution?

Changed in restricted-manager:
status: New → Confirmed

I think it is a good idea to let the restricted manager install the firmware. It could use the script which giner has posted and the download could be triggered either by the installation of foo2zjs or by plugging a LaserJet 1000/1005/1018/1020 to the USB, using a HAL script. The printers are USB-only so triggering the firmware installtion by plugging the printer is always possible.

I think it will be easy to do for the maintainer/developer of the restricted manager to add this. To see how USB printers get handled by HAL, see the /usr/lib/hal/scripts/hal_lpadmin script on Gutsy and /usr/share/hal/fdi/policy/10osvendor/10-hal_lpadmin.fdi to see how to make such a script get used by HAL.

I have the LaserJet 1020 if you need to get tests done on the printer or certain commands applied to see how the printer answers, please tell me.

JohnFlux (johnflux) wrote :

I had to do:

rmmod ehci_hcd

before the printer would work for me.

Henrik Nilsen Omma (henrik) wrote :

Removing milestone as this requires introducing anew feature for Restricted Manager which is not possible a few days from RC freeze.

We should include the in a Just Works printing spec for Hardy.

There is not really a spec needed for this problem (whereas in general a "Make printing just work" spec is a great idea for the next UDS, only that I cannot participate in the UDS because I have an OpenPrinting meeting in Tokyo then).

I had some talk with HP on the OpenPrinting Summit 2007 in Montreal last week and they are working on this problem. See

https://www.linux-foundation.org/en/OpenPrinting/SummitMontreal

and

https://www.linux-foundation.org/images/5/5f/LinuxPrintingSummitHPLinuxPrintingUpdate.pdf
https://www.linux-foundation.org/images/b/bd/Plugins.pdf

So I think we should wait for HPLIP 2.7.10 and only if the problem is not addressed there think about calling foo2zjs scripts from the restricted-manager. I will add an HPLIP task. If HP solves this issue I will close the foo2zjs task and depending on HP's solution also the restricted-manager task.

Let's see what HP will do and decide before the end of this year. Then we have 3 months/2 alphas + 1 beta for intensive testing.

Changed in hplip:
status: New → Confirmed
importance: Undecided → Medium
status: New → In Progress

The new HPLIP 2.7.10 is now released by HP (http://hplip.sf.net/) and in this version the tool hp-setup downloads the firmware automatically from the internet as described in the presentations of the Printing Summit. But note that this version of HPLIP got only finished after Gutsy was finished. Perhaps we will backport a newer version of HPLIP from Hardy to Gutsy or I will package HPLIP as distribution-independent LSB package on OpenPrinting (http://www.openprinting.org/). Then you will be able to use the new HPLIP on Hardy.

Changed in hplip:
status: In Progress → Fix Released
Pjotr12345 (computertip) wrote :

Great, Till!

I would much prefer a backport from Hardy, because that is the easiest solution. Can you report it here, when the backport is available?

Thanks in advance, Pjotr.

Lars Larsson (ynef) wrote :

The owner of the server where you can download the foo2zjs firmware files has changed the file paths on his server. To access the firmware to HP 1018, I had to go to http://foo2zjs.rkkda.com/firmware/sihp1018.tar.gz (note the folder is no longer the root folder, but rather a subfolder called firmware). Thus, to work as intended, the getweb script has to be updated with these new changes in mind.

Firmware for the 1018 and 1020 is included in HPLIP 2.7.10.

On 11/4/07, Lars Larsson <email address hidden> wrote:
>
> The owner of the server where you can download the foo2zjs firmware
> files has changed the file paths on his server. To access the firmware
> to HP 1018, I had to go to
> http://foo2zjs.rkkda.com/firmware/sihp1018.tar.gz (note the folder is no
> longer the root folder, but rather a subfolder called firmware). Thus,
> to work as intended, the getweb script has to be updated with these new
> changes in mind.
>
> --
> [Feisty, Gutsy] MASTER: HP LaserJet 1000/1005/1018/1020 don't work because
> of missing firmware
> https://bugs.launchpad.net/bugs/96454
> You received this bug notification because you are a member of HP Linux
> Imaging and Printing, which is the bug contact for HPLIP.
>

Yes, HPLIP 2.7.10 is working well on Gutsy i386 with HP LJ 1018. Would be great to have it backported to Gutsy.

Lars, the getweb script is now corrected in all Ubuntu versions from Edgy on.

HPLIP 2.7.10 fixes this problem for the HP LaserJet 1018 and 1020 on Hardy.

Please use getweb on older Ubuntu versions.

Changed in hplip:
status: Confirmed → Fix Released
Changed in foo2zjs:
status: Confirmed → Fix Released

What does it mean? Will my HP1018 now function in the 7.10 version? If
programming is required please give the necessary code?
Sören Zetterman
----- Original Message -----
From: "Till Kamppeter" <email address hidden>
To: <email address hidden>
Sent: Wednesday, December 05, 2007 6:02 PM
Subject: [Bug 96454] Re: [Feisty,Gutsy] MASTER: HP LaserJet
1000/1005/1018/1020 don't work because ofmissing firmware

Lars, the getweb script is now corrected in all Ubuntu versions from
Edgy on.

HPLIP 2.7.10 fixes this problem for the HP LaserJet 1018 and 1020 on
Hardy.

Please use getweb on older Ubuntu versions.

** Changed in: hplip (Ubuntu)
       Status: Confirmed => Fix Released

** Changed in: foo2zjs (Ubuntu)
       Status: Confirmed => Fix Released

--
[Feisty, Gutsy] MASTER: HP LaserJet 1000/1005/1018/1020 don't work because
of missing firmware
https://bugs.launchpad.net/bugs/96454
You received this bug notification because you are a direct subscriber
of a duplicate bug.

The state changes in the bug are concerning Hardy, for 7.10 run

sudo apt-get update
sudo apt-get dist-upgrade
getweb 1018
sudo arm2hpdl sihp1018.img > /usr/share/foo2zjs/firmware/sihp1018.dl
rm sihp1018.img

Then turn off and turn on your printer and from now on it should work.

Christoph Langner (chrissss) wrote :

I've got here a HP LaserJet 1020 with a up to date hardy.

$ sudo apt-get update && sudo apt-get dist-upgrade
$ getweb 1020
$ sudo arm2hpdl sihp1020.img > /usr/share/foo2zjs/firmware/sihp1020.dl

doesn't help. When i try to print i still get error messages like

---
Dec 26 12:15:48 arbeitszimmer HP_LaserJet_1020?serial=JL05GME: INFO: open device failed; will retry in 30 seconds...
Dec 26 12:15:48 arbeitszimmer foo2zjs-wrapper: foo2zjs-wrapper -P -z1 -L0 -r1200x600 -p9 -s7 -m1 -n1
---

Pjotr12345 (computertip) wrote :

@Till Kamppeter and Christoph Langner:
The commands suggested by Till don't work with "sudo". They do work, however, when you first create a root account with "sudo su" and run the commands then, als root. That is how I did it with my Laserjet 1018 and it works flawlessly now (with Gutsy).

Strange that "sudo" doesn't work, though. This is the first time that I encountered a root command that cannot be executed with sudo.

Pjotr12345 (computertip) wrote :

Further clarification: the error message when running the last command line with "sudo", is this:
bash: /usr/share/foo2zjs/firmware/sihp1018.dl: Access denied

Christoph Langner (chrissss) wrote :

To be exact, i didn't pipe the output.

$ getweb 1020
$ arm2hpdl sihp1020.img > sihp1020.dl
$ sudo cp sihp1020.dl /usr/share/foo2zjs/firmware/

btw. there's also a hp tool which install a firmware.

$ sudo hp-setup

But this doesn't help too...

Could you guys try:

sudo rmmod ehci_hcd

first. I had to do that to get it to work for me.

Christoph Langner (chrissss) wrote :

Nope, doesn't help, remove ehci_hcd kernel module

$ sudo rmmod ehci_hcd

restarted cups

$ sudo /etc/init.d/cupsys restart

but when i print, i stilll get

$ tail -f -n 0 /var/log/messages
Dec 26 18:37:29 arbeitszimmer HP_LaserJet_1020?serial=JL05GME: INFO: open device failed; will retry in 30 seconds...
Dec 26 18:37:29 arbeitszimmer foo2zjs-wrapper: foo2zjs-wrapper -P -z1 -L0 -r1200x600 -p9 -s7 -m1 -n1

Saeed Moaddeli (s-moaddeli) wrote :

hi,
just wanted to confirm an earlier post; HP laserjet 1022 works out of the box on Gutsy. it doesn't need anything just plug it in and print.
Saeed

The 1022 has its firmware built in, so no installation of a firmware file is needed here.

John Dong (jdong) wrote :

I just approved a backport yesterday of Hardy's HPLIP to add support for some new Laserjets, so I am gonna mark this "fix released" on the Backports side.

Changed in gutsy-backports:
status: New → Fix Released
Pjotr12345 (computertip) wrote :

The problem is still there in Hardy Heron alpha 5.

Felipe Figueiredo (philsf) wrote :

I tried the firmware download from the backported hplip in gutsy (2.7.12-0ubuntu2~gutsy1) . It fails with the following error in the terminal:

warning: I/O timeout
error: Firmware file '/usr/share/hplip/data/firmware/hp_laserjet_1020.fw.gz' not found.

I checked and I didn't have a /usr/share/hplip/data/firmware/ dir, so I created it. Same results.

At last, I followed the getweb instructions above (actually, the script posted) and it worked fine. I just had to turn the printer off and on again. This is a 1020 model.

Pjotr12345 (computertip) wrote :

The problem is solved in Ubuntu Hardy Heron 8.04. Simply install HPLIP-Toolbox: Applications - Add/Remove.... Or hplip-gui in Synaptic, if you prefer.

When you start HPLIP Toolbox (in System - Preferences), it starts a sequence that allows you to download and install the missing firmware. Just say "OK" to each proposition that the toolbox puts before you. Have fun with your beautiful printer! :-)

I have an HP LaserJet 1020 and I have also tried the cenario of not having the firmware file installed on my box and hp-toolbox does not automatically start any sequence.

Do you have the firmware file already installed and hp-toolbox loads it only into the printer?

Did you click on any function in the hp-toolbox to start the firmare installation?

Or was it hp-setup which you have used?

HPLIP is *CLOSED SOURCE* w.r.t. LaserJet's 1000/1005/1018/1020 and M1005/M1006/M1505.

You should use the OPEN SOURCE "foo2zjs" driver found here:

http://foo2zjs.rkkda.com/

Follow ALL instructions.

Pjotr12345 (computertip) wrote :

@Till Kampeter:
The firmware wasn't installed previously. I haven't paid close attention, but I think hp-setup was part of the sequence. In the sequence, I was asked for my password.

This is what I did:
- Ubuntu Hardy Heron 8.04 with all updates processed
- I installed HPLIP Toolbox (Applications - Add/Remove.... - HPLIP Toolbox)
- I turned on the printer
- I waited until it was recognized by Hardy (couldn't do anything with it of course, because no firmware)
- then: System - Preferences - HPLIP Toolbox
- then the sequence started. As I already said, I think hp-setup was part of it. Some stuff was downloaded and installed as well; I suppose that was the firmware.

"Hewlett-Packard supports Open Source ideals and principals through the development and support of the HP Linux Imaging & Printing (HPLIP) software which supports nearly all IPG printing devices. Hewlett-Packard recognizes that there are alternatives to HPLIP in the market today and some of these software solutions provide satisfactory results for Hewlett-Packard customers.

Since HPLIP software is designed by engineers with an in-depth understanding of Hewlett-Packard’s imaging and printing technology, the result is software that provides outstanding print quality, with fast, efficient printing, scanning and faxing solutions. Furthermore, HPLIP customers can be assured that great care has been taken to ensure all licensing issues have undergone the strictest legal scrutiny, delivering a robust Open Source solution for their needs. "

Also I'd like to mention that in my *own personal opinion* postings such as above are not in the spirit of the opensource community and are not helpful in closing/resolving open defects/bugs such as this one. I also believe that it is against the spirit of the opensource community to inform users of what they "should" be using. It is not up to the developer and/or package to force users to use a specific application or package. It is to provide choices to users so they may best decide what works best for them.

Till: I'm going to try to reproduce on Ubuntu Beta with the Ubuntu hplip package and I'll report my findings.

Aaron

Pjotr12345 (computertip) wrote :

Some extra remarks:

- when I want to operate the HPLIP Toolbox now, it gives the error: device not found. The toolbox is still partly functional, though: I can influence the print quality settings.

- The only way to start HPLIP Toolbox now without errors, is to start it in the terminal, as root: gksudo hp-toolbox
I suppose that it is the same problem as with my separate Epson scanner, which will only start with sudo xsane. Intelligent hardware connected through USB, needs root permission to function. Some security setting buried deep in Linux, I fear.

- it wasn't necessary to start the Toolbox as root, to start the sequence I described in my earlier post.

- I have a Laserjet 1018.

Pjotr:

Sorry if I missed it, but can you run the printingbuginfo script and post the output?

https://wiki.ubuntu.com/PrintingBugInfoScript

Thanks!

A

I have also added my printingbuginfo script, as for me the toolbox does not automatically install firmware. I only get the HP tools downloading firmware if I run hp-setup and set up a print queue for my LJ 1020.

Aaron, does the hp-ttolbox really automatically download and install plug-ins/firmware files when you do nothing more than starting it? I only know that hp-setup does so when one sets up a print queue.

Pjotr12345 (computertip) wrote :

Here is my printingbuginfo.

Hope this helps. :-)

Hey Till,

Sorry for the delay. the hp-toolbox does not download and install the plugins/firmware, however hp-setup does (as you know). I'll be looking at this today things got a little hectic on friday.

I don't think the printer configuration tool has a process to configure firmware printers?

Pjotr,

Can you try running hp-setup -i to configure the printer and see if it works after?

Thanks!

Aaron

sebs (sebs) wrote :

Worked for Laserjet 1000 on Hardy. After running hp-setup i could finally print.

Pjotr12345 (computertip) wrote :

@Aaron:

No success.

- I powered on the Laserjet 1018 and connected it to my laptop.

- I ran the command sudo hp-setup -i (I could only run it as root). I answered all questions with the suggested answers.

- Afterwards, I started HPLIP Toolbox as user, through the menu: System - Preferences - HPLIP Toolbox.
Still the same error: ERROR: Device not found. Please check connection and power-on device. Again, HPLIP Toolbox was only partially functional.

- I started HPLIP Toolbox as root, with the terminal command: sudo hp-toolbox
Now, as before, HPLIP Toolbox gave no errors and was fully functional.

I hope that HPLIP Toolbox can become fully functional when accessed through the menu (as user therefore). That is much easier.

Hope this helps.

Greetz, Pjotr.

Pjotr,

Please run:

groups

and post the output.

I believe this is because the user isn't part of the scanner group.

If it's missing (which I'm 90% sure it will be):
Click System
Click Admin
Click Users and Groups
Click Unlock
Click Manage Groups
Click scanner
Click Properties
Put the check mark next to the user name.
Then Click OK, Close, Close

The printer should now work with the toolbox..

Till,

I think this is related to the hal problem...

Aaron

Here's the link to the other bug I think this is either now a duplicate of and or related to:

https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/195782

A

Pjotr12345 (computertip) wrote :

Aaron, I did what you suggested. But no success.

Groups read now:
pjotr@klaptop:~$ groups
pjotr adm dialout cdrom floppy audio dip video plugdev scanner fuse lpadmin admin
pjotr@klaptop:~$

I still get the same error when I start up HPLIP Toolbox as user (through the Gnome menu). In the terminal, when I start the toolbox with sudo, I get no errors.

By the way: what has this printer, which has no scanner built in, to do with the group "scanner" ?

Pjotr12345 (computertip) wrote :

Aaron: please ignore my previous message. Your suggestion works!
I had forgotten to connect then USB cable the first time. :-)

In short: after adding myself (user pjotr) to the scanner group, HPLIP Toolbox can be started with no errors, as user.

I still am a bit mystified as to what this printer is doing in the scanner group.... :-)

Hey! Whew. I was rather having a difficult time trying to figure out why that wouldn't work. Anyway it's because the scanner group gives the usb ports different permissions than what they are by default. If that makes sense. The ubuntu printing team is working on a long term solution, however I'm not sure of the status of it right now. It involves how the hal system detects the device and what permissions it gives to the devices.

Glad we got you working!

Till,

I know there has been a log of dialog on this..what's the status?

Aaron

Pjotr12345 (computertip) wrote :

@Aaron: Thanks a lot for your help and for the information! :-)

Greetz, Pjotr.

Felipe Figueiredo (philsf) wrote :

I had the same behaviour in Hardy final, as I had in Gutsy (as in my previous comment): running hp-toolbox in terminal produces "error: Firmware file '/usr/share/hplip/data/firmware/hp_laserjet_1020.fw.gz' not found." when I tried to download firmware from the GUI.

I can confirm that using the HPLIP gui to remove and recreate the printer configuration gave me the interactive procedure provided by hp-setup, which automatically downloaded the firmware and worked fine.

Apparently CUPS creating the printer spool directly (when USB printer is first connected) ignores the need for special drivers. Could hp-setup be used automatically instead for HP printers for a "Just Works" experience?

Yannis Tsop (ogiannhs) wrote :

I have an HP Laserjet 1005 printer and it does not work, unless I follow the instructions on http://foo2zjs.rkkda.com/. Be aware that the driver is attached through another computer and exposed to me via samba. The driver is not on the list and I cannot use the printer unless I rebuild the driver database.

Ivan Panchenko (wao-mail) wrote :

http://foo2zjs.rkkda.com Helped to solve the same problem for 1018

aelfwyne (lotherius) wrote :

I followed the getweb directions for my 1018, converted the file from .img to .dl and copied it, restarted the printer and things worked.

However, I would like to say that with Hardy, the HP-LIP tool does NOT install the firmware automagically for my LJ 1018. It showed the printer, but the printer failed to function until I copied the firmware over to the foo2zjs directory. So it doesn't "just work" yet, even with the closed source tool.

Another set of datapoints that may be helpful:
All under a clean install of Ubuntu 8.04 / HPLIP 2.8.2 / with a HP P1005.

1. Installing the printer with hplip results in the message:
 "Device is busy or in an error state.
 Please check the device and try again."
  and HPLIP Status tab says the printer is down "Service Request"
  and I cannot print a test page or download firmware to it.

2. HOWEVER I can print to it almost normally.
However jobs are never shown as completed and have to be manually deleted from thQ.
But I think this is a separate bug, cf http://foo2zjs.rkkda.com/forum/read.php?42,1207

3. Using sudo hp-setup -i
    gives exactly the same result as above.

4. Using the open source procedure in http://foo2xqx.rkkda.com/
   also seems to give the same result as above.
   the install seems to work, it prints ok,
BUT:
a. opening HPLIP again says the printer is busy or in an error state.
b. same error mentioned in 2. above.

5. Both methods 1 and 4 seem to cause the firmware to be updated,
as the printer seems to work again after being powered off in both cases,
but it is hard to be sure about this.

So there seems to be a problem in HPLIP 2.8.2 re detecting these printers as operational.
In my travels around the web over the last 36 hours (getting to this point)
many others seem to have the same problems mentioned in 1. and 2. above.

Hope this is helpful.

kgoeser (kevin-kevin-online) wrote :

The automagic driver install didn't really work for hardy and the LJ 1000. Hardy installed the driver and said it was ready to print. Sending the job to the printer worked, and cups marked the job as processing and finally as finished - the printer itself was pretty much unimpressed (nothing was printed). There were no error messages at all (syslog / cups log).

Re-installing the printer using hp-setup fixed the problem.

xlinuks (xlinuks) wrote :

I got HP LaserJet 1020 and it has never been working out of the box on Ubuntu, I had to compile drivers by hand.
Now I got Jaunty Jackalope alpha 3 and no changes.
The printer is listed correctly as "HP LaserJet 1020", it's enabled, but when I try printing, I get a printing queue but the most important thing - to actually print - doesn't work, the printer does nothing.

Please follow ALL instructions on:

http://foo2zjs.rkkda.com/

HP has provided a tool now to easily download the firmware for all their printers which need a firmware file. So you need not to compile the foo2zjs driver package or create a print queue with HP's hp-setup any more.

If you have HPLIP 2.8.12 (on Jaunty) do:

sudo hp-plugin

and follow the instructions on the screen. This downloads and installs the firmware files for all HP printers which need such a file. After that it looks for existing print queues of such printers and uploads the firmware files into them immediately. So you will be able to print from all auto-generated queues for these printers immediately after the tool has finished.

I plan to integrate the call of the tool into system-config-printer.

An additional hint: On a default installation of Jaunty you will perhaps get presented a text mode interface in your terminal window. To get a graphical interface, run

sudo apt-get install hplip-gui

before running hp-plugin. Note that this installs some MB of additional packages.

Please follow ALL instructions on:

http://foo2zjs.rkkda.com/

xlinuks (xlinuks) wrote :

I'm just amazed that this bug hasn't been fixed for years regardless of Ubuntu being known as a Linux OS that has very good hardware support.

Felipe Figueiredo (philsf) wrote :

@xlinuks: this is a bug report, not a forum. Don't complain here, it does no good to the bug, the report, Ubuntu or anyone else, including you.

The bug is marked as fixed. If you have information otherwise, provide it (you have given none). You don't have to compile anything, and if you have done so, you did because you were poorly informed. If all that remais is proper documentation, please say so.

If you actually *read* the whole report, you will see that it *is* fixed. It has been for a long time.

hplib is CLOSED source with respect to HP 1000/1005/1018/1020 and HP P1005, P1006, P1007, P1008 and others.

foo2zjs is OPEN source. Plus, it can do Color LaserJet's like HP CLJ 1600/2600 and CP1215.

Please follow ALL instructions on:

http://foo2zjs.rkkda.com/

Rick, I only suggest the user to do "sudo hp-plugin" for getting the firmware automatically downloaded. I do not suggest him to switch his print queue from ffo2zjs to hpijs. The firmware is always closed-source.

Sprax (sprax-567) wrote :

"The bug is marked as fixed. If you have information otherwise, provide it..."

I keep hearing it's fixed and yet my printer doesn't print (Ubuntu 8.10). Maybe there is some way to get it to work, I don't know. There seem to be a myriad of fixes posted online and after having tried a lot of then I haven't had any success yet. One thing is for sure though, the printer certainly doesn't work out of the box.

The only thing that has changed in recent versions of Ubuntu is that the printer is nowadays recognised - but it still doesn't print. That is, under some circumstances it does but >90% of the time it doesn't. I don't know why every once in a while it does. Anyway, definitely not fixed.

In Jaunty these printers (I tested with LaserJet 1020) and after once running "sudo hp-plugin" as described earlier here it works perfectly. The firmware gets automatically loaded into the printer whenever one plugs it in or turns it on (the transfer is indicated by blinking lights and the noise of rotating the mechanics). Note that the firmware transfer is delayed 3 seconds after connecting to avoid interferences with the power-on procedure of the printer. After that printing works perfectly with both drivers: foo2zjs or HPIJS with plug-in (the proprietary plug-in is downloaded and installed together with the firmware file).

If you have an HP printer set up by Jaunty but not working, have a look into the hp-toolbox (can be started by the right-click menu of the HP icon in the system tray). If there is an icon "Install required plug-in" on the "Actions" tab a plug-in, like a firmware file or a proprietary extension to HPIJS is needed. Clicking the icon runs "sudo hp-plugin".

Intrepid (HPLIP 2.8.7) has also the automatic plug-in downloader utility, but it is not linked to /usr/bin/. Start it via

sudo /usr/share/hplip/plugin.py

The only remaning problem is that hp-plugin is not automatically called when an appropriate print queue is set up. I am thinking abou adding appropriate functionality to system-config-printer.

Changed in system-config-printer:
importance: Undecided → Wishlist
status: New → Confirmed

One don't need compile foo2zjs from source. foo2zjs normaly works in ubuntu, but haven't firmware. It's only needed for firmware download and install. If you compile foo2zjs from source, you can catch a problems after next upgrade.

Simple script for donwload and install firmware:
https://bugs.launchpad.net/ubuntu/+source/foo2zjs/+bug/96454/comments/12

All add-on downloads for the foo2zjs driver packages (firmware for low-end HP lasers, color profiles for color lasers) can be downloaded and installed without needing to compile foo2zjs. The shell code of the "install-extra:" section of the Makefile in the main directory of the source tarball only needs to be moved into the getweb utility, so that for example

sudo getweb 1020

downloads the firmware for the LaserJet 1020, converts it and puts it into the correct directory, so that the UDEV rules can load it into the printer.

I have added functionality to automatically download HPLIP's proprietary plug-in if needed into system-config-printer upstream. The user gets informed about why the plug-in is needed or recommended and when he confirms it gets automatically downloaded. It contains also firmware files for all HP printers which need them, and also UDEV scripts for automatic upload of the firmware files into the printers.

Changed in system-config-printer:
status: Confirmed → In Progress
Pjotr12345 (computertip) wrote :

This sounds very promising. Thank you, Till Kamppeter! :-)

Fixed in system-config-printer and hal-cups-utils in Jaunty.

Now printers which need firmware do not get set up automatically any more. Instead, a notification appears at the system tray telling that the printer got detected and allowing the user to fire up system-config-printer with one click to do the setup of the printer. system-config-printer asks the user whether he wants do download the HP plugin and installs it if the user agrees. So the user will not get left with non-working print queues any more.

Changed in system-config-printer:
status: In Progress → Fix Released
Sprax (sprax-567) wrote :

Sounds great, thank you very much!

chrone (chrone81) wrote :

i use the hp-setup method and it works with laserjet p1006, but the printer reacts so slow, it took nearly one minute to print a job. :(

i also have tried to use the foo2zjs, download the .tar.gz file and recompile the driver as on the site instruction. but sometimes it just won't print! :(

i've been waiting for 6 months but still no progress on this.

chrone (chrone81) wrote :

i use the hp-setup method and it works with laserjet p1006, but the printer reacts so slow, it took nearly one minute to print a job. :(

i also have tried to use the foo2zjs, download the .tar.gz file and recompile the driver as on the site instruction. but sometimes it just won't print! :(

i've been waiting for 6 months but still no progress on this.

chrone, please open a new bug on HPLIP. The slowness of your printer isb a problem of the driver.

USB issue.

You have a USB problem, then. Put it on a different USB controller or change the cables. Don't use an unpowered hub!

Follow ALL instructions for p1006 on:

http://foo2xqx.rkkda.com/

Mario S. Mommer (mommer) wrote :

Hi,

I have an hp1005 here. The first time I went to K-> Applications -> Settings -> Printing, I actually was able to ask for the "plugin" to be installed. However, it simply does not work. I did not find the .dl file that needs to be uploaded to the printer anywhere on the hard disk (I searched with 'find / -name \*.dl') so I think it did not download it. In any case, whatever it downloads never gets uploaded to the printer.

On the disappointing side: the printer gets detected as a brand new printer every time I turn it on. After repeating that a few times I have five identical printers, the last one of which is "hp-laserjet-1005-series5" (probably a different bug)

I have a fresh install of Jaunty, using kubuntu-desktop, on a fujitsu siemens lifebook e-series.

chrone, the slowness can also be caused by bug 382379. Please follow the instructions there.

Mario S. Mommer, if your printer setup toll popped up some dialog to install a plugin, the downloaded plugin is from HP. HP does not use the .dl extension for the firmware file. HP puts all firmware files into /usr/share/hplip/data/firmware/. They have the extension .fw.gz and the names are the model names of the printers to which they belong. If you have a file hp_laserjet_p1005.fw.gz in that directory all is OK. Note that the files are gzipped, so they cannot be sent directly to the printer without gunzipping.

To check whether the firmware gets actually loaded into the printer, unplug the USB cable and plug it again. After plugging the lights of the printer should flash and the mechanics rotate. This tells that the printer has loaded the firmware. Attach /var/log/syslog if this does not happen.

For the repeated auto-setup please attach your /etc/cups/printers.conf and post the output of "lsusb", "lpstat -v" and "lpinfo -v". Then unplug and replug the USB cable (or turn off and turn on the printer) and wait until the printer setup procedure ends (Printer with magnifier in notification area/system tray disappearing). Then attach /var/log/syslog.

Note that the repeated auto-setup is a different bug. Please open a new bug report (package hal-cups-utils) and post/attach the stuff I asked you for there.

chrone (chrone81) wrote :

thanks Till Kamppeter, it seems too hard for me newbie, and it seems karmic solve this problem. until now, i purchase windows license and use it as print server, the easiest way. :)

Changed in foo2zjs (Ubuntu):
status: Fix Released → Confirmed
Changed in hplip (Ubuntu):
status: Fix Released → Confirmed
Changed in foo2zjs (Baltix):
status: New → Confirmed
Changed in system-config-printer (Ubuntu):
status: Fix Released → Confirmed
Chris Coulson (chrisccoulson) wrote :

pramodpushpak - Please don't just re-open bug tasks without leaving any explanation

Changed in foo2zjs (Ubuntu):
status: Confirmed → Fix Released
Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
Changed in foo2zjs (Baltix):
status: Confirmed → Fix Released
Changed in system-config-printer (Ubuntu):
status: Confirmed → Fix Released
affects: restricted-manager (Ubuntu) → ubuntu
Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.