Samsung CLP-315 printer driver doesn't work

Bug #306004 reported by ®om on 2008-12-07
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
foo2zjs (Ubuntu)
Medium
Unassigned

Bug Description

I just bought a Samsung CLP-315 printer.

I plugged it using USB to my laptop, it is automatically detected and the appropriate driver (Samsung CLP-315 Foomatic/foo2qpdl (recommended)) is used.

But when I print a page, it always prints :
SPL-C ERROR - Including Corrupted Header Data
  POSITION : 0x0 (0)
  SYSTEM : src/xl_image
  LINE : 811
  VERSION : SPL-C 5.35 11-20-2007

®om (rom1v) wrote :

If it can help :

$ grep foo2qpdl /var/log/messages | tail -6
Dec 7 17:26:24 rom-laptop foo2qpdl-wrapper: foo2qpdl-wrapper -z2 -r1200x600 -p2 -m0 -s1 -d1 -z2 -C10 -Gsamclp300-0.icm
Dec 7 17:26:25 rom-laptop foo2qpdl-wrapper: gs -sPAPERSIZE=a4 -g9920x7016 -r1200x600 -sDEVICE=pbmraw -dCOLORSCREEN -dMaxBitmap=500000000
Dec 7 17:26:25 rom-laptop foo2qpdl-wrapper: foo2qpdl -r1200x600 -g9920x7016 -p2 -m0 -n1 -d1 -s1 -z2 -u 150x100 -l 150x100
Dec 7 17:40:10 rom-laptop foo2qpdl-wrapper: foo2qpdl-wrapper -z0 -r1200x600 -p2 -m0 -s1 -d1 -z2 -C10 -Gsamclp300-0.icm
Dec 7 17:40:11 rom-laptop foo2qpdl-wrapper: gs -sPAPERSIZE=a4 -g9920x7016 -r1200x600 -sDEVICE=pbmraw -dCOLORSCREEN -dMaxBitmap=500000000
Dec 7 17:40:11 rom-laptop foo2qpdl-wrapper: foo2qpdl -r1200x600 -g9920x7016 -p2 -m0 -n1 -d1 -s1 -z2 -u 150x100 -l 150x100

Probably an upstream bug in foo2qpdl, see http://foo2zjs.rkkda.com/forum/read.php?58,1412

Changed in cups:
importance: Undecided → Low
status: New → Confirmed
Changed in foo2zjs:
importance: Low → Medium

Follow ALL instructions on:

http://foo2qpdl.rkkda.com

albamayo (tzarinakaterina1) wrote :

hi guys. Just exactly the same "error". before arrived here I was in http://foo2qpdl.rkkda.com, but, Rick, I was a bit confused. you start speaking about foo2qpdl driver which offer support for CLP-315 and then change to foo2zjs which doesn't support it. the instructions in http://foo2qpdl.rkkda.com are related to foo2zjs driver. even you supply the command line to download this second driver instead the foo2qpdl for the CLP-315. I'm quite a newbie on GNU/Linux, so sure my ignorance is behind my confusion.
thanks for the help.

Till Kamppeter (till-kamppeter) wrote :

The foo2zjs package contains all the foo2... drivers, therefore foo2zjs is mentioned in all instructions.

The case that the CLP-315 does not work seems to be really an upstream bug for me,

Till Kamppeter (till-kamppeter) wrote :

Try also Samsung CLP-300 with the SpliX driver. Does this work for you?

2008-09-18 Rick Richardson <email address hidden>
        * foo2qpdl: Change unknown value (margin?) based on page size.

Till Kamppeter (till-kamppeter) wrote :

The cited upstream fix is in the current Jaunty package of SpliX (2.0.0 final). Please test.

®om, albamayo,
Is this still a problem with Jaunty?

Changed in foo2zjs (Ubuntu):
status: Confirmed → Incomplete
®om (rom1v) wrote :

It works with Karmic (but the printer is detected as CLP-310, so it doesn't work, I have to manually select CLP-315 driver and it works).

Changed in foo2zjs (Ubuntu):
status: Incomplete → Fix Released
Bill Yiannakos (billyiannakos) wrote :

Still got this problem on Koala (9.10)
Actually, I can print pdf, doc files and images through gimp, but I get the error when trying to print odt files and webpages through firefox...

Paul Belanger (pabelanger) wrote :

Same issue here. Samsung CLP-310N printer detected as CLP-310 driver, failed to print. Manually set it to CLP-315 driver, worked.

Luigi Maselli (grigio) wrote :

The bug is still present in Ubuntu 9.10 even if 315 driver is chosen. I noticed that Firefox is unable to print (see the error on top) while Epiphany can..
Maybe something about the old cups implementation. i dunno
see also:
http://foo2zjs.rkkda.com/forum/read.php?58,2334,2334

Changed in foo2zjs (Ubuntu):
status: Fix Released → Confirmed
Bill Yiannakos (billyiannakos) wrote :

This issue has already been closed by the original bug reporter.

Luigi Masselli, Ubuntu 9.10 is no longer supported. Please update to a supported release: Ubuntu 10.04 or higher.
If you still have a problem please file a new bug report by typing the following command on a terminal (this will give us some usefull information about your printing setup):
ubuntu-bug cups

Changed in foo2zjs (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers