Firmware upload fails in hplj1000 script

Bug #1003843 reported by Job Noorman on 2012-05-24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
foo2zjs (Ubuntu)

Bug Description

The hplj1000 script fails to upload firmware files when both the usb_printerid program and the CUPS USB backend are found.

The problem is that the hplj1000 script first tries to upload the firmware by catting it to /dev/usb/lpN and sending this process to the background.
Then, while this process is probably still running, it *also* tries to upload the firmware using the CUPS USB backend.

The net result is that both methods fail.

I have attached a patch that fixes the problem. The patch makes sure that either the cat method *or* the CUPS method is used (it tries in that order) but never both.

Another note: the upload happens too fast on my system (the script sleeps 3s before uploading) and this causes the printer to not work (although the firmware *is* uploaded). If I increase the sleep to 10s, it does work. Should I file another bug for this?

Some more info:
$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

$ apt-cache policy printer-driver-foo2zjs
  Installed: 20111202dfsg0-1ubuntu1
  Candidate: 20111202dfsg0-1ubuntu1
  Version table:
 *** 20111202dfsg0-1ubuntu1 0
        500 precise/main i386 Packages
        100 /var/lib/dpkg/status

Job Noorman (jobnoorman) wrote :
description: updated

The attachment "Patch that fixes the problem" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Till Kamppeter (till-kamppeter) wrote :

Thank you for the patch, I will overtake it in a slightly different form, letting the script first try to upload the firmware with the USB CUPS backend and only if it fails fall back to the usblp kernel module.

Changed in foo2zjs (Ubuntu):
status: New → Triaged
Till Kamppeter (till-kamppeter) wrote :

Note for Precise users: The firmware problem should get solved by the CUPS package in -proposed, see bug 1000253.

Changed in foo2zjs (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package foo2zjs - 20111202dfsg0-1ubuntu2

foo2zjs (20111202dfsg0-1ubuntu2) quantal; urgency=low

  * debian/patches/96-hplj1000-fix-cups-usb-backend-firmware-upload.patch:
    The firmware upload script tried to upload the firmware via the usblp
    kernel module and with the CUPS USB backend (using libusb) in parallel,
    making the printer crash (LP: #1003843).
 -- Till Kamppeter <email address hidden> Fri, 25 May 2012 19:29:00 +0200

Changed in foo2zjs (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers