Update fonts-noto-color-emoji to 20180810 release for Unicode 11

Bug #1788256 reported by Jeremy Bicha on 2018-08-21
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fonts-noto-color-emoji (Ubuntu)
Low
Jeremy Bicha
Bionic
Low
Jeremy Bicha

Bug Description

Impact
======
Google has released the latest version of their color emoji font that is shipped with Android 9 "Pie".
The new release is a major upgrade, including support for the new Unicode 11 standard. Some existing emoji were tweaked.

We need this update in Ubuntu 18.04 LTS so that the new emoji work.

https://blog.emojipedia.org/whats-new-in-unicode-11-0/
https://blog.emojipedia.org/inclusive-emojis-coming-back-to-android/
https://emojipedia.org/emoji-11.0/

Note that several of the new combined emoji (like red-haired man 👨‍🦰 ) will need an update elsewhere (pango?) to display as combined.

Test Case
=========
1. After installing the update, visit
https://unicode.org/emoji/charts/full-emoji-list.html
The browser column should match the Google column

2. You can also use the Characters app shipped by default to verify that the emoji seem to work ok.

Regression Potential
====================
Except for being rebuilt from source in Ubuntu, this is basically the same emoji font Google ships in the latest Android.

We can easily verify that the update is successful by completing the 2 test cases above.

Other Info
==========
Google does a major update of this font once per year corresponding with the annual release of the new Unicode standard and Android.

Proposed pango update:
https://gitlab.gnome.org/GNOME/pango/merge_requests/15

gtk3 could then probably use an update to get the new emoji in its emoji chooser.

Most other GNOME distros (including Debian Testing and Fedora 28) also use this font as their default color emoji font.

Jeremy Bicha (jbicha) on 2018-08-21
description: updated
Jeremy Bicha (jbicha) on 2018-08-21
description: updated
Changed in fonts-noto-color-emoji (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-noto-color-emoji - 0~20180810-1

---------------
fonts-noto-color-emoji (0~20180810-1) unstable; urgency=medium

  * New upstream release (LP: #1788256)
    - This major update introduces support for the new Unicode 11 standard

 -- Jeremy Bicha <email address hidden> Tue, 21 Aug 2018 15:26:49 -0400

Changed in fonts-noto-color-emoji (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-08-28
Changed in fonts-noto-color-emoji (Ubuntu Bionic):
assignee: nobody → Jeremy Bicha (jbicha)
Changed in fonts-noto-color-emoji (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha) on 2018-08-28
description: updated
Changed in fonts-noto-color-emoji (Ubuntu Bionic):
status: Triaged → In Progress
Jeremy Bicha (jbicha) on 2018-08-30
description: updated
Steve Langasek (vorlon) wrote :

The debdiff for this upload includes changes e.g. to fonts-noto-color-emoji-0~20180810/emoji_aliases.txt that change existing behavior:

-1f46a;1f468_200d_1f469_200d_1f466 # FAMILY -> family: man, woman, boy

The Makefile has started to pass a -S "small metrics" flag to emoji_builder.py that was not previously in use; and previously the script defaulted to "big metrics".

How do we ascertain that these changes do not regress consumers of these fonts that may be relying on the existing behavior? I don't think the regression potential has been adequately addressed with the current SRU template.

Changed in fonts-noto-color-emoji (Ubuntu Bionic):
status: In Progress → Incomplete
Jeremy Bicha (jbicha) wrote :

emoji_aliases.txt removal
-------------------------
In the previous version, Google used the "family: man, woman, boy" emoji to represent the generic "family" emoji. In this version, Google created a unique emoji to represent the "family" emoji. The justification is that all 3 people in the new emoji are now represented as gender-neutral.

Emoji #408 is the family emoji. Emoji #409 is "family: man, woman, boy".
https://unicode.org/emoji/charts/full-emoji-list.html

Or compare https://emojipedia.org/family/ with https://emojipedia.org/family-man-woman-boy/
If you click Google, you can see the historical versions. This update is Android 9.0; the version currently in 18.04 LTS is Android 8.0.

The same thing happened with the "couple with heart" emoji, #404 and #405 where the 2 adults now are gender-neutral.
https://emojipedia.org/couple-with-heart/
https://emojipedia.org/couple-with-heart-woman-man/

So yes, this is a behavior change, but it is expected that there are some changes to existing emoji. For a more dramatic example, see LP: #1766736 (the pistol emoji change which landed in Ubuntu 18.04 LTS just before release).

Not to mention the dramatic style change in Android 7.0. See https://blog.emojipedia.org/rip-blobs-google-redesigns-emojis/

Small glyphs
------------
The small glyphs change was made in this commit:
https://github.com/googlei18n/noto-emoji/commit/e571d53e0299bd1

The commit message says that "android has legacy tooling that expects small metrics" but they'll eventually switch to using big metrics. But on closer reading, it does look like this used to build big metrics before this change, so let me ask for clarification.

Jeremy Bicha (jbicha) wrote :

Small glyphs (continued)
------------------------
I asked. Is this sufficient?

https://github.com/googlei18n/noto-emoji/issues/233

Changed in fonts-noto-color-emoji (Ubuntu Bionic):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fonts-noto-color-emoji (Ubuntu Bionic):
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

Since the small-metrics thing is switchable, it seems that we could entirely bypass the question of whether it might cause regressions by changing debian/rules to pass SMALL_METRICS= to the make invocation?

Jeremy Bicha (jbicha) wrote :

Re-uploaded with the suggested change from comment 6.

Changed in fonts-noto-color-emoji (Ubuntu Bionic):
status: Confirmed → In Progress

Hello Jeremy, or anyone else affected,

Accepted fonts-noto-color-emoji into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fonts-noto-color-emoji/0~20180810-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in fonts-noto-color-emoji (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.