Wrong rendering of the sinhala font comes along with ttf-freefont.

Bug #756279 reported by Kunchana on 2011-04-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fonts-freefont (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ttf-freefont

There is a problem in the rendering of sinhala fonts with ibus and scim both input methods. this problem wxist in the ttf-freefont. when I remove the ttf-freefont its working fine with the thirdparty sinhala unicode fonts. but there are some other important packages get removed along with the ttf-freefont like printer drivers etc.

ttf-sinhala-lklug has the correct rendering instead of freefont.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ttf-freefont 20090104-7
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
Date: Sun Apr 10 09:16:14 2011
Dependencies:

InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ttf-freefont

Steve White (stevan-white) wrote :

Hi Kunchana!

A lot of work went into the Sinhala range in the 2010-09-19 release of FreeFont.
It has been reviewed by native-language speakers and declared quite good.

Download it here
    http://ftp.gnu.org/gnu/freefont/

(Note you'll have to remove the files from the old versions, and there are unfortunate package dependencies.
The best way I know, is unfortunately to delete the installation files from the old version by hand.)
Then you also need to delete font caches. As root
    fc-cache -fv
and probably it's good also to do it as your normal user.

Unfortunately it takes a long time for software changes to get through debian and then to Ubuntu.

And... the right place to report FreeFont bugs, is on the FreeFont site,
     https://savannah.gnu.org/bugs/
Nobody told us about your problem. I only stumbled across it by chance.

Cheers!

Changed in ttf-freefont (Ubuntu):
status: New → Fix Committed

Thank you for taking the time to report this bug and helping to make Ubuntu better. The version of ttf-freefont has been updated since you reported this issue (Ubuntu 11.10 and the upcoming 12.04 provide version 20100919-1 instead of version 20090104-7) -- could you test wether this is still an issue?

Thanks again and we appreciate your help.

PS @Steve: Thanks for looking at the bugs in the Ubuntu bug tracker. Please note that the "Fix commited" status for an Ubuntu bug means that the fix will be shortly uploaded *in Ubuntu*. If you want to register that it is committed upstream (i.e. in the GNU SVN), please open an "upstream bug task" by clicking the "also affects project" link. You can then optionally register an upstream bug report if one exists, this way launchpad will automatically update the status. See https://wiki.ubuntu.com/Bugs/Status for more details.

Changed in ttf-freefont (Ubuntu):
status: Fix Committed → Incomplete
Steve White (stevan-white) wrote :

Hi Marcel,

Thanks for deal ing with this, and for your advice.

This fix is already in Ubuntu. So your changing the status to "Fix Committed-Incomplete" is in error.

I will communicate privately to you about improvements to your system that might reduce such errors.

Hi Steve,

for bug triaging, we normally set the status to "incomplete" if we are waiting for any answer from the original reporter. You are right, if the fix is in Ubuntu, the status should be "Fix released". However, we normally wait for a confirmation that the issue is really fixed for the OP before setting such a status -- it might be that Kunchana's issue is not completely addressed yet. If we do not get any response, the issue will be closed, though.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Adolfo Jayme (fitojb) on 2015-01-15
affects: ttf-freefont (Ubuntu) → fonts-freefont (Ubuntu)
Changed in fonts-freefont (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.