Monospace not Monospace in Japanese

Bug #1595822 reported by Mingye Wang on 2016-06-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fonts-android (Ubuntu)
Undecided
Unassigned

Bug Description

I found this problem when testing FF for bug #1595414, on an English installation of 14.04. In short:

$ LC_ALL='ja_JP.UTF-8' fc-match 'Monospace'
DroidSansFallbackFull.ttf: "Droid Sans Fallback" "Regular"

Mingye Wang (artoria2e5) on 2016-06-24
description: updated
Mingye Wang (artoria2e5) wrote :

Bug apparently caused by this part in 65-droid-sans-fallback.conf:

        <alias>
                <family>monospace</family>
                <prefer>
                        <family>Droid Sans Fallback</family>
                </prefer>
        </alias>

Since no language-selector files related to ja are installed, I am moving this problem to fonts-droid.

affects: language-selector (Ubuntu) → fonts-droid (Ubuntu)
Mingye Wang (artoria2e5) wrote :

Firefox exhibits similar broken behavior with lang='zh-CN', but not lang='zh-Hans-CN'. (What am I looking at..)

Gunnar Hjalmarsson (gunnarhj) wrote :

This issue was fixed in xenial via <https://bugs.debian.org/787149>. OTOH, we don't use the fonts-droid-fallback package by default in Ubuntu. The replacement conf file in xenial (64-language-selector-prefer.conf) is correct in this respect.

The question is if the issue is important enough to backport the fix to trusty. If you think it is, please feel free to prepare a patch and accomplish a SRU in accordance with <https://wiki.ubuntu.com/StableReleaseUpdates>.

affects: fonts-droid (Ubuntu) → fonts-android (Ubuntu)
Changed in fonts-android (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.