installed fonts are not actually available for use

Bug #904043 reported by Adrian Mariano on 2011-12-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Undecided
Unassigned
xfonts-100dpi (Ubuntu)
Undecided
Unassigned

Bug Description

The xfonts-75dpi package is also affected.

I installed ubuntu and found that certain standard X fonts such as adobe-courier were not available. Curiously, installing the xfonts-75dpi and xfonts-100dpi packages did *not* fix the problem. The fonts remained unavailable. They did not show up with xfontsel and when used (e.g. by xterm -fn) they are subsitututed by other fonts. Even more curiously, a bit of probing revealed that the font files were actually present in /usr/share/fonts/X11.

Based on this article from 2008, it appears that this is a long standing and pervasive problem:

http://www.oreillynet.com/linux/blog/2008/02/where_did_the_courier_and_helv_1.html

I followed the method described in this article and added

   <dir>/usr/share/fonts/Type1</dir>
   <dir>usr/share/fonts/X11</dir>

to the file /etc/fonts/conf.avail/51-local.conf and found that this made the fonts available.

So in short, the installer for these fonts is broken. It installs the files but does not make the necessary changes to the font configuration files so that the fonts can actually be used.

Description: Ubuntu 11.10
Release: 11.10

xfonts-100dpi:
  Installed: 1:1.0.3
  Candidate: 1:1.0.3
  Version table:
 *** 1:1.0.3 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
        100 /var/lib/dpkg/status
adrian> apt-cache policy xfonts-75dpi
xfonts-75dpi:
  Installed: 1:1.0.3
  Candidate: 1:1.0.3
  Version table:
 *** 1:1.0.3 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xfonts-100dpi 1:1.0.3
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic-pae 3.0.9
Uname: Linux 3.0.0-14-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Dec 13 20:09:49 2011
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/tcsh
SourcePackage: xfonts-100dpi
UpgradeStatus: Upgraded to oneiric on 2011-12-10 (3 days ago)

Adrian Mariano (avm4) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfonts-100dpi (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers