package libfontconfig1 2.8.0-3ubuntu1 failed to install/upgrade: './usr/share/doc/libfontconfig1/AUTHORS' is different from the same file on the system

Bug #828014 reported by Ofer Cohen on 2011-08-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Undecided
Loïc Minier

Bug Description

It just happened suddenly.
On upgrading the package stuck on installation on some command (updmap-sys).

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: libfontconfig1 2.8.0-3ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Wed Aug 17 15:38:42 2011
DpkgHistoryLog:
 Start-Date: 2011-08-17 15:38:34
 Commandline: apt-get -f install
 Install: libfontconfig1:i386 (2.8.0-3ubuntu1, automatic)
DpkgTerminalLog:
 Unpacking libfontconfig1:i386 (from .../libfontconfig1_2.8.0-3ubuntu1_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libfontconfig1_2.8.0-3ubuntu1_i386.deb (--unpack):
  './usr/share/doc/libfontconfig1/AUTHORS' is different from the same file on the system
DuplicateSignature:
 Unpacking libfontconfig1:i386 (from .../libfontconfig1_2.8.0-3ubuntu1_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libfontconfig1_2.8.0-3ubuntu1_i386.deb (--unpack):
  './usr/share/doc/libfontconfig1/AUTHORS' is different from the same file on the system
ErrorMessage: './usr/share/doc/libfontconfig1/AUTHORS' is different from the same file on the system
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: fontconfig
Title: package libfontconfig1 2.8.0-3ubuntu1 failed to install/upgrade: './usr/share/doc/libfontconfig1/AUTHORS' is different from the same file on the system
UpgradeStatus: Upgraded to oneiric on 2011-08-17 (0 days ago)

Related branches

Ofer Cohen (oc666) wrote :
Changed in fontconfig (Ubuntu):
status: New → Confirmed
Loïc Minier (lool) wrote :

on my system, /usr/share/doc/libfontconfig1/AUTHORS is a (looping) symlink to ../libfontconfig1/AUTHORS, but that's not what the .deb ship and I couldn't find any maintainer snippet creating these symlinks at install time, so I'm a bit puzzled; if I compare the .debs for i386 they both ship a real file, and the contents match

Loïc Minier (lool) wrote :

This seems to be a result of the Ubuntu changes getting lost due to a bogus sync in the oneiric cycle, then being restored; people who have had the bogus version installed will have broken symlinks.

Loïc Minier (lool) on 2011-08-18
Changed in fontconfig (Ubuntu):
assignee: nobody → Loïc Minier (lool)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fontconfig - 2.8.0-3ubuntu2

---------------
fontconfig (2.8.0-3ubuntu2) oneiric; urgency=low

  * Remove /usr/share/doc/$pkg in preinst if it's a symlink for packages
    fontconfig, fontconfig-config, libfontconfig1-dev and libfontconfig1-dbg;
    fixes upgrades from older borken packages; LP: #828014. This can be
    dropped after oneiric, as noted in the preinst snippets.
 -- Loic Minier <email address hidden> Thu, 18 Aug 2011 16:40:46 +0200

Changed in fontconfig (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers