After upgradeing to Lucid, unexpectedly-using bitmap font in Japanese Environment (upgrading regression)

Bug #569442 reported by Fumihito YOSHIDA on 2010-04-24
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned
language-selector (Ubuntu)
Low
Arne Goetje
Lucid
Low
Arne Goetje
ttf-wqy-zenhei (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: fontconfig

When Hardy/Karmic users with Japanese environment upgrade to Lucid,
Desktop fonts are unexpectedly-using bitmapped/Traditonal Chinese.

This is regression of UX/Desktop.

How to reproduce:
   1) Install Karmic or Hardy with Japanese languages.
     ( or, install with other langs,
       "System" -> "Administartion" -> "Language Support" ->
         set "Japanese" to first at 'Language for menus and windows:')
   2) Upgrade with "update-manager -d"
   3) When upgrade completed, your desktop is render with bitmap-fonts.

Actual result:
   - Desktop are render with
     - Traditonal Chinese
     - bitmap-fonts
     ("WenQuanYi Zen Hei" / ttf-wqy-zenhei).

Expected result:
   - Desktop are render with
     - Japanese
     - outline-fonts
     (such as "Takao P Gothic"(ttf-takao-pgothic).

Workaround in "24 Apr 2010":
 a) exec: "sudo apt-get remove ttf-wqy-zenhei"

 b) exec: " sudo rm /etc/fonts/conf.d/44-wqy-zenhei.conf /etc/fonts/conf.d/66-wqy-zenhei-sharp.conf"
    *and* patch to /etc/fonts/conf.avail/65-nonlatin.conf (see attachment).

Background:
 ttf-wqy-zenhei is included some fontconfig configs, it provides two too-fast timing configurations.
   - "sans/sans-serief" default font changing to Zen Hei: 44-wqy-zenhei.conf
   - "sans/sans-serief" bitmap enabling: 66-wqy-zenhei-sharp.conf

Related(not dupulicate)bugs:
 - https://bugs.launchpad.net/ubuntu/+source/ttf-wqy-zenhei/+bug/475240
 - https://bugs.launchpad.net/ubuntu/+source/ttf-wqy-zenhei/+bug/521163

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: fontconfig 2.8.0-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Sat Apr 24 23:56:52 2010
ProcEnviron:
 LANGUAGE=C
 PATH=(custom, user)
 LANG=C
 SHELL=/bin/zsh
SourcePackage: fontconfig

Fumihito YOSHIDA (hito) wrote :
tags: added: patch
Fumihito YOSHIDA (hito) wrote :

notes:
 In other hands, this problem triggererd by binding level change at latest language-selector. It changed (strong => same) at /etc/fonts/conf.d/69-language-selector-ja-jp.conf (from language-selector), if we can change this binding, problems could be fixed.

Fumihito YOSHIDA (hito) wrote :
Ingo Karkat (inkarkat) wrote :

I can confirm this problem; just upgraded from Karmic to Lucid, and all Japanese fonts in the desktop, menus and applications (my LANG=ja_JP.UTF-8) looked "strange", "Mincho"-like.

Fixed the problem via (there's a typo in the original description, it's "-wqy-", not "-qwy-":
    sudo apt-get remove ttf-wqy-zenhei

Fumihito YOSHIDA (hito) wrote :

@Ingo: I fix typo, thanks!

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Arne, could you look at this issue and advice on what we should be doing?

Changed in ttf-wqy-zenhei (Ubuntu):
importance: Undecided → Low
Changed in fontconfig (Ubuntu):
importance: Undecided → Low
Changed in ttf-wqy-zenhei (Ubuntu):
assignee: nobody → Arne Goetje (arnegoetje)
Arne Goetje (arnegoetje) wrote :

Fixed in my language-selector branch, this can be SRU'ed. For fontconfig, would need to test if the necessary changes don't cause other regressions. Using the fix in language-selector is the safe bet for now.

Changed in language-selector (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
assignee: nobody → Arne Goetje (arnegoetje)
Changed in ttf-wqy-zenhei (Ubuntu):
assignee: Arne Goetje (arnegoetje) → nobody
status: New → Invalid
Changed in fontconfig (Ubuntu):
status: New → Triaged
Changed in ttf-wqy-zenhei (Ubuntu Lucid):
importance: Undecided → Low
status: New → Invalid
Changed in language-selector (Ubuntu Lucid):
assignee: nobody → Arne Goetje (arnegoetje)
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :

I've sponsor the fix from Arne which needs to be reviewed by the sru team now

Accepted language-selector into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

could somebody who had the issue test the update and confirm if it's working or not? that's required to get it approved as an official lucid update

Fumihito YOSHIDA (hito) wrote :

sorry for lazy testing, I test with proposed language-selector:0.58, karmic -> lucid upgrading looks good for me.

Its working.

tags: added: verification-done
removed: verification-needed
Changed in fontconfig (Ubuntu Lucid):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.5.8

---------------
language-selector (0.5.8) lucid-proposed; urgency=low

  * update fontconfig/69-language-selector-ja-jp.conf: change binding to
   'strong' (LP: #569442)
 -- Arne Goetje <email address hidden> Wed, 16 Jun 2010 00:28:34 +0800

Changed in language-selector (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.6.1

---------------
language-selector (0.6.1) maverick; urgency=low

  [ Michael Vogt ]
  * fix dialog returning too early (issue with latest aptdaemon)
  * fix deprecation warning
  * build with include-links
  * dbus_backend/ls-dbus-backend: move dbus.mainloop.glib integration way up
    to avoid crash on startup (LP: #598619) (LP: #596603)

  [ Arne Goetje ]
  * clean up data/pkg-depends:
    - remove enigmail-locale- (LP: #588254)
    - remove obsolete kde-i18n- and koffice-i18n- entries, packages have
      been removed from archive in Lucid.
  * update fontconfig/69-language-selector-ja-jp.conf: change binding to
    'strong' (LP: #569442)
  * LocaleInfo.py: check for file permissions (LP: #598802)
  * fix depreciation warnings
  * debian/control: add pyqt4-dev-tools to Build-Depends
 -- Arne Goetje <email address hidden> Fri, 02 Jul 2010 17:21:08 +0800

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Nobuto Murata (nobuto) wrote :

According to the reporter's comment and language-selector status, this issue was fixed in language-selector. I will mark as Invalid against fontconfig task because this bus is not fontconfig one.

Changed in fontconfig (Ubuntu Lucid):
status: New → Invalid
Changed in fontconfig (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers