Ubuntu

Lucida Console and Andale Mono render badly in bold

Reported by Forest on 2009-01-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Forest
fontconfig (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Forest
freetype (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Forest
msttcorefonts (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Forest

Bug Description

I use Lucida Console 9 (a Microsoft TrueType font) as my terminal font. It worked great in Hardy, but after upgrading to Intrepid, bold rendering looks awful, as if the bytecode hinter has gone haywire. This is puzzling because the other TrueType fonts I have tried look fine, as does non-bold Lucida Console. I am attaching screen shots to demonstrate the difference between hardy and intrepid.

My font settings:
  Anti-aliasing is disabled.
  Hinting is set to Full.
  Sub-pixel hinting is disabled.

(All these are set in the xfce User Interface Preferences. I normally use xfce, but the same problem is visible when I log in using gnome.)

Forest (foresto) wrote :

It's worth noting that the bad rendering occurs outside the Terminal application as well, such as in the window manager's font picker.

Forest (foresto) wrote :

dpkg-reconfigure fontconfig-config showed that those settings were correct, and changing them didn't help.

Forest (foresto) wrote :
Forest (foresto) wrote :
Forest (foresto) wrote :

Bug 262028 may be related.

Forest (foresto) wrote :

I just noticed that Andale Mono, part of the msttcorefonts package, shares this problem. It's as if the bytecode hinter (not the auto-hinter) gets disabled for bold text.

Forest (foresto) wrote :

The patch in bug 293643 did not help.

Forest (foresto) wrote :

Added cairo because it seems to be related to Intrepid's font rendering (and recent changes therein).

antistress (antistress) wrote :

maybe Bug #305394 is related ?

Alexander Sack (asac) wrote :

not a cairo issue.

Changed in cairo (Ubuntu):
status: New → Invalid
Alexander Sack (asac) wrote :

not freetype, nor msttcorefonts.

Changed in freetype (Ubuntu):
status: New → Invalid
Changed in msttcorefonts (Ubuntu):
status: New → Invalid
Alexander Sack (asac) wrote :

i think the cleanup done up to 2.6.0-1ubuntu11 will fix this issue. if you still see this with latest jaunty packages reopen this bug. thanks!

Changed in fontconfig (Ubuntu):
status: New → Fix Released
Forest (foresto) wrote :

I'm now using Jaunty, which includes 2.6.0-1ubuntu12.

Lucida Console bold and Andale Mono bold now look correct when rendered in the terminal window. However, they are still rendered badly in the font picker, text editor, and everywhere else.

Forest (foresto) wrote :

Re-opening, since the problem was only fixed for one application.

Changed in fontconfig (Ubuntu):
status: Fix Released → Confirmed
Forest (foresto) wrote :

Interesting:
Lucida Console bold and Andale Mono bold share this problem, which made me think that the freetype bytecode hinter had been disabled for monospaced bold fonts. However, Times New Roman, which is also a Microsoft monospaced font, seems fine in bold. Maybe some special fontconfig rules are being applied to some of these fonts but not to others?

Forest (foresto) wrote :

Correction to that previous comment: Courier New is the monospaced font that renders fine. (Times New Roman is not monospaced, obviously.)

I can't reproduce this problem is lucid or maverick. Is is still an issue for you ?

Changed in fontconfig (Ubuntu):
status: Confirmed → Incomplete
Forest (foresto) wrote :

Yes, it's still an issue. Lucida Console bold is fine in my terminal window, but it still renders badly in the font picker, text editor (mousepad), and possibly other programs as well. I'm running Xubuntu Lucid.

It's odd that the problem only occurs in certain applications. Could it be a disagreement between XSETTINGS and fontconfig about the hintstyle to use for certain fonts?

Changed in fontconfig (Ubuntu):
status: Incomplete → New
Forest (foresto) wrote :

Firefox 3.6.8 and Chromium 5.0.375.99~r51029 also exhibit the problem. For example, bad rendering of Andale Mono Bold on this page:

http://www.braintreepaymentsolutions.com/docs/python

(Note the keywords in the code examples: import, if, elif, else, print, for, and in.)

I'm now on Ubuntu Lucid.

Forest (foresto) wrote :

Screen shot of Andale Mono rendering correctly in normal weight and incorrectly in bold, on the same web page.

summary: - Lucida Console bold renders badly after upgrade to intrepid
+ Lucida Console and Andale Mono render badly in bold
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers