Ubuntu

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

Reported by Fernando Miguel on 2008-09-17
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aptitude (Ubuntu)
Undecided
Unassigned
fontconfig (Ubuntu)
Undecided
Unassigned
pidgin (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I got this updates today and the system was left unconfigured with the error :
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

Running Intrepid.

Mackenzie Morgan (maco.m) wrote :

What are the permissions on the file? /var/cache/debconf/config.dat

Changed in xulrunner-1.9:
status: New → Invalid
Changed in pidgin:
status: New → Invalid
Changed in fontconfig:
status: New → Invalid
Changed in firefox-3.0:
status: New → Invalid

# ls -lah /var/cache/debconf/config.dat
-rw-r--r-- 1 root root 42K 2008-09-18 08:39 /var/cache/debconf/config.dat

After a reboot (almost) everything seems ok.
Other then landscape-client bug #270862, and pidgin crashing all around (uploading now a 30MiBs backtrace).

Should this ticket be marked as invalid? or leave it open until we can figure what cause it?

Mackenzie Morgan (maco.m) wrote :

I'd rather leave it open so we can try to figure out why the upgrade failed.

Were you upgrading from Hardy to Intrepid, or was a regular update within Intrepid?

Changed in update-manager:
status: New → Incomplete
description: updated

regular update-manager on intrepid.

Jean-Baptiste Lallement (jibel) wrote :

This was due to a concurrent access to the debconf database. This is usually a very temporary and not reproducible situation. If you can reproduce it then use the following command to find the culprit:
fuser -v /var/cache/debconf/config.dat

I'm closing this report but don't hesitate to reopen if you can reproduce it and provide more information. Thanks.

Changed in update-manager:
status: Incomplete → Invalid

np Jean... i no longer see it... thanks

Derek White (d-man97) wrote :
Download full text (3.4 KiB)

After attempting upgrade today I had several errors with mysql, cups, and dpkg in general.
It all seems to be caused by the following error:

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

I also noticed the same error in syslog (or .xsession-errors) earlier, while using startupmanager.
Upon opening synaptic:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

Prior to doing that, the recommended 'fuser -v /var/cache/debconf/config.dat' returned nothing.
Returning to startupmanager...it seems that su-to-root (and other related programs) was active, running something that gave the following in my .xsession-errors log:
---
A new version of /boot/grub/menu.lst is available, but the version installed
currently has been locally modified.

  1. install the package maintainer's version
  2. keep the local version currently installed
  3. show the differences between the versions
  4. show a side-by-side difference between the versions
  5. show a 3-way difference between available versions
  6. do a 3-way merge between available versions (experimental)
  7. start a new shell to examine the situation

What would you like to do about menu.lst?
---

So, in my case, this was a startupmanager problem - it has no facility to notify the user that this input is required...and waiting in a non-existent terminal. I added this as a bug a while ago, but no one is currently supporting startupmanager and the bug has gone without a fix. I dunno, maybe it's a problem with 'sudo update-initramfs -u'? To whomever this problem belongs, in my case initramfs noticed either the menu.lst~ or the menu.lst.backup and wanted user input to decide whether or not to update menu.lst - and startupmanager has no such facility to let the user know.

Upon killing ucf, this showed up in my .xsession-errors:

/usr/sbin/update-grub: line 1036: 11220 Terminated ucf --debconf-ok --debconf-template grub/update_grub_changeprompt_threeway --three-way "$buffer" $ucf_menu_file

So, maybe it's update-grub's fault? =)

Anyways, after killing ucf, 'sudo dpkg --configure -a' still didn't fix the packages, so I found su-to-root still running and End'd it; but still, update-grub & 'python /usr/sbin/startupmanager' (after attempting an End) are in a Zombie state and cannot be End'd or Kill'd. Even 'su kill -9' or -anything won't end them. ... OK, so 'sudo killall -g update-grub' finally killed them all.

Then I ran 'sudo dpkg --configure -a' and it told me that mysql-server-5.0 was in really bad shape and I should re-install it, the other 4-5 packages were configured OK. After a 'sudo apt-get install --reinstall mysql-server-5.0 mysql-server' everything seems OK and the 'sudo dpkg --configure -a' returns cleanly. And, most importantly, my LAMP server is functional again!

This may have been, and probably was, over-kill...but at least you know this error can be over-come (without a logout or restart). It is also not a bug of any one program, many different circumstances can cause this "debconf: DbDriver"config":" error to r...

Read more...

Gioele Barabucci (gioele) wrote :

This also happens when doing an installation from the Lucid minimal CD using the "expert mode".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptitude (Ubuntu):
status: New → Confirmed
Bill Ruddock (bill-ruddock) wrote :

Happened to me when aptitude (or presumably any other apt package manager) was interrupted by an accidental X restart. No process shown to be using the file with 'fuser -v /var/cache/debconf/config.dat'. Killing the still running but inactive aptitude and dpkg processes did not work. System reboot fixed the problem.

Micah Gersten (micahg) on 2011-12-18
no longer affects: firefox-3.0 (Ubuntu)
no longer affects: xulrunner-1.9 (Ubuntu)
Daniel Hartwig (wigs) wrote :

Please demonstrate how this is caused by a bug in aptitude.

Changed in aptitude (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for aptitude (Ubuntu) because there has been no activity for 60 days.]

Changed in aptitude (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments