"/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy

Bug #243130 reported by Shirish Agarwal
22
Affects Status Importance Assigned to Milestone
Wine
Invalid
Undecided
Unassigned
fontconfig (Ubuntu)
Low
Matthias Klose

Bug Description

Binary package hint: fontconfig

Hi all,
 I updated fontconfig and this is what happened (extracted from log at /usr/share/apt/term.log)

Setting up fontconfig (2.6.0-1ubuntu1) ...
Updating font configuration of fontconfig...
Cleaning up category cid..
Cleaning up category truetype..
Cleaning up category type1..
Updating category type1..
Updating category truetype..
Updating category cid..
Updating fontconfig cache for /usr/share/fonts/truetype/latex-xft-fonts /usr/share/fonts/truetype/ttf-indic-fonts-core /usr/share/fonts/truetype/ttf-sil-gentium /usr/share/fonts/truetype/thai /usr/share/fonts/truetype/ttf-lao /usr/share/fonts/truetype/ttf-arabeyes /usr/share/fonts/truetype/ttf-liberation /usr/share/fonts/truetype/ttf-dejavu /usr/share/fonts/truetype/ttf-devanagari-fonts /usr/share/fonts/truetype/ttf-gujarati-fonts /usr/share/fonts/truetype/ttf-bengali-fonts /usr/share/fonts/type1/gsfonts /usr/share/fonts/truetype/dustin /usr/share/fonts/truetype/ttf-tamil-fonts /usr/share/texmf/fonts/type1/public/lm /usr/share/fonts/truetype/ttf-bitstream-vera /usr/share/fonts/truetype/ttf-punjabi-fonts /usr/share/fonts/truetype/unfonts /usr/share/fonts/truetype/baekmuk /usr/share/fonts/truetype/ttf-kannada-fonts /usr/share/fonts/truetype/ttf-telugu-fonts /usr/share/fonts/truetype/freefont /usr/share/fonts/truetype/ttf-oriya-fonts /usr/share/fonts/truetype/arphic /usr/share/fonts/truetype/ttf-malayalam-fonts /usr/share/fonts/truetype/kochi /usr/share/fonts/truetype/ttf-mgopen /usr/share/fonts/truetype/ttf-gentium /usr/share/fonts/truetype/msttcorefonts
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Updating fontconfig cache for /usr/share/fonts/truetype/latex-xft-fonts /usr/share/fonts/truetype/ttf-indic-fonts-core /usr/share/fonts/truetype/ttf-sil-gentium /usr/share/fonts/truetype/thai /usr/share/fonts/truetype/ttf-lao /usr/share/fonts/truetype/ttf-arabeyes /usr/share/fonts/truetype/ttf-liberation /usr/share/fonts/truetype/ttf-dejavu /usr/share/fonts/truetype/ttf-devanagari-fonts /usr/share/fonts/truetype/ttf-gujarati-fonts /usr/share/fonts/truetype/ttf-bengali-fonts /usr/share/fonts/type1/gsfonts /usr/share/fonts/truetype/dustin /usr/share/fonts/truetype/ttf-tamil-fonts /usr/share/texmf/fonts/type1/public/lm /usr/share/fonts/truetype/ttf-bitstream-vera /usr/share/fonts/truetype/ttf-punjabi-fonts /usr/share/fonts/truetype/unfonts /usr/share/fonts/truetype/baekmuk /usr/share/fonts/truetype/ttf-kannada-fonts /usr/share/fonts/truetype/ttf-telugu-fonts /usr/share/fonts/truetype/freefont /usr/share/fonts/truetype/ttf-oriya-fonts /usr/share/fonts/truetype/arphic /usr/share/fonts/truetype/ttf-malayalam-fonts /usr/share/fonts/truetype/kochi /usr/share/fonts/truetype/ttf-mgopen /usr/share/fonts/truetype/ttf-gentium /usr/share/fonts/truetype/msttcorefonts
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy
Regenerating fonts cache... done.

Now how show I clear the lcdfilterlegacy stuff. I'm on a CRT monitor .

Related branches

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

Now the last line comes whenever I start any application

Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy

This happened only after fontconfig got updated.

Arne Goetje (arnegoetje)
Changed in fontconfig:
assignee: nobody → doko
Revision history for this message
Brian Rogers (brian-rogers) wrote :

Same here, confirming. I get the warning when most programs start:
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdfilterlegacy

Changed in fontconfig:
status: New → Confirmed
Revision history for this message
Arne Goetje (arnegoetje) wrote :
Revision history for this message
Arne Goetje (arnegoetje) wrote :

What happened is, that the constant name has been fixed in the source package already, but the new config file did not get installed in /etc/fonts/conf.avail.

Revision history for this message
John Vivirito (gnomefreak) wrote :

so far i only see this in gajim

Revision history for this message
Matthias Klose (doko) wrote :

fixed in 2.6.0-1ubuntu2

Changed in fontconfig:
status: Confirmed → Fix Released
Revision history for this message
Laurent Bigonville (bigon) wrote :

Reopening, I get the same warning with 2.6.0-1ubuntu2 in intrepid

"Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdlegacy"

Changed in fontconfig:
status: Fix Released → New
Revision history for this message
Hew (hew) wrote :

Confirming. I get this output when running Wine. I can confirm that both /etc/fonts/conf.d/53-monospace-lcd-filter.conf and /etc/fonts/conf.avail/53-monospace-lcd-filter.conf files exist and are identical.

fontconfig/intrepid uptodate 2.6.0-1ubuntu2

Changed in fontconfig:
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fontconfig - 2.6.0-1ubuntu3

---------------
fontconfig (2.6.0-1ubuntu3) intrepid; urgency=low

  * Recognize const value "lcdfilterlegacy", introduced before upstream
    did introduce "lcdlegacy". LP: #243130.

 -- Matthias Klose <email address hidden> Fri, 12 Sep 2008 19:34:01 +0200

Changed in fontconfig:
status: Confirmed → Fix Released
Revision history for this message
Hew (hew) wrote :

I'm still getting the same error with this latest package, unfortunately.

Changed in fontconfig:
status: Fix Released → New
Revision history for this message
graingert (tagrain) wrote :

yes this is true

Revision history for this message
Hew (hew) wrote :

This is not a Wine problem, closing against Wine. Confirming for fontconfig again based on the above comment.

Changed in wine:
status: New → Invalid
Changed in fontconfig:
status: New → Confirmed
Revision history for this message
Bremm (bremm) wrote :

Confirmed bug on 2.6.0-1ubuntu3. Same issue here:

Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdlegacy

$ apt-cache show fontconfig
Package: fontconfig
Priority: optional
Section: utils
Installed-Size: 308
Maintainer: Ubuntu Core developers <email address hidden>
Original-Maintainer: Keith Packard <email address hidden>
Architecture: amd64
Version: 2.6.0-1ubuntu3

Revision history for this message
Bremm (bremm) wrote :

Looks like 2.6.0-1ubuntu4 solved the problem. Thanks!

Revision history for this message
Hew (hew) wrote :

Marking as fixed, fontconfig 2.6.0-1ubuntu4 has solved this issue.

Changed in fontconfig:
status: Confirmed → Fix Released
Revision history for this message
Sebastian Keller (skeller) wrote :

I still have the following entry in my .xsession-errors:
Fontconfig warning: "/etc/fonts/conf.d/11-lcd-filter-lcddefault.conf", line 9: invalid constant used : lcddefault
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdlegacy

However it appears there only once, at login time.

Revision history for this message
dvo (mueller8) wrote :

I got similar warnings when launching skype and other programs, e.g.
Fontconfig warning: "/etc/fonts/conf.d/11-lcd-filter-lcddefault.conf", line 9: invalid constant used : lcdlegacy
My workaround was simply to rename or remove the file in question, apparently without any negative effect.

Revision history for this message
Sebastian Keller (skeller) wrote :

I just found what was causing it here: dropbox, it shipped its own version of libfontconfig. I guess it is the same for the statically linked skype and other programs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers