[hardy] fonts smaller after update

Bug #174229 reported by Matt on 2007-12-05
20
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
fontconfig (Baltix)
Undecided
Unassigned
fontconfig (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

I have just installed the fonts update in Hardy (fontconfig-config_2.4.2-1.2ubuntu1_all.deb), and the fonts for firefox (2.0.0.10) have got smaller even though the default size is still at 16. All other font sizes on the desktop, in the file browser etc seems fine.

Tom Vetterlein (smbm) wrote :

Font rendering is also messed up in QT apps too. I tried to add fontconfig to this report too but I seem to have failed!

Same here. The fonts look like crap.

Kow (kow) wrote :

Same here. This is beyond firefox. They are smaller and more pixelated (lower res?). I would confirm the status but it applies to a crapton of packages so... I will confirm it by comment.

Kow (kow) wrote :

Just a guess but fontconfig maybe?

Murat Gunes (mgunes) wrote :

Stating the version of Firefox and Ubuntu you're using and "the font update" you've mentioned would be beneficial, especially for future reference. Please edit your report to include these details.

Changed in fontconfig:
status: New → Invalid
Kow (kow) wrote :

I can confirm this bug. In particular it is with the font configuration files provided by the binary package fontconfig-config. A temporary workaround is to force install the gutsy version of fontconfig-config. Ignore any broken package info (update manager will not work for the time being.) I simply do not have the time to go through all of the font configuration file changes between the 2 versions right now to figure out exactly where the problem is in the configuration.

Changed in fontconfig:
status: New → Confirmed
Kow (kow) wrote :

I will invalidate firefox as it is not the problem.

Kow (kow) wrote :

Actually I will not. This may be 2 different bugs. I have not had any issues with firefox besides the one I mentioned with fontconfig-config. Perhaps the reporter can try my previously mentioned suggestion and comment on his results. This would invalidate firefox as the cause if my workaround works.

Matt (mattbutler-2) wrote :

I installed fontconfig-config_2.4.2-1.2ubuntu1_all.deb and it didn't seem to make much of a difference in Firefox

btw im using hardy and firefox version 2.0.0.10

Murat Gunes (mgunes) on 2007-12-07
description: updated
Kow (kow) wrote :

Okay well we have 2 different bug reports in 1 then, doh. Also dont post updates to the initial post because the whole point in adding comments is to retain the timeline. Now everyone reading the bug report is going to wonder why you installed an old version of fontconfig-config when they haven't read the comments yet. Honestly I have not had any issues with firefox except for the fontconfig problem which is a global issue (it handles rendering of pretty much every font however its effects on GTK are minimal compared to QT).

Kow (kow) wrote :

For those with the same issue as me here is what I did to workaround it (and keep an unbroken repository). First, force remove fontconfig-config (the new hardy version.) This will break your system temporarily! Make sure the folder /etc/fonts and all of its subfolders and files are deleted. Then install the gutsy version. Make a complete backup of /etc/fonts to some folder in your home directory (to be safe choose this local.) Next, install the hardy version. Delete /etc/fonts and then copy over your backup. This will maintain a working local repository and your fonts will be fixed. I know these steps are somewhat ambiguous but this workaround is not meant for someone with little experience. I'm not sure if deleting /etc/fonts (without a replacement) would render X11 unusable, it shouldn't... but its worth mentioning the risk. If you dont want to risk it then wait. The fonts are not unreadable by any means but I agree they do look like crap. I noticed 2.4 -> 2.5 of fontconfig added braile support which may have to do with the problem. I'll take the time this weekend to go through and figure out exactly what is causing this in the /etc/fonts configuration files.

Kow (kow) wrote :

I forgot to mention, with the workaround I posted above: fontconfig-config will likely not uninstall cleanly if it ever comes to apt wanting to do so. Its not a major problem. I can't figure out a better way at the moment to maintain a working apt repository and fix the fonts. I'm not sure why the fontconfig packages depend on the latest version of fontconfig-config because the gutsy version (2.4.something) works just fine with 2.5.

Che Guevara (che-guevara-3) wrote :

Reasigned to fontconfig-config

Che Guevara (che-guevara-3) wrote :

Never mind that, same package, but marked firefox as invalid, since its not an FF problem

Changed in firefox:
status: New → Invalid

Could this be related to the fact that fontconfig-config installs files in /etc/fonts/conf.d/ which should be in /etc/fonts/conf.avail/ instead (i.e. all the non-symlink files)?

On Wed, Dec 05, 2007 at 09:07:19PM -0000, Matt wrote:
> Public bug reported:
>
> Binary package hint: firefox
>
> I have just installed the fonts update, and the fonts for firefox have
> got smaller even though the default size is still at 16. All other font
> sizes on the desktop, in the file browser etc seems fine.

does starting firefox with

export MOZ_DISABLE_PANGO=1
firefox

from the command line help?

Do you see the same issue with firefox-3.0 in hardy?

 - Alexander

Tom Vetterlein (smbm) wrote :

This is still affecting QT4 apps for me but QT3 apps seem unaffected.

knarf (launchpad-ubuntu-f) wrote :

The font problems with QT4 are not related to this issue but are caused by a bug in QT4 which makes it display all fonts without antialiasing when there is at least one font on the system for which antialiasing has been disabled. On Gutsy/Hardy there is at least one such font: ttf-arphic-uming. Either remove this font or apply the attached patch to /etc/fonts/conf.d/70-ttf-arphic-uming.conf.

please stop sending me Bug reporting. Thanks
 -------------- Original message ----------------------
From: knarf <email address hidden>
> The font problems with QT4 are not related to this issue but are caused
> by a bug in QT4 which makes it display all fonts without antialiasing
> when there is at least one font on the system for which antialiasing has
> been disabled. On Gutsy/Hardy there is at least one such font: ttf-
> arphic-uming. Either remove this font or apply the attached patch to
> /etc/fonts/conf.d/70-ttf-arphic-uming.conf.
>
>
> ** Attachment added: "Enable antialising for ttf-arphic-uming"
> http://launchpadlibrarian.net/11445975/patch-qt4-no-antialias-1.txt
>
> --
> [hardy] fonts smaller after update
> https://bugs.launchpad.net/bugs/174229
> You received this bug notification because you are a bug contact for
> firefox in ubuntu.

Iain Lane (laney) wrote :

I was seeing this too. Downgrading from fontconfig-config 2.5.0-2ubuntu2 (hardy) to 2.4.2-1.2ubuntu4 (gutsy) fixed it.

>does starting firefox with
>
>export MOZ_DISABLE_PANGO=1
>firefox

>from the command line help?

Nope.

>Do you see the same issue with firefox-3.0 in hardy?

Nope again. Looked fine there. I should note it was also broken in epiphany-browser.

Alexander Sack (asac) wrote :

On Sun, Jan 20, 2008 at 10:19:59PM -0000, jack wrote:
> please stop sending me Bug reporting. Thanks

only you can unsubscribe on your own. visit the bug and then on the
left you should see "unsubscribe"

 - Alexander

Alexander Sack (asac) wrote :

On Mon, Jan 28, 2008 at 02:33:37AM -0000, Iain Lane wrote:
> I was seeing this too. Downgrading from fontconfig-config 2.5.0-2ubuntu2
> (hardy) to 2.4.2-1.2ubuntu4 (gutsy) fixed it.
>

Thanks ...

 affects ubuntu/fontconfig
 status confirmed
 affects ubuntu/firefox
 status invalid

 - Alexander

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers