font cache broken after system upgrade (missing .dpkg-tmp files)

Bug #1651922 reported by Jeremy Bicha on 2016-12-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Undecided
Unassigned

Bug Description

I recently upgraded from 16.10 to 17.04 Alpha. I noticed that https://git.gnome.org/ was nearly unusuable with Firefox (although it displayed ok in Epiphany and Chromium). Well that website use Cantarell as its font.

I tried opening gnome-font-viewer but got no content. When I ran gnome-font-viewer from the command line, I got this output:

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/opentype/cantarell/Cantarell-Regular.otf.dpkg-tmp: No such file or directory

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/opentype/cantarell/Cantarell-Bold.otf.dpkg-tmp: No such file or directory

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/truetype/freefont/FreeSans.ttf.dpkg-tmp: No such file or directory

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/truetype/freefont/FreeSansBoldOblique.ttf.dpkg-tmp: No such file or directory

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/truetype/freefont/FreeMono.ttf.dpkg-tmp: No such file or directory

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/truetype/lao/Phetsarath_OT.ttf.dpkg-tmp: No such file or directory

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/opentype/cantarell/Cantarell-Oblique.otf.dpkg-tmp: No such file or directory

** (gnome-font-viewer): WARNING **: Can't get font name: Error opening file /usr/share/fonts/truetype/freefont/FreeMonoBoldOblique.ttf.dpkg-tmp: No such file or directory

So then I ran sudo fc-cache -f
Closed Firefox and re-opened it and git.gnome.org looks normal again. gnome-font-viewer is also working again.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: fontconfig 2.11.94-0ubuntu2
ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
Uname: Linux 4.9.0-11-generic x86_64
ApportVersion: 2.20.4-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Dec 21 21:09:46 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-08-11 (132 days ago)
InstallationMedia: Ubuntu-GNOME 16.10 "Yakkety Yak" - Alpha amd64 (20160811)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fontconfig
UpgradeStatus: Upgraded to zesty on 2016-12-20 (1 days ago)

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

I did the upgrade using 'update-manager -d'

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers