Blurry fonts after update to fontconfig 2.11.1-0ubuntu9

Bug #1566651 reported by Ivan Larionov on 2016-04-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
High
Unassigned

Bug Description

I use terminus font in gnome-terminal. After upgrade to the latest fonconfig in xenial my terminal font is blurry.

Versions which work as expected:

<= 2.11.1-0ubuntu8

Broken versions:

>= 2.11.1-0ubuntu9

Screenshots attached.

Probably related to this change https://bugs.launchpad.net/ubuntu/+source/fontconfig/+bug/1556457

Rollback to the following packages fixes this issue:

fontconfig_2.11.1-0ubuntu8_amd64.deb
fontconfig-config_2.11.1-0ubuntu8_all.deb
libfontconfig1_2.11.1-0ubuntu8_amd64.deb

Ivan Larionov (xeron-oskom) wrote :
Ivan Larionov (xeron-oskom) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fontconfig (Ubuntu):
status: New → Confirmed

I too encountered the same issue after updating fontconfig. All bitmap fonts that I have installed on my system (that is terminus and unifont) are blurred in all applications (xfce4-terminal, sublime text, monodevelop, gtk font selection dialog). Downgrading helped in my case too.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for the report.

Before the upload of fontconfig 2.11.1-0ubuntu9 we also considered to instead upgrade to the upstream version 2.11.94. It's available in this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/fontconfig-test2

Can you please test that fontconfig version, and let us know whether the problem goes away.

Changed in fontconfig (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → High
Mingye Wang (artoria2e5) wrote :

Does force-regenerating font cache using `fc-cache -f` help? The commit message in 3cd573f says:

> This may breaks the cache but not bumping in this change sets at this moment.
> please be aware if you want to try it and run fc-cache before/after to avoid
> the weird thing against it.

I didn't list the version-bump commit for cherry-picking.

Mingye Wang (artoria2e5) wrote :

Upstream HEAD git log with 'bitmap':
https://cgit.freedesktop.org/fontconfig/log/?qt=grep&q=bitmap&showmsg=1

The two 2015-05-27 commits, and the 2014-08-20 one look interesting.
I'm not sure if it's worth to try some extra cherry-picking though. Backporting is hard it seems.

By the way, upstream tagged 2.11.95 77 mins ago:
https://cgit.freedesktop.org/fontconfig/tree/README?id=13087e3

Force-regenerating font cache did not change anything, but updating fontconfig to the version in the provided ppa did fix this issue.

Changed in fontconfig (Ubuntu):
status: Incomplete → Confirmed
Martin Pitt (pitti) on 2016-04-06
Changed in fontconfig (Ubuntu):
status: Confirmed → Fix Committed
Gunnar Hjalmarsson (gunnarhj) wrote :

Since fontconfig 2.11.94 is on its way into the archive, I'd like to mention this "call for testing" message I posted to the ubuntu-devel mailing list:

https://lists.ubuntu.com/archives/ubuntu-devel/2016-April/039303.html

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fontconfig - 2.11.94-0ubuntu1

---------------
fontconfig (2.11.94-0ubuntu1) xenial; urgency=medium

  * New upstream release (LP: #1556457)
    - Fixes blurry fonts regression from previous upload (LP: #1566651)
  * d/p/0001-Revert-Bug-73291-poppler-does-not-show-fl-ligature.patch,
    d/p/0002-demilight.patch:
    - Dropped, applied in new release
  * Bump freetype build dep to 2.5.1 as per configure.ac.
  * Drop gperf build dep again, not necessary any more.

 -- Gunnar Hjalmarsson <email address hidden> Sun, 03 Apr 2016 02:54:00 +0200

Changed in fontconfig (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers