Fontconfig error output due to malformed conf file

Bug #1416768 reported by pbhj on 2015-02-01
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
fontconfig (Ubuntu)
Medium
Unassigned
Nominated for Utopic by Alberto Salvia Novella

Bug Description

Generating new string page texture 121: 256x256, total string texture memory is 393.22 KB
Generating new string page texture 122: 128x256, total string texture memory is 2.79 MB
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
Generating new string page texture 136: 2048x256, total string texture memory is 4.88 MB
Installing breakpad exception handler for appid(steamwebhelper)/version(20150130171142)
Installing breakpad exception handler for appid(steamwebhelper)/version(1422637902)

Above output is produced, eg by steam when running a game.

The fontconfig error lines can be verified with "fc-cache -v | grep -i err".

The offending section is around original lines 70, 78:

<match target="font">
  <test name="scalable" compare="eq">
    <bool>false</bool>
  </test>
  <test name="pixelsizefixupfactor" compare="not_eq">
    <double>1.0</double>
  </test>
  <edit name="matrix" mode="assign">
    <times>
      <name>matrix</name>
      <matrix>
        <name>pixelsizefixupfactor</name> <double>0</double>
        <double>0</double> <name>pixelsizefixupfactor</name>
       </matrix>
    </times>
  </edit>
  <edit name="size" mode="assign">
    <divide>
      <name>size</name>
      <name>pixelsizefixupfactor</name>
    </divide>
  </edit>
</match>

Note that the <matrix> element has 2 <name> child elements when it should only have 1. Removal of the second "<name>pixelsizefixupfactor</name>" solves the error. After this removal neither fc-cache nor steam report an "Fontconfig error:".

The documentation for fonts.conf, eg http://linux.die.net/man/5/fonts-conf, suggests that the <matrix> element should hold 4 <double> elements:

><MATRIX>
>
>This element holds the four <double> elements of an affine transformation.

But it appears not to produce an error when only 2 elements are present (and does produce an error here when there are 4, for me).

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: fontconfig-config 2.11.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.16.0-29.39-generic 3.16.7-ckt2
Uname: Linux 3.16.0-29-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.1
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Feb 1 00:46:10 2015
InstallationDate: Installed on 2012-11-02 (820 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
PackageArchitecture: all
SourcePackage: fontconfig
UpgradeStatus: Upgraded to utopic on 2015-01-28 (3 days ago)
modified.conffile..etc.fonts.conf.avail.10.scale.bitmap.fonts.conf: [modified]
mtime.conffile..etc.fonts.conf.avail.10.scale.bitmap.fonts.conf: 2015-02-01T00:30:44.308962

pbhj (pbhj) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fontconfig (Ubuntu):
status: New → Confirmed
Changed in fontconfig (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Sworddragon (sworddragon) wrote :

This ticket ( https://bugs.freedesktop.org/show_bug.cgi?id=70258 ) claims that Steam uses its own fontconfig runtime which is too old which causes this errors. Also on executing "fc-cache -v | grep -i err" nothing is shown anymore so could it be that all is fine now with that configuration file and only Steam does cause its own issue here?

pbhj (pbhj) wrote :

Running steam now on Kubuntu 15.10 I still get the lines:

"Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 77: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 77: wrong number of matrix elements
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 85: saw unknown, expected number"

in console output (repeated twice, along with other errors/warnings). The fc-cache output doesn't show any errors though as you note.

Tobin Davis (gruemaster) wrote :

This doesn't just affect Steam. I see the same error when running Cura (3D printer slicer program). See attached log.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.