evince does not display ligatures

Bug #1379375 reported by hede on 2014-10-09
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
poppler (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Iain Lane
Utopic
Undecided
Iain Lane

Bug Description

[ Description ]

Some ligatures (e.g. "fi") are not displayed in certain fonts, because there are two different naming schemes in use in the wild.

[ Fix ]

Poppler upstream fixed this by adding a lookup table to fall back to the second scheme if necessary.

[ QA ]

1. Install tex-gyre
2. Download https://bugs.launchpad.net/ubuntu/+source/fontconfig/+bug/1317599/+attachment/4213588/+files/rfa1415_15sep_lect1.pdf
3. Open the file in evince
4. Look at "Biometrics: file" on page 3

If the "fi" ligature in "file" is not displayed, you have this bug. "file" should be displayed normally after it's fixed.

[ Regression potential ]

Since this patch implements a fallback only when lookup false, there shouldn't be any problems. Still, check all existing PDFs are still displayed correctly.

[ Original report ]

While there's Bug #1325230 with the same title and the linked PDFs there are working fine here (displaying "fi" correctly) there seems to be still some bug regarding ligatures.
https://bugs.launchpad.net/ubuntu/+source/fontconfig/+bug/1325230

I have some PDFs substituting Helvetica (and others) with TeX Gyre Heros and showing no "fi" ligature. I attached a patch I derived from the patch in Bug #1325230 which is working fine. Now it uses Nimbus Sans L and the ligatures are fine.

hede (michael-heide) wrote :
hede (michael-heide) wrote :
hede (michael-heide) wrote :

To make it clearer: Bug #1379375 treats TeX Gyre Termes, while this one treats TeX Gyre Heros. (Termes vs. Heros)

The attachment "the patch only (no debdiff)" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
madbiologist (me-again) wrote :

The patch mentioned in comment #5 is included in poppler 0.28.1-1ubuntu1, which is currently available in Ubuntu 15.04 "Vivid Vervet" development version.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fontconfig (Ubuntu):
status: New → Confirmed

What is the difference between this bug and https://bugs.launchpad.net/bugs/1317599 ?

madbiologist (me-again) wrote :

I could be wrong, but it seems to me that bug 1317599 was originally filed about a document that is typeset predominately in Times/Times-Roman. After that bug was fixed by modifying fontconfig, this bug remained for documents typeset in Helvetica. See also comment #3 in this bug. The poppler patch described in comment's #5 and #6 of this bug will fix both issues.

As a result of a fixed version of poppler being available, there are comments in an upstream bug report to revert the changes in fontconfig to avoid side-effects in LaTex and other programs using the TeX Gyre fonts.

Iain Lane (laney) on 2015-01-19
Changed in fontconfig (Ubuntu Trusty):
status: New → Won't Fix
Changed in fontconfig (Ubuntu Utopic):
status: New → Won't Fix
Changed in poppler (Ubuntu):
status: New → Fix Released
Changed in poppler (Ubuntu Trusty):
status: New → In Progress
Changed in poppler (Ubuntu Utopic):
status: New → In Progress
Changed in poppler (Ubuntu Trusty):
assignee: nobody → Iain Lane (laney)
Changed in poppler (Ubuntu Utopic):
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) wrote :

The patch seemed to work for me on utopic, so I uploaded a stable update. Please check once you get a call for testing via this bug.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fontconfig - 2.11.1-0ubuntu6

---------------
fontconfig (2.11.1-0ubuntu6) vivid; urgency=medium

  * 0001-Revert-Bug-73291-poppler-does-not-show-fl-ligature.patch: Now poppler
    is fixed, revert the alias of TeX Gyre Termes to Times. (LP: #1379375)
 -- Iain Lane <email address hidden> Mon, 19 Jan 2015 13:24:12 +0000

Changed in fontconfig (Ubuntu):
status: Confirmed → Fix Released

Could someone please also fix the bug for 14.10?
For 14.10 there is only version 2.11.1-0ubuntu3 of fontconfig available.

Iain Lane (laney) wrote :

The fix is in poppler. See comment #10.

Hello hede, or anyone else affected,

Accepted poppler into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/poppler/0.24.5-2ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in poppler (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in poppler (Ubuntu Utopic):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello hede, or anyone else affected,

Accepted poppler into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/poppler/0.26.5-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

What is the exact name of the package that I have to install from utopic-proposed?

madbiologist (me-again) wrote :

According to https://launchpad.net/ubuntu/+source/poppler the package you want is libpoppler46

Updating libpoppler46 to the version in utopic-proposed didn't solve the problem for me. Do I have to restart something to see effects?

The attached file is still displayed incorrectly.

tags: added: verification-failed
removed: verification-needed

To clarify:
My version of libpoppler46 now is 0.26.5-0ubuntu2.

You need libpoppler-glib8=0.26.5-0ubuntu2 as well for evince. I suggest
just upgrading all of the poppler packages you have installed.

See the attached screenshots for before/after when upgrading
libpoppler46 & libpoppler-glib8. I didn't restart the session, just
evince.

On Wed, Jan 21, 2015 at 04:22:05PM -0000, Alexander Buchner wrote:
> To clarify:
> My version of libpoppler46 now is 0.26.5-0ubuntu2.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1379375
>
> Title:
> evince does not display ligatures
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/fontconfig/+bug/1379375/+subscriptions
>

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Yeah!
Updating libpoppler-glib8 to 0.26.5-0ubuntu2 solved my problem.

tags: added: verification-done
removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poppler - 0.24.5-2ubuntu4.2

---------------
poppler (0.24.5-2ubuntu4.2) trusty; urgency=medium

  * 0001-Map-Standard-Expert-encoding-ligatures-to-AGLFN-name.patch:
    Cherry-pick patch from upstream to fix ligature mapping with substitute
    fonts which don't use the current standard glyph names. (LP: #1379375)
 -- Iain Lane <email address hidden> Mon, 19 Jan 2015 13:18:49 +0000

Changed in poppler (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for poppler has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poppler - 0.26.5-0ubuntu2

---------------
poppler (0.26.5-0ubuntu2) utopic; urgency=medium

  * 0001-Map-Standard-Expert-encoding-ligatures-to-AGLFN-name.patch:
    Cherry-pick patch from upstream to fix ligature mapping with substitute
    fonts which don't use the current standard glyph names. (LP: #1379375)
 -- Iain Lane <email address hidden> Mon, 19 Jan 2015 12:52:43 +0000

Changed in poppler (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers