Some truetype fonts are not rendered : webdings / wingdings

Bug #1195799 reported by dino99 on 2013-06-28
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Medium
Unassigned

Bug Description

This also affect Raring : fontconfig 2.10.2.0ubuntu2

- /usr/share/fonts/truetype/msttcorefonts : webdings.ttf is displaying only rectangles instead of the symbols when clicking on it for viewing.

i've first reported against msttcorefonts:
https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1195785

but googling around that issue, a bug has been reported against fontconfig:
https://bugs.freedesktop.org/show_bug.cgi?id=58641

reading that freedesktop report, the package "pango" can be also related to that issue.
- raring: pango 1.32.5-0ubuntu1
- saucy : pango 1.32.5-5ubuntu1 (also tried the ricotz's 1.34.1-0ubuntu1 with the same result)

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: fontconfig 2.10.93-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-0.7-generic 3.10.0-rc7
Uname: Linux 3.10.0-0-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.10.2-0ubuntu3
Architecture: i386
Date: Fri Jun 28 18:07:19 2013
MarkForUpload: True
SourcePackage: fontconfig
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
tags: added: raring
dino99 (9d9) wrote :

The workaround related to wine is installing opens__.ttf (opensymbol) inside .wine/..../windows/fonts/ , as wine is not able to find the fonts installed on the host system.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fontconfig (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Using fontforge to re-encode to 'unicode full' lets these two fonts be rendered. But sadly wine still cant use them as it should do.

tags: added: trusty utopic
removed: raring
Changed in fontconfig (Ubuntu):
importance: Undecided → Medium
dino99 (9d9) wrote :

Looking back at the upstream bug https://bugs.freedesktop.org/show_bug.cgi?id=58641
it seems a fix have been found:

I believe I've now fixed this:

commit d6d5adeb7940c0d0beb86489c2a1c2ce59e5c044
Author: Behdad Esfahbod <email address hidden>
Date: Wed Jan 21 14:13:36 2015 -0800

Ubuntu Devs, please fix that issue asap.

tags: added: vivid
removed: saucy
dino99 (9d9) wrote :

Upstream have set 3 new releases since the ubuntu version:
http://www.freedesktop.org/software/fontconfig/release/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.