xpdf crashes with SIGSEGV in GlobalParams::findFontFile()

Bug #1184328 reported by Michael Mess on 2013-05-26
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fontconfig
New
Undecided
Unassigned
Poppler
New
Undecided
Unassigned
xpdf-intl
Undecided
Unassigned
fontconfig (Ubuntu)
Undecided
Unassigned
poppler (Ubuntu)
Undecided
Unassigned
xpdf (Ubuntu)
Undecided
Unassigned

Bug Description

xpdf crashes with SIGSEGV when opening the public available document DOSB_Pruefungswegweiser_Komplett_web_11_12.pdf

The document can be viewed with mupdf, but there are also issues (non-crash) with other viewers, see Bug 1111429.

xpdf crashes with SIGSEGV when opening the public available document 033_avv.pdf

That document can be viewed with mupdf and other viewers without any issues.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xpdf 3.02-21build1
ProcVersionSignature: Ubuntu 3.2.0-44.69-generic-pae 3.2.44
Uname: Linux 3.2.0-44-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.2
Architecture: i386
Date: Sun May 26 13:57:27 2013
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MarkForUpload: True
SourcePackage: xpdf
UpgradeStatus: No upgrade log present (probably fresh install)

The crash could be probably caused by two bugs:
 - One bug might be an issue with type1 fonts like in Bug 1111429 occuring in the poppler library.
 - Another bug is that the issue above is not handled well and lets xpdf crash.

Please correct me, if I am wrong.

description: updated

Could be also related to fontconfig-config 2.8.0-3ubuntu9.1 and libfontconfig1 2.8.0-3ubuntu9.1 which is not used by mupdf which has no issues displaying the document, but used by xpdf (this bug) and evince, epdfview, okular and zathura (Bug 1111429).

xpdf seems to crash also for other files which are displayed correctly with evince, epdfview, okular and zathura (Bug 1111429).

This means that the xpdf crash seems to have a different cause than the issues in Bug 1111429.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fontconfig (Ubuntu):
status: New → Confirmed
Changed in poppler (Ubuntu):
status: New → Confirmed
Changed in xpdf (Ubuntu):
status: New → Confirmed

Seems to be fixed in Ubuntu 14.04 LTS.

Florian Schlichting (fschlich) wrote :

attached PDF files display without crashing in xpdf 3.04-5, hence marking as "Fix Released"

Changed in xpdf (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers