Bad substituted fonts in Feisty

Bug #112092 reported by Jan Rathmann on 2007-05-03
2
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Medium
Arne Goetje
Declined for Feisty by Henrik Nilsen Omma
Declined for Gutsy by Henrik Nilsen Omma
Hardy
Medium
Arne Goetje

Bug Description

Binary package hint: fontconfig

Recently when I opened one PowerPoint presentation with OpenOffice Impress on Feisty, I noticed that the layout on some pages was really screwed up. I investigated a little bit and I found out that the problem lied within the font that was used to substitute Times New Roman, which is not avaible on my system.
Obviously Dejavu Sans gets chosen as a substitute, allthough it is much bigger than Times New Roman at the same font size.
In Edgy and Dapper Times New Roman was replaced with Nimbus Roman No 9 L, which looked really great, since these two fonts seem to be nearly identical.
Now I wondered why Feisty chooses a different substitute than previous Ubuntu versions and found out that one passage of one of the fontconfig files in Edgy is missing in Feisty, which is obviously responsible for the choice of the correct font replacements.
If I create a file called .fonts.conf in my home directory and insert the missing passage there, the fonts are substituted as in Edgy again.
I have added below screenshots of the presentation, the presentation itself and the certain passage of my .fonts.conf and I would suggest to include it by default again, since documents can look really ugly and screwed up otherwise.

Jan Rathmann (kaiserclaudius) wrote :
misan (misan) wrote :

Jan, you made my day, thanks for such a detailed post and suggestions.

In my case just adding the msttfcorefonts package did fix the problem as it containts TImes New Roman font.

KennoVO (kenno-xs4all) wrote :

This bug has caused severe problems for me, as I only discovered its existence 20 minutes before having to use a Feisty machine to give a presentation that was made on Edgy using a powerpoint template. I found no better solution than exporting it to PDF on an edgy machine and using that PDF file for the presentation. It was still not perfect and I yelled at people and started late. Foo, having a newer version of your operating system make a core application behave different in a way that it can't be used anymore would make even microsoft feel ashamed.

After reading the present bug description, I reverted to my edgy fonts.conf, and the problem is now solved. However, not all end-users will find this solution or be able to apply it (in time). I think it is very important for Ubuntu's PR to solve this bug.

Jan Rathmann (kaiserclaudius) wrote :

Gutsy is also affected.

Changed in fontconfig:
assignee: nobody → arnegoetje
importance: Undecided → Medium
status: New → Confirmed
Jan Rathmann (kaiserclaudius) wrote :

I have tested my use case on the current daily live build of Hardy, the fonts were substituted correctly now (also in Gutsy), so the problem seems so be fixed.

Kind regards,
Jan

Arne Goetje (arnegoetje) wrote :

Hardy: Times is substituted with Nimbus Roman No9 L, Times New Roman is provided by Times_New_Roman.ttf

Changed in fontconfig:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers