Activity log for bug #110358

Date Who What changed Old value New value Message
2007-04-26 19:51:12 Martin Stjernholm bug added bug
2008-10-07 21:07:48 Daniel T Chen fontconfig: status New Incomplete
2008-10-07 21:07:48 Daniel T Chen fontconfig: statusexplanation Is this symptom still reproducible in 8.10 beta?
2008-10-07 22:29:41 Martin Stjernholm fontconfig: status Incomplete New
2008-10-07 22:29:41 Martin Stjernholm fontconfig: statusexplanation Is this symptom still reproducible in 8.10 beta?
2009-05-18 22:45:27 xteejx fontconfig (Ubuntu): status New Incomplete
2010-01-08 23:56:30 xteejx fontconfig (Ubuntu): status Incomplete Invalid
2010-01-19 15:23:29 xteejx fontconfig (Ubuntu): importance Undecided Low
2010-01-19 15:23:29 xteejx fontconfig (Ubuntu): status Invalid Confirmed
2010-04-08 20:54:47 xteejx fontconfig (Ubuntu): importance Low Undecided
2010-04-08 20:54:47 xteejx fontconfig (Ubuntu): status Confirmed Invalid
2010-04-08 20:54:54 xteejx removed subscriber Teej
2010-10-02 21:20:13 Martin Stjernholm fontconfig (Ubuntu): status Invalid New
2010-12-28 17:27:43 xteejx fontconfig (Ubuntu): status New Incomplete
2011-04-21 04:29:29 Launchpad Janitor fontconfig (Ubuntu): status Incomplete Expired
2011-04-24 18:36:53 Martin Stjernholm fontconfig (Ubuntu): status Expired New
2011-04-25 11:02:34 xteejx bug watch added http://bugs.freedesktop.org/show_bug.cgi?id=36577
2011-04-25 11:02:34 xteejx fontconfig (Ubuntu): importance Undecided Medium
2011-04-25 11:02:34 xteejx fontconfig (Ubuntu): status New Triaged
2011-04-25 11:03:33 xteejx description Binary package hint: fontconfig If I have bitmaps fonts disabled (i.e. /etc/fonts/conf.d/70-no-bitmaps.conf exists) while running "sudo fc-cache -r -s -v" to update /var/cache/fontconfig, then I won't get the bitmap fonts in e.g. /usr/share/fonts/X11/misc even if I enable bitmap fonts in my personal ~/.fonts.conf file. Updating the local cache in ~/.fontconfig doesn't make any difference. Workaround: sudo rm /var/cache/fontconfig/* Ubuntu Feisty. Workaround: sudo rm /var/cache/fontconfig/* Binary package hint: fontconfig This bug still exists in Natty beta 2. To reiterate, here are exact steps and expected vs observed behavior: Preconditions: /etc/fonts/conf.d/70-no-bitmaps.conf is present and the fontconfig cache has been populated with "fc-cache -s". 1. Create a user-specific ~/.fonts.conf containing the following to enable bitmap fonts for the current user: <?xml version="1.0"?> <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> <fontconfig> <selectfont> <acceptfont> <pattern> <patelt name="scalable"><bool>false</bool></patelt> </pattern> </acceptfont> </selectfont> </fontconfig> 2. Optionally do "fc-cache -f" (the following results are the same both with and without this step). 3. Try "fc-list fixed". Expected: A number of entries, including "Fixed:style=Regular". Observed: No output. (A more real-world severe effect is that gnome-terminal does not use the fixed font even though configured for it.) 4. sudo rm /etc/fonts/conf.d/70-no-bitmaps.conf 5. sudo fc-cache -f -s (note that -f is necessary) 6. Now "fc-list fixed" returns a number of entries, as expected. 7. sudo ln -s /etc/fonts/conf.avail/70-no-bitmaps.conf /etc/fonts/conf.d/ 8. "fc-list fixed" still returns a number of entries, as expected due to ~/.fonts.conf. 9. rm ~/.fonts.conf 10. "fc-list fixed" returns nothing, as expected. This shows that the system setting takes effect properly in lack of a user local override. The bug is present already in step 3. I believe the remaining steps suggest that the problem is that "fc-cache -s" takes <rejectfont> rules into account when populating the global cache, which is incorrect since the fonts thus left out won't be available when a user local <acceptfont> takes precedence. Also, refreshing the user-local cache through "fc-cache -f" has no effect. Side note: This is a quite old bug by now. I've grown used to do sudo rm /etc/fonts/conf.d/70-no-bitmaps.conf after every upgrade, so it's only a mild annoyance to me personally. The full scope of the problem is probably larger though. ============================================== If I have bitmaps fonts disabled (i.e. /etc/fonts/conf.d/70-no-bitmaps.conf exists) while running "sudo fc-cache -r -s -v" to update /var/cache/fontconfig, then I won't get the bitmap fonts in e.g. /usr/share/fonts/X11/misc even if I enable bitmap fonts in my personal ~/.fonts.conf file. Updating the local cache in ~/.fontconfig doesn't make any difference. Ubuntu Feisty.
2011-04-25 11:03:47 xteejx bug task added fontconfig
2011-04-25 11:04:17 xteejx removed subscriber Teej
2011-04-25 12:49:35 Bug Watch Updater fontconfig: status Unknown Confirmed
2011-04-25 12:49:35 Bug Watch Updater fontconfig: importance Unknown Medium
2011-06-20 23:03:10 Bug Watch Updater fontconfig: status Confirmed Fix Released