Two highly-visible typos in src/fcxml.c

Bug #1037509 reported by Logan Rosen on 2012-08-16
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Fontconfig
Fix Released
Low
fontconfig (Ubuntu)
Low
Unassigned

Bug Description

There are two highly-visible typos in src/fcxml.c in severe warning messages:
* On line 1594, "not works" should be "not work"
* On line 2230, "not works" should be "not work"

One of these messages shows up currently under Ubuntu, as there are many broken
fonts that are installed by default, so these typos are very evident when
starting different programs that use fontconfig.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: fontconfig 2.10.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
Uname: Linux 3.5.0-10-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Thu Aug 16 07:11:34 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fontconfig
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

There are two highly-visible typos in src/fcxml.c in severe warning messages:
* On line 1594, "not works" should be "not work"
* On line 2230, "not works" should be "not work"

One of these messages shows up currently under Ubuntu, as there are many broken fonts that are installed by default, so these typos are very evident when starting different programs that use fontconfig.

Logan Rosen (logan) wrote :

Thanks. fixed in git.

Wow, record time. Thanks!

Changed in fontconfig:
importance: Unknown → Low
status: Unknown → Fix Released
Logan Rosen (logan) on 2012-08-16
Changed in fontconfig (Ubuntu):
status: New → Fix Committed
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fontconfig (Ubuntu):
status: New → Confirmed
Changed in fontconfig (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fontconfig - 2.10.2-0ubuntu1

---------------
fontconfig (2.10.2-0ubuntu1) raring; urgency=low

  * New upstream version:
    - includes the typo fixes for lp: #1037509
 -- Sebastien Bacher <email address hidden> Mon, 26 Nov 2012 18:21:52 +0100

Changed in fontconfig (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.