Text antialiasing is green.....

Bug #1010421 reported by Brendan_P on 2012-06-08
This bug affects 19 people
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)

Bug Description


So upgraded to Gimp 2.8 and now text antialaising is green.

Use white text on a black background to check it out.

Brendan_P (brendan-p) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed
SBKch (ssbkch) wrote :

This bug makes gimp completely unusable :( This is really urgent matter.

cagara (cagara) wrote :

Gimp was working fine for a long time,
i cannot understand why the developers have introduced this "greenish font antialiasing" bug (or do they call it feature?) in the latest release.

I have been using Gimp in a production environment and now will be forced to switch to Photoshop as Gimp became absolutely useless the moment this glitchy version came out.

Please fix it as soon as possible, this report is almost 4 months old and nothing happened yet.

Bob Johnson (f661815) wrote :

Here is a workaround for KDE (might work for others as well):

Turn off sub-pixel rendering (a.k.a. Cleartype)

Go to System Settings > Application Appearance > Fonts > Configure (Anti-aliasing)

disable sub-pixel rendering, restart gimp, problem goes away

Michael Schumacher (schumaml) wrote :

Ubuntu, please tell your fontconfig package maintainer to check https://bugzilla.gnome.org/show_bug.cgi?id=657047

Giri M. Carlos (giricarlos) wrote :

I just purged a ppa that I used to install the "infinality" font rendering,

sudo ppa-purge ppa:no1wantdthisname/ppa

This solved the bug for me on Ubuntu 13.04, so I can go on using Gimp in my works.

Mahdi (mnameghi) wrote :

I have this bug :( this is too bad!

Blaze (blaze) wrote :

15.04 - bug is still here

Gaston Martini (hgmartini) wrote :

The workaround in #5 worked for me (Kubuntu 14.04, KDE 4.14.2). I guess I'll have to remember to disable sub-pixel rendering before starting GIMP :(

Waz (paviluf) wrote :

I also have this problem on Netrunner 14 (based on Kubuntu 14.04). This workaround works perfectly :

I don't know if it's still happen on more recent version of Ubuntu, KDE, Gnome, etc... If anyone have more infos I will be glad to read them.

affects: gimp (Ubuntu) → fontconfig (Ubuntu)

It seems odd gimp doesn't override the system and user's configuration of the rgba attribute to none, e.g. by providing a /etc/gimp/2.0/fonts.conf, e.g. https://gist.github.com/csaez/5d8286b134266e51c6cb76fd218d1d5d

If they think that a user might want to produce a PNG with rgba set for a particular sub-pixel layout then they could have a UI choice on the text-tool's options, just as they currently have anti-alias to override the system and user.

Zeioth (zeioth) wrote :

Runnig Gimp using flatpak fixes this problem. So most likely the problem is some dependency related with Gimp. Official bug: https://gitlab.gnome.org/GNOME/gimp/issues/3065

Sebastien Bacher (seb128) wrote :

Did you try if it's still an issue with the Debian in recent versions of Ubuntu?

Zeioth (zeioth) wrote :

I can only confirm it is still an issue with Antergos (arch).

Brendan_P (brendan-p) wrote :

This is resolved for me. Ubuntu 18.04 running stock gnome shell session.

naught101 (naught101) wrote :

I'm still seeing this on version Version: 2.10.6-3 on Kubuntu 18.10

Sebastien Bacher (seb128) wrote :

The reporter said it's fixed for him, closing. If you have similar issues on newer version better to open a new report with the system info and a screenshot

Changed in fontconfig (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.