empathy crashed with SIGSEGV in empathy_contact_get_alias()

Bug #907916 reported by Ken VanDine
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Medium
Unassigned
folks (Ubuntu)
High
Unassigned

Bug Description

This crash occurs when trying to add a new contact and when trying to place a "New call" to a SIP number not in the contact list.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: empathy 3.3.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
Uname: Linux 3.2.0-6-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CheckboxSubmission: 1e7afd42fe45733e86839c658e18c54d
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Thu Dec 22 16:02:04 2011
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110802)
ProcCmdline: empathy
SegvAnalysis:
 Segfault happened at: 0x47e766 <empathy_contact_get_account+22>: cmp %rax,(%rdx)
 PC (0x0047e766) ok
 source "%rax" ok
 destination "(%rdx)" (0xe7894cc689f2894c) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: empathy
StacktraceTop:
 empathy_contact_get_account (contact=<optimized out>) at empathy-contact.c:978
 empathy_new_call_dialog_response (dialog=0x2302a80, response_id=-3) at empathy-new-call-dialog.c:99
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: empathy crashed with SIGSEGV in empathy_contact_get_account()
UpgradeStatus: Upgraded to precise on 2011-11-08 (44 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Revision history for this message
Ken VanDine (ken-vandine) wrote :
visibility: private → public
Revision history for this message
Ken VanDine (ken-vandine) wrote :
Changed in folks (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ken VanDine (ken-vandine)
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 empathy_contact_get_alias (contact=0x7fdd2d5e094f) at empathy-contact.c:837
 empathy_new_call_dialog_class_init (class=<optimized out>) at empathy-new-call-dialog.c:264
 empathy_new_call_dialog_class_intern_init (klass=<optimized out>) at empathy-new-call-dialog.c:51
 ?? ()

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in empathy (Ubuntu):
importance: Undecided → Medium
summary: - empathy crashed with SIGSEGV in empathy_contact_get_account()
+ empathy crashed with SIGSEGV in empathy_contact_get_alias()
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Revision history for this message
Ken VanDine (ken-vandine) wrote :

This was fixed in empathy 3.3.4 as a side effect of fixing another crasher.

Changed in empathy (Ubuntu):
status: Confirmed → Fix Released
Changed in folks (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.